×

INDI Library v1.9.8 Released (Yesterday)

Bi-monthly INDI Library released with new drivers and bug fixes.

Is INDI ready for Ubuntu 22.04?

  • Posts: 4
  • Thank you received: 0
I confirm thas kstars can be installed using official repo and with this command:
sudo apt install indi-bin kstars-bleeding

but...

kstars is still asking for som indi libraries such as indi-eqmod ans indi-asi-ccd
5 months 4 days ago #82535

Please Log in or Create an account to join the conversation.

On Kubuntu, they're building all the INDI packages. This poses a problem with the PPA and there is conflict. This is not the issue with standard Ubuntu, just Kubuntu. I changed the names of all packages so that they supercede the Kubuntu packages next we I trigger a build. Will do that for next stable INDI release.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Spartacus
5 months 4 days ago #82538

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Thanks for this information,
So what is the correct repo and correct command to have everything functionnal (with asi camera, eqmod...)

I tried this (with the nightly build repo)
sudo apt install indi-full
this answer that indi-full is not availlable
5 months 4 days ago #82549

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 40
Hi Pollet,

Try sudo apt-get install indi-bin kstars-bleeding

This will give you a range of commonly used drivers. Then open up an ekos profile and see if your equipment is listed. It is likely that in a few days or so indi-full installation will work. This works on the stable install of kstars.

Cheers
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 480SSD running KStars/Ekos/Indi under Ubuntu Mate 22.04, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

5 months 3 days ago #82561

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 40
Hi Pollet,

I have installed using indi-bin on both stable and nightly versions with no issues. EqMod or asi libraries are not being asked for when installing indi-bin with KStars bleeding on my system (Rpi4 running Ubuntu Mate). Indi-full is showing as not available as you say. EqMod drivers and ZWO cameras are available on indi-bin. Oddly the EFW filter wheel is not available in the filter dropdown in EKOS profile builder. I did find the ZWO EFW driver in aux section under ZWO with a pop up about use as remote driver (not local).
Hope this info helps :)
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 480SSD running KStars/Ekos/Indi under Ubuntu Mate 22.04, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

5 months 3 days ago #82564

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 2
<em>The following packages have unmet dependencies:
indi-aagcloudwatcher-ng : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
.
.
.
indi-talon6 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
As of 24th April[
</em>

I encountered the same issue on my Ubuntu installation.
How would someone resolve this?

On another note, Ekos/INDI are completely unusable if installed on Ubuntu from Snap, for me.
Last edit: 4 months 3 weeks ago by R Dan Nafe.
5 months 3 days ago #82576

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 2
good morning.

I also tried to install indi and kstars on xubuntu 22.04LTS but the" indi-full" package conflicts with the basic indi packages integrated into the new version of ubuntu ( libindidriver1).

So impossible to install a lot of PPA driver only the Ubuntu indi driver.
4 months 3 weeks ago #82754

Please Log in or Create an account to join the conversation.

  • Posts: 185
  • Thank you received: 27
I tried to start up one of my profiles and get a message that indi_ccd is not installed.

I can't get past the inability to install indi-asi on 22.04. I have indi-bin installed since indi-full won't install. When I try to install indi-asi, I get the following message
Not having full support for ASI ccds makes EKOS totally unusable for me.
Losmandy G11G, ZWO OAG, Celestron OAG, ASI 120MM mini guide camera, SV 80ST, TPO RC8, ASI 1600MM Pro, ASI 294MM Pro, ASI filters and filter wheel
4 months 3 weeks ago #82766

Please Log in or Create an account to join the conversation.

  • Posts: 185
  • Thank you received: 27
I went ahead and compiled INDI and INDI-ASI which took care of my immediate need.
Losmandy G11G, ZWO OAG, Celestron OAG, ASI 120MM mini guide camera, SV 80ST, TPO RC8, ASI 1600MM Pro, ASI 294MM Pro, ASI filters and filter wheel
4 months 3 weeks ago #82769

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 1
No its not working even on Xubuntu. The culprit appears to be indi-eqmod which appears to have bene built against indi 9.4

The following packages have unmet dependencies:
libindi1 : Conflicts: libindi-plugins but 1.9.4+dfsg-1 is to be installed
Conflicts: libindialignmentdriver1 but 1.9.4+dfsg-1 is to be installed
Conflicts: libindidriver1 but 1.9.4+dfsg-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The only version that everything works fine in this PPA is 21.10.
Last edit: 4 months 3 weeks ago by James Langston.
4 months 3 weeks ago #82771

Please Log in or Create an account to join the conversation.

  • Posts: 91
  • Thank you received: 18

Hi Jasem, when is the next stable INDI release scheduled for?
4 months 2 weeks ago #82826

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0

Exactly the same trouble.
I can get trough with the synscan driver but the guiding seems to be not so efficient (Not sure if it's related).

I hope that indi-full package will be available soon
4 months 2 weeks ago #82827

Please Log in or Create an account to join the conversation.

Time to create page: 2.632 seconds