×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Is INDI ready for Ubuntu 22.04?

  • Posts: 4
  • Thank you received: 0
Thanks for this information,
So what is the correct repo and correct command to have everything functionnal (with asi camera, eqmod...)

I tried this (with the nightly build repo)
sudo apt install indi-full
this answer that indi-full is not availlable
5 months 1 week ago #82549

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 40
Hi Pollet,

Try sudo apt-get install indi-bin kstars-bleeding

This will give you a range of commonly used drivers. Then open up an ekos profile and see if your equipment is listed. It is likely that in a few days or so indi-full installation will work. This works on the stable install of kstars.

Cheers
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 480SSD running KStars/Ekos/Indi under Ubuntu Mate 22.04, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

5 months 1 week ago #82561

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 40
Hi Pollet,

I have installed using indi-bin on both stable and nightly versions with no issues. EqMod or asi libraries are not being asked for when installing indi-bin with KStars bleeding on my system (Rpi4 running Ubuntu Mate). Indi-full is showing as not available as you say. EqMod drivers and ZWO cameras are available on indi-bin. Oddly the EFW filter wheel is not available in the filter dropdown in EKOS profile builder. I did find the ZWO EFW driver in aux section under ZWO with a pop up about use as remote driver (not local).
Hope this info helps :)
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 480SSD running KStars/Ekos/Indi under Ubuntu Mate 22.04, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

5 months 1 week ago #82564

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 2
<em>The following packages have unmet dependencies:
indi-aagcloudwatcher-ng : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
.
.
.
indi-talon6 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
As of 24th April[
</em>

I encountered the same issue on my Ubuntu installation.
How would someone resolve this?

On another note, Ekos/INDI are completely unusable if installed on Ubuntu from Snap, for me.
Last edit: 5 months 5 days ago by R Dan Nafe.
5 months 1 week ago #82576

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 2
good morning.

I also tried to install indi and kstars on xubuntu 22.04LTS but the" indi-full" package conflicts with the basic indi packages integrated into the new version of ubuntu ( libindidriver1).

So impossible to install a lot of PPA driver only the Ubuntu indi driver.
5 months 2 days ago #82754

Please Log in or Create an account to join the conversation.

  • Posts: 185
  • Thank you received: 27
I tried to start up one of my profiles and get a message that indi_ccd is not installed.

I can't get past the inability to install indi-asi on 22.04. I have indi-bin installed since indi-full won't install. When I try to install indi-asi, I get the following message
Not having full support for ASI ccds makes EKOS totally unusable for me.
Losmandy G11G, ZWO OAG, Celestron OAG, ASI 120MM mini guide camera, SV 80ST, TPO RC8, ASI 1600MM Pro, ASI 294MM Pro, ASI filters and filter wheel
5 months 1 day ago #82766

Please Log in or Create an account to join the conversation.

  • Posts: 185
  • Thank you received: 27
I went ahead and compiled INDI and INDI-ASI which took care of my immediate need.
Losmandy G11G, ZWO OAG, Celestron OAG, ASI 120MM mini guide camera, SV 80ST, TPO RC8, ASI 1600MM Pro, ASI 294MM Pro, ASI filters and filter wheel
5 months 1 day ago #82769

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 1
No its not working even on Xubuntu. The culprit appears to be indi-eqmod which appears to have bene built against indi 9.4

The following packages have unmet dependencies:
libindi1 : Conflicts: libindi-plugins but 1.9.4+dfsg-1 is to be installed
Conflicts: libindialignmentdriver1 but 1.9.4+dfsg-1 is to be installed
Conflicts: libindidriver1 but 1.9.4+dfsg-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The only version that everything works fine in this PPA is 21.10.
Last edit: 5 months 18 hours ago by James Langston.
5 months 19 hours ago #82771

Please Log in or Create an account to join the conversation.

  • Posts: 91
  • Thank you received: 18

Hi Jasem, when is the next stable INDI release scheduled for?
4 months 3 weeks ago #82826

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0

Exactly the same trouble.
I can get trough with the synscan driver but the guiding seems to be not so efficient (Not sure if it's related).

I hope that indi-full package will be available soon
4 months 3 weeks ago #82827

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
I have the same problem on my Ubuntu 22.04:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 indi-aagcloudwatcher-ng : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-apogee : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-armadillo-platypus : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-asi : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-astromechfoc : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-avalon : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-bresserexos2 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-celestronaux : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
                     Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-dreamfocuser : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-dsi : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-eqmod : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
              Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-ffmv : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-fishcamp : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-fli : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-gpsd : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-gpsnmea : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-maxdomeii : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-mgen : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-mi : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-nexdome : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-nightscape : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-playerone : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-shelyak : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-starbook : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-starbook-ten : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-sx : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-talon6 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
4 months 3 weeks ago #82833

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
I've just had some fun with this issue... today I have upgraded from Kubuntu 20.04 LTS to 21.10 and then on to 22.04 LTS only to find indi and kstars all screwed up and giving me grief getting it all reinstalled etc. basically the same issues everyone else is having.

my workaround....

I have just setup indi-allsky on a rpi4... part of that process was to run a script to build/install indi. The script dealt with the vast majority of the dependency issues nicely so... I ran that script on this pc... I did have to use muon package manager to enforce use of a certain version of something (can't remember the name atm but it'll be in the list of unmet dependencies) but indi installed and is indi-full I think. no drivers missing so far. happy days.

sudo apt install kstars-bleeding definitely works from the ppa with Kubuntu 22.04 :)

Having done it this way... I seem to have got it working fully. ZWO cams x2, zwo efw8, EQmod (bluetooth), pegasus upb, sqm, flip-flat and openweather all working fine. of course that is because it is currently raining. it'll crash as soon as I roll the roof off the observatory ;) ;)

hope that bit of info helps anyone else struggling to figure this one out.
4 months 3 weeks ago #82843

Please Log in or Create an account to join the conversation.

Time to create page: 1.252 seconds