×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Is INDI ready for Ubuntu 22.04?

  • Posts: 4
  • Thank you received: 0

Exactly the same trouble.
I can get trough with the synscan driver but the guiding seems to be not so efficient (Not sure if it's related).

I hope that indi-full package will be available soon
4 months 3 weeks ago #82827

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
I have the same problem on my Ubuntu 22.04:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 indi-aagcloudwatcher-ng : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-apogee : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-armadillo-platypus : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-asi : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-astromechfoc : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-avalon : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-bresserexos2 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-celestronaux : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
                     Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-dreamfocuser : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-dsi : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-eqmod : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
              Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-ffmv : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-fishcamp : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-fli : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-gpsd : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-gpsnmea : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-maxdomeii : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-mgen : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-mi : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-nexdome : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-nightscape : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-playerone : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-shelyak : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-starbook : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-starbook-ten : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-sx : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-talon6 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
4 months 3 weeks ago #82833

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
I've just had some fun with this issue... today I have upgraded from Kubuntu 20.04 LTS to 21.10 and then on to 22.04 LTS only to find indi and kstars all screwed up and giving me grief getting it all reinstalled etc. basically the same issues everyone else is having.

my workaround....

I have just setup indi-allsky on a rpi4... part of that process was to run a script to build/install indi. The script dealt with the vast majority of the dependency issues nicely so... I ran that script on this pc... I did have to use muon package manager to enforce use of a certain version of something (can't remember the name atm but it'll be in the list of unmet dependencies) but indi installed and is indi-full I think. no drivers missing so far. happy days.

sudo apt install kstars-bleeding definitely works from the ppa with Kubuntu 22.04 :)

Having done it this way... I seem to have got it working fully. ZWO cams x2, zwo efw8, EQmod (bluetooth), pegasus upb, sqm, flip-flat and openweather all working fine. of course that is because it is currently raining. it'll crash as soon as I roll the roof off the observatory ;) ;)

hope that bit of info helps anyone else struggling to figure this one out.
4 months 3 weeks ago #82843

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
libgphoto2 was the dependency that ended up sorting it I think. downgraded the version to 2.5.27
4 months 3 weeks ago #82844

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 2
Same here. Not only indi_eqmod_telescope but also indi_canon_cdd cannot be found. I tried also to compile indi lib from source but can get any improvements: compilation was fine but some pieces (i.e. indi_eqmod) were not compiled at all. Any possible work-around for my PC with ubuntu 22.04? I do not have any RPi or other stuff like that.
Thanks
EQ6-R Pro, TecnoSky 70/420, Canon 700D, Svbony 30mm guide scope, QHY 5LII guide camera
The following user(s) said Thank You: R Dan Nafe
4 months 3 weeks ago #82852

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 2
News from here. I recompile from source both indi-lib and indi-3rd-party on my Ubuntu 22.04 PC. Everything (almost) went smooth. So in this respect problem solved.
EQ6-R Pro, TecnoSky 70/420, Canon 700D, Svbony 30mm guide scope, QHY 5LII guide camera
4 months 3 weeks ago #82857

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
just some supplementary info to help guide people like me (basic linux users) with sorting this problem. After messing up my system completely (novice linux user getting ahead of himself) I reinstated it from a backup and carried on playing around and I've learned a few things...

If you are running a rpi at the mount and connecting to that remotely from your pc all is not lost, there's good news... you should be fine until you upgrade the rpi to run on 22.04. :-)

If you install gsc and then kstars bleeding from jasem's ppa on a clean install of 22.04LTS... it will install without any conflicts or dependency problems at all. This does only install indi-bin though. All you then need to do is setup a new equipment profile in kstars (on the upgraded 22.04 computer) identical to your usual one. You then select the equipment as you normally would but you'll notice that the driver names have a little icon next to them. These are the remote drivers that are running on your rpi. If your equipment is not connected to your pc... your pc does not need the drivers itself. It just needs to connect to the indi server that is connected to the equipment. This is how I'm working around the issue until I decide to poke about under the hood and inevitably break linux again....probably this afternoon ;-)

If you are connecting your equipment directly to your pc then you're gonna be doing some compiling soon if you want indi-full I'm afraid. Compiling does work as long as you've got the patience to deal with the couple of dependency issues that will arise until libindi1 is updated. These clever chaps who write all this software for us will figure out the issue pretty soon I suspect.

btw...when you clone the indi-allsky project from github there is a build_indi.sh script in the misc folder. It's a lazy way to get indi-full but it worked for me until I bricked my system.
The following user(s) said Thank You: R Dan Nafe
4 months 3 weeks ago #82859

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 1
Any news on when indi-full will be ready to install?
Indi-bin doesn’t seem to have all the drivers?

I figured all would be ready for 22.04 if I left it a month?

Or should I just go back to 21.10?

It definitely does not install properly on Ubuntu mate 22.04
It keeps saying it’s missing libindidriver1
4 months 3 weeks ago #82866

Please Log in or Create an account to join the conversation.

I believe these issue should be resolved by next INDI release where we will rebuild all packages and override the OS packages.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Davy HUBERT, Spartacus, Darren
4 months 3 weeks ago #82868

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
Hi, any idea as to when this will happen? Thanks!
4 months 2 weeks ago #82969

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
The bug is not fixed in 1.9.6
4 months 2 weeks ago #83000

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
I'm installing a new Ubuntu Mate 22.04 on a X86. This bug is still there on 1.9.6
I'm going to setup this machine before July (must).
Should I rollback to 20.4 or waiting for a patch? Or build from source?
4 months 2 weeks ago #83001

Please Log in or Create an account to join the conversation.

Time to create page: 1.001 seconds