×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Is INDI ready for Ubuntu 22.04?

  • Posts: 42
  • Thank you received: 4
I'm installing a new Ubuntu Mate 22.04 on a X86. This bug is still there on 1.9.6
I'm going to setup this machine before July (must).
Should I rollback to 20.4 or waiting for a patch? Or build from source?
4 months 1 week ago #83001

Please Log in or Create an account to join the conversation.

I'm building all the drivers now, it usually takes two days to finish since launchpad is pretty slow.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 1 week ago #83003

Please Log in or Create an account to join the conversation.

More bad news. Canonical Launchpad is having networking issues now so there is more down time :(
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 1 week ago #83007

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 3
Hi !

I used pinning and I was able to install indi-sx and indi-eqmod. Some conflicts still remains and I couldn't install indi-full but at least it works for my setup...
To do so, I created a file /etc/apt/preferences.d/indi with this content :
Package: *
Pin: release o=LP-PPA-mutlaqja
Pin-Priority: 800

Hope it helps.

Regards
Davy Hubert
Setup : 102/715 APO refractor; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser
Last edit: 4 months 1 week ago by Davy HUBERT.
4 months 1 week ago #83008

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 17
On Lubuntu 22.04, the installation gone well but Kstars is not launching at all.

From Terminal :
kstars: symbol lookup error: kstars: undefined symbol: _ZN7SSolver10Parameters14convertFromMapE4QMapI7QString8QVariantE
Last edit: 4 months 1 week ago by Euripides.
4 months 1 week ago #83037

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
Following the PPA site: launchpad.net/~mutlaqja/+archive/ubuntu/ppa
Build seem to be done, still getting this error when trying to install:
sudo apt-get install indi-full kstars-bleeding gsc
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies.
 indi-aagcloudwatcher-ng : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-apogee : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-armadillo-platypus : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-astromechfoc : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-avalon : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-bresserexos2 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-celestronaux : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
                     Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-dreamfocuser : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-dsi : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-eqmod : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
              Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-ffmv : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-fishcamp : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-gpsd : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-gpsnmea : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-maxdomeii : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-mgen : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-nexdome : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-nightscape : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-shelyak : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-starbook : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-starbook-ten : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
 indi-sx : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
 indi-talon6 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
4 months 1 week ago #83042

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1

Replied by Tim on topic Is INDI ready for Ubuntu 22.04?

Exactly the same problem and error message. Running on Ubuntu 20.04.4 LTS on IBM NUC.
Regards
Tim
4 months 1 week ago #83055

Please Log in or Create an account to join the conversation.

Just an update... just found out that Ubuntu own version is marked HIGHER than PPA version, so now have to adjust the version name so we can override them. This was never an issue before they decided to build 3rd party drivers.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Tim, George Alin Costea
4 months 1 week ago #83058

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
So is it possible to let them to build the new version for you? What is their SOP when a 3rd software release a new version?
4 months 1 week ago #83069

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
KStars 3.5.9 Stable installed on Ubuntu 22.04. All drivers available, including eqmod and ZWO ASI. Thank you!
The following user(s) said Thank You: Tim
4 months 1 week ago #83083

Please Log in or Create an account to join the conversation.

  • Posts: 297
  • Thank you received: 56
I have just installed ubuntu 22.04 on a pi4, and confirm that stars 3.5.9 stable installs perfectly from the ppa.

Good news! The performance of stars and ekos under Gnome in jammy seems noticeably more snappy than in 20.04. I haven't tried an actual imaging session yet, but this is really an improvement.
4 months 1 week ago #83090

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Confirmed....installing fine on 22.04 LTS (kubuntu) now. already had kstars and indi-bin working fine as I'm connecting to a rPi that hasn't been updated... yet... but just installed indi-full on my pc with no conflicts or dependency issues whatsoever. Now i can connect my additional equipment to my pc too. Thanks Jasem and anyone else who sorted this for us all. :-)
4 months 1 week ago #83106

Please Log in or Create an account to join the conversation.

Time to create page: 1.066 seconds