×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

ubuntu ppa repository failure

  • Posts: 5
  • Thank you received: 0
Thank you very much for your answer.
This should also work on A RPI running on ubuntu server with a mate desktop ? I found information only for raspbian OS.

Cheers,
Blaise
4 months 1 week ago #84492

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 17
@jasem tried both stable and nightly but got errors back.

At the moment even on nightly:
E: Unable to locate package indi-full
E: Unable to locate package gsc
Last edit: 4 months 6 days ago by Euripides.
4 months 6 days ago #84544

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 17
There are also a lot of discontinuities on github’s instructions to compile. A lot of missing packages.
4 months 6 days ago #84555

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 17
The following packages have unmet dependencies:
 indi-asi : Depends: libindi1 but it is not going to be installed
 indi-bin : Depends: libindi1 but it is not going to be installed
 kconfig-frontends : Depends: libncurses-dev but it is not going to be installed
                     Recommends: qtbase5-dev but it is not going to be installed
 libindi-dev : Depends: libindi1 (= 1.9.7~202207211032~ubuntu22.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Any idea will be more than appreciated..I'm going back on forth for hours
4 months 5 days ago #84575

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Actually, for me, installing from the nightly works, even if some drivers are broken ( in particular, PlayerONE cameras do not work any more, at least for me). Also, compiling from source works.

I think we have to be a little bit patient until the next stable release is out... if I'm correct, that should happen on the 29th of July.
4 months 5 days ago #84576

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 17
I hope I was lucky too, but no win for me. Tried any fix, any hint I could find for ppa or compile :-(
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gsc : Depends: gsc-data (>= 1.3~ubuntu22.04.1) but it is not going to be installed
 indi-asi : Depends: libindi1 but it is not going to be installed
 indi-bin : Depends: libindi1 but it is not going to be installed
 indi-full : Depends: libindi1 (>= 1.9) but it is not going to be installed
             Depends: indi-eqmod but it is not going to be installed
             Depends: indi-sx but it is not going to be installed
             Depends: indi-sbig but it is not going to be installed
             Depends: indi-apogee but it is not going to be installed
             Depends: indi-gphoto but it is not going to be installed
             Depends: indi-qsi but it is not going to be installed
             Depends: indi-fishcamp but it is not going to be installed
             Depends: indi-maxdomeii but it is not going to be installed
             Depends: indi-aagcloudwatcher-ng but it is not going to be installed
             Depends: indi-ffmv but it is not going to be installed
             Depends: indi-dsi but it is not going to be installed
             Depends: indi-qhy but it is not going to be installed
             Depends: indi-gpsd but it is not going to be installed
             Depends: indi-mi but it is not going to be installed
             Depends: indi-duino but it is not going to be installed
             Depends: indi-fli but it is not going to be installed
             Depends: indi-nexdome but it is not going to be installed
             Depends: indi-gpsnmea but it is not going to be installed
             Depends: indi-armadillo-platypus but it is not going to be installed
             Depends: indi-mgen but it is not going to be installed
             Depends: indi-shelyak but it is not going to be installed
             Depends: indi-nightscape but it is not going to be installed
             Depends: indi-toupbase but it is not going to be installed
             Depends: indi-atik but it is not going to be installed
             Depends: indi-avalon but it is not going to be installed
             Depends: indi-starbook but it is not going to be installed
             Depends: indi-starbook-ten but it is not going to be installed
             Depends: indi-astromechfoc but it is not going to be installed
             Depends: indi-dreamfocuser but it is not going to be installed
             Depends: indi-aok but it is not going to be installed
             Depends: indi-talon6 but it is not going to be installed
             Depends: indi-pentax but it is not going to be installed
             Depends: indi-celestronaux but it is not going to be installed
             Depends: indi-sv305 but it is not going to be installed
             Depends: indi-bresserexos2 but it is not going to be installed
             Depends: indi-playerone but it is not going to be installed
 kstars-bleeding : Depends: libkf5newstuff5 (>= 5.27.0) but it is not going to be installed
                   Depends: libkf5plotting5 (>= 4.96.0) but it is not going to be installed
                   Depends: libqt5keychain1 (>= 0.7.0) but it is not going to be installed
                   Depends: libqt5websockets5 (>= 5.6.0) but it is not going to be installed
                   Depends: libraw20 (>= 0.19.0) but it is not going to be installed
                   Depends: kstars-bleeding-data (>= 6:3.6.0+202207220622~ubuntu22.04.1) but it is not going to be installed
                   Depends: kstars-bleeding-dbg (= 6:3.6.0+202207220622~ubuntu22.04.1) but it is not going to be installed
                   Depends: kinit but it is not going to be installed
                   Depends: libindi1 but it is not going to be installed
                   Recommends: xplanet but it is not going to be installed
                   Recommends: xplanet-images but it is not going to be installed
 libindi-dev : Depends: libindi1 (= 1.9.7~202207211032~ubuntu22.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
4 months 5 days ago #84578

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
I tried to install from source, and I got issues with the camera drivers (ZWO) on both computer and RPI (ubuntu server 20.04.4 LTS 32-bit with mate desktop environment). If I wait the next release, what is the cleanest way to remove the indi package that I built from source ? Any tips ?
4 months 5 days ago #84579

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Probably is not what you want to hear... but I simply erased the whole HD and started from a fresh Ubuntu install. But maybe a make uninstall works... Or even more Hocus Pocus techniques like: stackoverflow.com/questions/1439950/what...tall-a-library-in-li
4 months 5 days ago #84580

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Did you try using the script I posted a few message above? However a prerequisite is starting from a clean system or the combination of missing dependancies and wrong version libraries can result in a huge mess... and with huge a mean really huge

P.S. However, this thread made me think that with new equipment (I just put together everything to get my feet wet with mono) comes either bad weather or a maelstrom of broken drivers with KStars ;-)
Last edit: 4 months 5 days ago by Massimo.
4 months 5 days ago #84581

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 17
I believe that this would be my last option... I'm gonna reformat the drive and try to compile from scratch.
4 months 5 days ago #84582

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
Thanks, that's exactly what I didn't want to read :lol: . But I already consider this option for a RPI it is quiet fast.
4 months 5 days ago #84583

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
No I didn't tried your option @Massimo, this is my next option.

Haha it is always like this with new equipements :lol: From my side it's not new equipement, but I drop my RPI and broke the SD card, so I have to reinstall everything. I buy a new case and integrated a SSD to boot the RPI from the SSD and improve a bit the read/write performances. I hade this idea a long time ago, unfortunatelly I don't have a lot of time and am I a novice with all this stuff.
4 months 5 days ago #84584

Please Log in or Create an account to join the conversation.

Time to create page: 1.797 seconds