×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

ubuntu 18.04: cannot upgrade indi-full (altaircam error)

1 year 3 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1238
Karma: 6
More
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31574
Looks like a package was renamed. Please try

sudo dpkg -P indi-altair

and then try again

sudo apt install indi-altaircam

dpkg will probably complain that you are trying to uninstall indi-altair because indi-full depends on it. In that case you can do

sudo dpkg -P indi-altair indi-full

and then

sudo apt install indi-full

which then also should install indi-altaircam automatically.


HTH, Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You kcobby, TomAstro

Please Log in or Create an account to join the conversation.

1 year 3 months ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 459
More
Topic Author
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31575
sudo dpkg -P indi-altair
[sudo] password for steve:
dpkg: dependency problems prevent removal of indi-altair:
indi-full depends on indi-altair.

dpkg: error processing package indi-altair (--purge):
dependency problems - not removing
Errors were encountered while processing:
indi-altair

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 year 3 months ago
TomAstro
Gold Boarder
Gold Boarder
Posts: 179
More
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31578

wvreeven wrote: Looks like a package was renamed. Please try

sudo dpkg -P indi-altair

and then try again

sudo apt install indi-altaircam

dpkg will probably complain that you are trying to uninstall indi-altair because indi-full depends on it. In that case you can do

sudo dpkg -P indi-altair indi-full

and then

sudo apt install indi-full

which then also should install indi-altaircam automatically.


HTH, Wouter


Thanks a lot and it is well done. Solved!

Please Log in or Create an account to join the conversation.

1 year 3 months ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 459
More
Topic Author
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31579
Doesn't work here:

sudo dpkg -P indi-altair indi-full
[sudo] password for steve:
(Reading database ... 258885 files and directories currently installed.)
Removing indi-full (1.7.5~201811081036~ubuntu18.04.1) ...
Removing indi-altair (0.1~201811101850~ubuntu18.04.1) ...
steve@steve-ubuntu:~$ sudo apt install indi-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
indi-full : Depends: indi-altaircam but it is not installable
E: Unable to correct problems, you have held broken packages.

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 year 3 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1238
Karma: 6
More
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31580

alacant wrote: Doesn't work here:

sudo dpkg -P indi-altair indi-full
[sudo] password for steve:
(Reading database ... 258885 files and directories currently installed.)
Removing indi-full (1.7.5~201811081036~ubuntu18.04.1) ...
Removing indi-altair (0.1~201811101850~ubuntu18.04.1) ...
steve@steve-ubuntu:~$ sudo apt install indi-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
indi-full : Depends: indi-altaircam but it is not installable
E: Unable to correct problems, you have held broken packages.


Did you do

sudo apt update

as well?

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 year 3 months ago 1 year 3 months ago by alacant.
alacant
Platinum Boarder
Platinum Boarder
Posts: 459
More
Topic Author
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31584

wvreeven wrote:

alacant wrote: Doesn't work here:

Did you do

sudo apt update

as well?


Hi. Yes. The same:
The following packages have unmet dependencies.
indi-full : Depends: indi-altaircam but it is not installable
E: Unable to correct problems, you have held broken packages.

What is indi-full and why do I need it??
Thanks


ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 year 3 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1238
Karma: 6
More
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31585
indi-full is a package that depends on all indi drivers that are available. If you don’t need the indi-altaircam package then you can happily use Ekos without indi-full. You could even uninstall it to get rid of this error. Still, it is strange that you cannot install the indi-altaircam package!

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 year 3 months ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 459
More
Topic Author
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31586
OK, thanks. As I can't now install indi-full anyway, it looks like my only option! I need indi-eqmod and indi-gphoto. Why does the nightly tell us to install them all I wonder?
Clear skies...

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 year 3 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1238
Karma: 6
More
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31587
Because the nightly doesn’t know what drivers you need for your equipment. It is much easier and safer to install them all than to instruct users to install only specific ones. Not everyone is as savvy about Linux as might be expected and simply installng them all prevents a lot of trouble and headaches.

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You knro, alacant

Please Log in or Create an account to join the conversation.

1 year 3 months ago 1 year 3 months ago by alacant.
alacant
Platinum Boarder
Platinum Boarder
Posts: 459
More
Topic Author
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31588
OK but now I can't install indi-full which brings me back to my original message:

sudo apt install indi-full
[sudo] password for steve:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
indi-full : Depends: indi-altaircam but it is not installable
E: Unable to correct problems, you have held broken packages.

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 year 3 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1238
Karma: 6
More
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31595
The command I always use to make sure that the latest updates are installed on my Debian based systems (which include Raspbian and Ubuntu) is

sudo apt-get update && sudo apt-get dist-upgrade -y

I just gave this a try on one of my KStars/Ekos systems and indi-altaircam was automatically selected for installation. The installation failed because indi-altair still was installed and after uninstalling that, the installation of indi-altaircam still did not complet successfully. First I had to do

sudo apt --fix-broken install

and thén it finally worked.

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You martingo

Please Log in or Create an account to join the conversation.

1 year 3 months ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 459
More
Topic Author
ubuntu 18.04: cannot upgrade indi-full (altaircam error) #31596
Yessssss....!

sudo apt install indi-full
[sudo] password for steve:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
indi-aagcloudwatcher indi-altaircam indi-apogee indi-armadillo-platypus
indi-dsi indi-duino indi-ffmv indi-fishcamp indi-fli indi-gpsd indi-gpsnmea
indi-maxdomeii indi-mgen indi-mi indi-nexdome indi-nexstarevo
indi-nightscape indi-qhy indi-qsi indi-sbig indi-shelyak indi-ssag indi-sx
libapogee3 libfishcamp libfli2 libqhy libqsi7 libsbig

Thanks for your patience:)

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

Time to create page: 0.295 seconds