×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

PHD Guiding Setup Connection Problem

  • Posts: 321
  • Thank you received: 19
Hey guys!

Wanted to try PHDGuiding tonight, via Remote Macbook.

Set all up like in Jasems video. But i can not get a connection at all.

The strange thing is, when i use my old profile WITHOUT PPHD, instead the internal guider, i connects flawless.

I can´t find out what the problem is...

ideas?
Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
3 years 1 week ago #31781
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 10
You've probably tried this, but I'll ask anyway: are you starting up PHD2 and connecting your mount and camera before you try to start guiding? It tripped me up that I had to select "INDI Camera" in the PHD2 device config to get it to work.
3 years 1 week ago #31783

Please Log in or Create an account to join the conversation.

  • Posts: 321
  • Thank you received: 19
I don´t know if i understand you right. I am on my Remote-Mac in my house. The Linux-Computer with all the devices connected is outside next to the mount. Now, my problem is that i am not able to start indi on my remote-machine anyway when i select phd2-guiding. So sadly its not a question atm, if phd is started at all... Or do i have to start and connect phd2 BEFORE? Cause in the video of jasem this is NIT the case...

cheers
Niki
Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
3 years 1 week ago #31784

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 10
So you are saying that, by simply changing your profile to use PHD2, you can no longer connect to your indi server? That would be odd. If you change the profile back to Internal, can you connect to the server?

I use a Mac as well to connect to my RPi at my mount. On my Mac, I start Kstars/Ekos and connect to the server. I then VNC to the Pi and start PHD2 and connect the mount and camera. Then back to the Mac to start guiding.
3 years 1 week ago #31785

Please Log in or Create an account to join the conversation.

  • Posts: 321
  • Thank you received: 19
In my screenshot you see the connection settings for the profile called phd2. They do not connect. Now if i change the guider setting to internal, it WILL connect... So thats my main problem ATM...
Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
3 years 1 week ago #31786

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 10
That's really strange. I'd normally start looking at firewall settings to see if a port was blocked, but your error shows it not connecting to the server port (7624). That port is definitely not getting blocked since you can connect with a different profile. Other than rebooting everything and trying a new profile (which you've probably already done), I'm not sure what to suggest. Have you enabled verbose logging for Ekos/INDI to see if that shows anything amiss?
3 years 1 week ago #31787

Please Log in or Create an account to join the conversation.

  • Posts: 321
  • Thank you received: 19
Didn´t check the log yet, since the system is not even starting...

Testing inernal guider settings atm, won´t stop that today.
Will test a restart of the whole system tomorrow, and a new profile too.

Sure, it´s not a big deal...

cheers
Niki
Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
3 years 1 week ago #31790

Please Log in or Create an account to join the conversation.

  • Posts: 2548
  • Thank you received: 676
That is odd. Did you check the INDI web manager to see if it is running? Or maybe try starting the profile using the web manager?
The following user(s) said Thank You: the.cakemaker
3 years 1 week ago #31806

Please Log in or Create an account to join the conversation.

  • Posts: 2548
  • Thank you received: 676
Phd2 should not prevent the INDI Server from connecting whether it is working or not
3 years 1 week ago #31807

Please Log in or Create an account to join the conversation.

  • Posts: 321
  • Thank you received: 19

Yes i never stopped ist. It was alwas on...
I even made a new Profile with the same name there. No effect...


Gesendet von iPhone mit Tapatalk
Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
3 years 1 week ago #31808

Please Log in or Create an account to join the conversation.

  • Posts: 321
  • Thank you received: 19
Restarted Linux Machine, Made new profile, samestrange behaviour... see video...
Tried the same with activated indi Web manager... Not even the Web manager does connect in this case... Very strange...



cheers
Niki
Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
3 years 1 week ago #31810

Please Log in or Create an account to join the conversation.

  • Posts: 755
  • Thank you received: 60
Hi. Remove the guider entry from your ekos profile and select the native zwo driver for your PHD2 camera choice profile. Start PHD2 before hitting connect in EKOS.
Works fine in a similar setup here. HTH.
kubuntu 20.04
700d, eq6, t7m
3 years 1 week ago #31812

Please Log in or Create an account to join the conversation.

Time to create page: 0.331 seconds