×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Re:Re:Looking for all MAC users of Kstars / Ekos

1 year 2 months ago
albeltrang73
Junior Boarder
Junior Boarder
Posts: 33
More
Re:Re:Looking for all MAC users of Kstars / Ekos #40005

rlancaste wrote: Note that this build does not contain QHY or SDR drivers. Right now each of those drivers has a serious build issue and so I disabled them from building on Mac for now.

drive.google.com/open?id=1JujfWiY__XSaLppcmFe2LzucUo6tT7df

Thank you,

Rob


Hi Rob

I'm trying to connect my hardware to Kstars on mac: iOptron CEM60, ZWO 071, Microtouch focuser and Orion SSAG.

Of those pieces, only the ZWO camera gets to connect. Being the SSAG mainly a QHY camera, is it supported now under mac? (your post is of a few months ago)

I'm getting also this message when trying to connect the mount: 2019-06-08T22:58:37: [ERROR] Failed to connect to port (/dev/cu.usbserial). Error: Port failure Error: No such file or directory. Check if device is connected to this port.

And this for the focuser: 2019-06-08T22:58:37: [ERROR] Failed to connect to port (/dev/cu.usbserial). Error: Port failure Error: No such file or directory. Check if device is connected to this port.

Nevertheless, those devices are shown on the "System information" display (from the apple menu on the top bar, so the MacOS is able to see them.

Is it needed to install an app similar to Indi server on windows?

Thank you very much,

Alfredo

CEM60
Celestron 925 EdgeHD Hyperstar
MicroTouch Focuser
ZWO ASI071MC Pro
Bogota, Colombia
www.flickr.com/photos/alfredo_beltran

Please Log in or Create an account to join the conversation.

1 year 1 month ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2265
Karma: 22
More
Re:Re:Looking for all MAC users of Kstars / Ekos #40020
No, the latest INDI server is included with KStars. I can probably look into the star shoot auto guider this summer if I can get access to one. I think some people were connecting to that with the qhy driver, but it wasn’t perfectly reliable . For the microtouch focuser, are you using the focus boss? I have used that with my Mac. It did work but required some configuration. I don’t know about an ioptron Mount . I haven’t tried that

Please Log in or Create an account to join the conversation.

1 year 1 month ago
albeltrang73
Junior Boarder
Junior Boarder
Posts: 33
More
Re:Re:Looking for all MAC users of Kstars / Ekos #40027
I chose the corresponding drivers on the equipment profile, when configuring Ekos, including the QHY driver for the SAAG.

When doing the same under Linux, all of the devices worked perfectly.

Will it be some port configuration? If so, how can be done?

Thanks,

Alfredo

CEM60
Celestron 925 EdgeHD Hyperstar
MicroTouch Focuser
ZWO ASI071MC Pro
Bogota, Colombia
www.flickr.com/photos/alfredo_beltran

Please Log in or Create an account to join the conversation.

1 year 1 month ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2265
Karma: 22
More
Re:Re:Looking for all MAC users of Kstars / Ekos #40028
One issue might be drivers for usb serial devices. Other than that it should work the same as Linux.

Please Log in or Create an account to join the conversation.

1 year 1 month ago
albeltrang73
Junior Boarder
Junior Boarder
Posts: 33
More
Re:Re:Looking for all MAC users of Kstars / Ekos #40033
Well, only the mount has a serial to USB adaptors. The focuser and the guide camera come through USB 2.0

Any ideas?

CEM60
Celestron 925 EdgeHD Hyperstar
MicroTouch Focuser
ZWO ASI071MC Pro
Bogota, Colombia
www.flickr.com/photos/alfredo_beltran

Please Log in or Create an account to join the conversation.

1 year 1 week ago
kjeanpaul
Fresh Boarder
Fresh Boarder
Posts: 3
More
Re:Re:Looking for all MAC users of Kstars / Ekos #41475
Hello everyone
are you capable of running the latest Kstars/Ekos on your mac using Mac OS X El Capitan?
I have a an excellent old mac, with SSD, lot of RAM, dedicated to Astrophotos. Since the latest release of Kstars/Ekos, it does not support anymore the 10.11 OS.
I tried to contact the developers with no success. Is there a way to recompile it for any OS older than the 10.12?

Many thanks

Celestron EdgeHD 800 and AVX, with Celestron 0.7 reducer
Zwo ASI 1600MM Pro and 174mini on Celestron DO

Please Log in or Create an account to join the conversation.

1 year 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2265
Karma: 22
More
Re:Re:Looking for all MAC users of Kstars / Ekos #41480
Hello kjeanpaul,

How did you try to contact the developers? This is the first I have heard of this. I have put in quite a bit of work porting KStars to Mac over the last several years, and I am about to build the newest DMG which should be released soon.

So as to the issue with compiling with older versions of OS X, this is not my decision. I actually have a great 10.11 machine I would love to still be able to use with KStars. In fact, that machine is the one I used to use to build kstars for Mac. The issue is that the underlying software on which KStars is build, called QT, no longer supports older versions of OS X. I do not know why they changed this, it happened very suddenly, back in January of 2019, but one day I was able to build for 10.11 and the next day I wasn't. There must have been some issue with the software that was fixed by requiring 10.12 Sierra. Now it is true that the older versions of QT should still probably build for older versions of OS X just fine, but craft, our build system, uses the latest version of QT. And there were some bugs in older versions of QT (there are always bugs in software though) I could probably look into some way to make craft use an older version of QT, but that would require keeping multiple copies of qt on my machine, plus keeping QT in an outdated state will eventually cause problems. But I could probably look into it.

Please Log in or Create an account to join the conversation.

1 year 1 week ago 1 year 1 week ago by kjeanpaul.
kjeanpaul
Fresh Boarder
Fresh Boarder
Posts: 3
More
Re:Re:Looking for all MAC users of Kstars / Ekos #41491
Hello rlancaste

thank you for your response, I think I tried on this forum itself however do not recall exactly how as it was 3 to 4 weeks ago. I am glad you found my message and thank you for response.

So I understand this is due to QT, that is unfortunate as, like you, my ancient macbook from 2008 is still very fast with good SSD and lot of RAM. This has been my perfect companion for astrophotos for long now, and most of it, I do not care to expose it to long cold night :) macbook computers were build like a rock at that time!

Yes if you find ways it would be excellent, I have read you have introduced new features in the latest release I will need in future, like the support of new focuser from Celestron for instance, It will be my pleasure helping you testing if you need me,

Your Kstars/Ekos is as per me by far the best software available on mac os!

Please Log in or Create an account to join the conversation.

1 year 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2265
Karma: 22
More
Re:Re:Looking for all MAC users of Kstars / Ekos #41499
Awesome! Yes if an older version still works for you on the older system, that's really great. I had refined my script and was pretty pleased with it up until 2.9.8/3.0.0.

It really threw a monkey wrench into the works back in January when I tried to build 3.1.0 and suddenly QT refused to build on my old laptop since thats how I did everything. I had to quickly write a whole new script. I had been planning to change to a new build method using craft and had been working on it already, but I wasn't ready for the old build method to suddenly stop working one day, and didn't have everything ready to go yet. So the first couple of builds with the new build script had some issues, but after a month or two, it got back to the same stability as the old script. Unfortunately, this did mean leaving 10.11 behind.

No guarantees that I will be able to get a 10.11 build to work again, but I can see what I can find out about getting an older QT. Because the new build script should actually work on an older Mac, if in fact we have a QT version that works with it.

Please Log in or Create an account to join the conversation.

11 months 1 day ago
kjeanpaul
Fresh Boarder
Fresh Boarder
Posts: 3
More
Re:Re:Looking for all MAC users of Kstars / Ekos #43028
Hello Again :)

How do you do?
Some inputs for you that can eventually help:

The versions I am using on my "old" mac running ElCapitan:
KStars v3.0.0, Build 2018-12-21T06:07:37z
KD+ FW 5.52.0
Q+ 5.11.3 (built agains 5.11.2)
Cocoa windowing sys

And QT player v19.4 (855)

Hope this helps.
Any findings on your side?
Regards, Jean-Paul

Please Log in or Create an account to join the conversation.

11 months 8 hours ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2265
Karma: 22
More
Re:Re:Looking for all MAC users of Kstars / Ekos #43069
Sorry, I haven't had time to look into this because I have had too many other things to do. I've been working on my Raspberry Pi and other SBC setup scripts, I've been working on improving the Astrometry.net configuration files/setup tools for Mac/Linux in KStars, and I've been working on a new app that I wrote for Macs and for Linux called INDI Web Manager App that sets up and runs an INDI Server and INDI Web Manager for any clients like KStars, Caries Du Ciel, PHD2, etc. And now it is fall and I have to go back to work again teaching students. . .

Another thought I recently had is that there is no reason we couldn't use our old Macs that don't support Sierra and newer MacOS. We could install Kubuntu or something similar on them and they would run KStars, INDI, INDI Web Manager App, and everything else with no problem. And they might even be faster since its a pretty lightweight OS.

But if we do want to use an old Mac running El Capitan for KStars with the new scripts and versions of KStars/INDI etc, then I think the main thing that would need to be solved would be to get craft to build and run off an older version of QT. Since it is actually QT that is causing the issue because they just decided one day that they were not going to support anything less than Mac OS 10.12 anymore. If you can tell craft to use a certain QT version, then you could specify that version for QT and then I would think everything would work fine, since actually everything we code in KStars is coded to work on older versions of QT than the one we are using. But I think the version you pick is actually pretty important, since I recall there were some serious issues with bugs on Mac for one or two versions of QT. I think some things broke somewhere around 5.7 and then they didn't fix it until about 5.10 (but I am just going off memory right now, so I might be wrong). Also, it should be a version after QT Visualizations was released so that the 3D star profile works, but prior to them deciding that they wouldn't support anything older than Sierra.

That all being said, I just got done building KStars 3.3.5 which should be released today!

Thanks,

Rob

Please Log in or Create an account to join the conversation.

Time to create page: 0.571 seconds