×

INDI Library v1.7.8 Released (11 May 2019)

Mid year release of INDI Library v1.7.8 comes with a few drivers and improvements to to existing drivers.

Slow Preview Speed and Poor Network Stability Issues SOLVED Using Ethernet ??

  • Posts: 47
  • Thank you received: 15

Slow Preview Speed and Poor Network Stability Issues SOLVED Using Ethernet ?? was created by werper

I may have finally figured out the solution for one of the last big hurdles I've been having with SM/Kstars/Ekos system: VERY slow image preview speeds and networking instability. Solution: I had to go old school - Ethernet.

Background:
I run two RPI 3B's distributed - one for guide cam and mount control, the second PI for the main camera, a Canon T3i/600D. These are networked to my laptop using a dedicated router (no Internet). I had been using WiFi to connect everything but was having LOTS of issues with the SM Indi Servers losing their network connection and Ekos crashing as a result, poor guiding, and to me, the worst was terribly slow speeds previewing images as they're shot during a sequence - 45-60 seconds between each shot of a sequence as the preview is downloaded to my laptop. Combine all this and the system was/is unusable. VERY disappointing and frustrating.

BUT, I know this system can work and Ekos has features/functions I like MUCH better than anything else out there. So, determined to figure this out and after TONS (more) of research, I have come to the conclusion the base-cause for my problems must be poor network performance, I had simply run out of configuration settings to tweak in Ekos. After some digging, sure enough, I learned the built-in WiFi on a RPI 3B is not up to this job - even when using two PIs. Given my to-date overall lack of success using SM/Kstars/Ekos, I did not want to throw ANY more money into it by buying a USB WiFi w/antenna or USB ethernet adapter. That only left the built in Ethernet to experiment with. Why not? Let's give it a try. After wiring it all up and updating configuration files, I got the system up and running 100% for "bench" testing.

So far, I see an immediate HUGE performance improvement!! The entire system is much quicker to respond. It's too early to say conclusively that I solved all my problems at last, until I get under the stars and give her a real test, but it's never ran this well in the six months I've been working with SM/Kstars/Ekos. Not one crash or network drop yet, much more stable. The best part though is image previewing now works well. REALLY well!! Instead of a shot once a minute, now it's about one every 7 seconds - a WORLD of difference and VERY usable whereas before, I simply could not live with the long delay between each and every shot. Live video is just shy of an instantaneous, live stream now too, instead of choppy and delayed.

Here's how I now have my system set up: Two RPIs, each wired via 100baseT Ethernet directly to a dedicated router that is not on the Internet. Each RPI is running Stellarmate OS as an INDI server. A Win7 laptop uses Wifi (802.11n) to connect to the router and runs Kstars/Ekos which seamlessly controls both SM PIs as if they were one unit.

I don't mind saying it's been a real battle getting SM/Kstars/Ekos to work. I've been working with it for over six months with not one astro-photo to show for it. There's been more than one time I was about to say: "screw it, APT and SGP work fine". But I love a challenge and believe in the future and potential of this project. Ekos is POWERFUL. If this is my last big hurdle and I can finally start using it instead of always going back to APT (which I like VERY much BTW), the six+ months of research, learning, trial and error, learning more, researching more, building, and endless tweaking/configuring, will be worth it.

Here's hoping for some clear skies soon, I'm psyched!!
Celestron C8-N
iOptron iEQ45 Pro
Two Stellarmate Rasberry Pis - Distributed
Dedicated WiFi Network
Canon T3i DSLR - Primary Cam
QHY5L-II-M - Guide Cam
Astromania 60 Guide Scope
The following user(s) said Thank You: Herrhausen
Last edit: 1 week 2 days ago by werper.
1 week 4 days ago #39055

Please Log in or Create an account to join the conversation.

Time to create page: 0.279 seconds