×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

FlipFlat not working with Canon dslr

  • Posts: 10
  • Thank you received: 1

FlipFlat not working with Canon dslr was created by p1cass0

Hi all,

I am trying to use FlipFlat driver with a Canon dslr but i'm having problems. Everything works OK when using the CCD simulator with FlipFlat as you can see from this log extract...

[2019-05-24T17:47:03.541 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Job requires 1.000-second Red images, has 0/1 frames captured and will be processed."
[2019-05-24T17:47:03.541 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Parking dust cap..."
[2019-05-24T17:47:03.606 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>C000> "
[2019-05-24T17:47:03.668 GMT Daylight Time INFO ][ org.kde.kstars.indi] - CCD Simulator : "[INFO] Upload settings set to local only. "
[2019-05-24T17:47:03.668 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - < CCD Simulator >: < CCD_FILE_PATH >
[2019-05-24T17:47:03.672 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*C99000> "
[2019-05-24T17:47:04.409 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:47:04.466 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:47:04.467 GMT Daylight Time INFO ][ org.kde.kstars.indi] - Flip Flat : "[INFO] Cover closed. "
[2019-05-24T17:47:04.543 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Dust cap parked."
[2019-05-24T17:47:04.543 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Capturing 1.000-second Red image..."
[

...but when using the dslr with FlipFlat its as if the FlipFlat isn't there. This is the log ...

[2019-05-24T17:36:44.062 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Job requires 1.000-second images, has 0/1 frames captured and will be processed."
[2019-05-24T17:36:44.237 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:44.297 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:45.257 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:45.312 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:46.277 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:46.335 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:46.676 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Capturing 1.000-second image..."
[2019-05-24T17:36:46.721 GMT Daylight Time INFO ][ org.kde.kstars.indi] - Canon DSLR EOS 450D (PTP mode) : "[WARNING] The CCD does not have a shutter. Cover the camera in order to take a dark frame. "
[2019-05-24T17:36:46.781 GMT Daylight Time INFO ][ org.kde.kstars.indi] - Canon DSLR EOS 450D (PTP mode) : "[INFO] Starting 1 seconds exposure. "
[2019-05-24T17:36:47.291 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:47.346 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:48.311 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:48.366 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:49.331 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:49.386 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:50.351 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD <>S000> "
[2019-05-24T17:36:50.406 GMT Daylight Time DEBG ][ org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES <*S99001> "
[2019-05-24T17:36:51.351 GMT Daylight Time INFO ][ org.kde.kstars.indi] - Canon DSLR EOS 450D (PTP mode) : "[INFO] Image saved to /share/astro/240519/Dark/Dark_001.fits "
[2019-05-24T17:36:51.416 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Remote image saved to /share/astro/240519/Dark/Dark_001.fits"
[2019-05-24T17:36:51.416 GMT Daylight Time INFO ][ org.kde.kstars.ekos.capture] - "Received image 1 out of 1."

Should FlipFlat work with a dslr ? Is there some configuration setting I'm missing?

Any help appreciated.

Ray.
2 months 3 weeks ago #39409

Please Log in or Create an account to join the conversation.

Replied by knro on topic FlipFlat not working with Canon dslr

Hmmm, I'll check.. the "calibration" button has the same configuration between CCD Simulator and the DSLR?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 3 weeks ago #39412

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1

Replied by p1cass0 on topic FlipFlat not working with Canon dslr

Thanks Jasem,
Could you also clarify for me too. In Calibration it is only possible to select 'Dust Cover with External Flat Light' OR 'Wall' location. When using the Wall option it only moves the mount but doesn't control the Flap or Light as the External Flap Light option does. Could it be possible to select BOTH these option not just one? I can work around it by taking a dummy flat frame with Wall option selected to move the mount then follow with the real Flats with the External Flap Light selected but it would be nice to do it in one step.

I'm relatively new to ekos/indi but loving it.
2 months 3 weeks ago #39415

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1

Replied by p1cass0 on topic FlipFlat not working with Canon dslr

Hi Jasem,

An update on this.

I have been able to get my DSLR working with FlipFlat by adding 'CCD_HAS_SHUTTER' to the 'SetCCDCapability' function of gphoto.cpp.

I have also detected another issue that affects both the CCD Simulator as well as other CCD's.

When taking a Light frame from a starting position of Shutter closed all works as expected.
When taking a Flat frame (external light source) from a starting position of Shutter closed
Kstars/ekos commands the shutter to open correctly but doesn't wait for the Shutter to open, it
immediately takes the frame while the shutter is still opening. I was able to get this working
correctly by making the follow change to capture.cpp in Kstars. Hope this is useful to you.

Change from...
// Wait until cap is parked
if (calibrationStage == CAL_DUSTCAP_UNPARKING)
{
if (dustCap->isParked() == true)
return IPS_BUSY;
else
{
calibrationStage = CAL_DUSTCAP_UNPARKED;
appendLogText(i18n("Dust cap unparked."));
}
}


..to...

// Wait until cap is unparked <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
if (calibrationStage == CAL_DUSTCAP_UNPARKING)
{
if (dustCap->isUnParked() == false) <<<<<<<<<<<<<<<<<<<<<<<
return IPS_BUSY;
else
{
calibrationStage = CAL_DUSTCAP_UNPARKED;
appendLogText(i18n("Dust cap unparked."));
}
}
2 months 2 weeks ago #39799

Please Log in or Create an account to join the conversation.

Replied by knro on topic FlipFlat not working with Canon dslr

No need to change gphoto_ccd.cpp, I just submitted a fix to KStars which should hopefully be available later in the nightly build that should fix this issue.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 2 weeks ago #39895

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1

Replied by p1cass0 on topic FlipFlat not working with Canon dslr

Hi Jasem,

This is a paste from a previous comment I posted a while ago . Just wondering if this bug will be corrected at some point? I can correct the issue under Linux by making the changes to the source mentioned but I prefer to use Kstars under Windows and I don't have the build environment to recompile under windows.


When taking a Light frame from a starting position of Shutter closed all works as expected.
When taking a Flat frame (external light source) from a starting position of Shutter closed
Kstars/ekos commands the shutter to open correctly but doesn't wait for the Shutter to open, it
immediately takes the frame while the shutter is still opening. I was able to get this working
correctly by making the follow change to capture.cpp in Kstars. Hope this is useful to you.

Change from...
// Wait until cap is parked
if (calibrationStage == CAL_DUSTCAP_UNPARKING)
{
if (dustCap->isParked() == true)
return IPS_BUSY;
else
{
calibrationStage = CAL_DUSTCAP_UNPARKED;
appendLogText(i18n("Dust cap unparked."));
}
}


..to...

// Wait until cap is unparked <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
if (calibrationStage == CAL_DUSTCAP_UNPARKING)
{
if (dustCap->isUnParked() == false) <<<<<<<<<<<<<<<<<<<<<<<
return IPS_BUSY;
else
{
calibrationStage = CAL_DUSTCAP_UNPARKED;
appendLogText(i18n("Dust cap unparked."));
}
}


Tanks.
4 weeks 1 day ago #41286

Please Log in or Create an account to join the conversation.

Replied by knro on topic FlipFlat not working with Canon dslr

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 weeks 1 day ago #41288

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1

Replied by p1cass0 on topic FlipFlat not working with Canon dslr

Thanks Jasem,
I'm running the latest viersion 3.3.2 on edu.kde.org/kstars/#download . Guess I just need to wait until v3.3.3 is available.

Much appreciated.

Ray.
4 weeks 1 day ago #41289

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1

Replied by p1cass0 on topic FlipFlat not working with Canon dslr

Hi Jasem,

I've tested the nightly build of Kstars 3.3.3 dated 23rd July but the issue is still there. I suspect you may have changed the wrong occurrence of code as the lines I changed are still there unchanged in capture.cpp at lines 5194 and 5197

// Wait until cap is unparked <<<<<<<< line 5194 changed by me from // Wait until cap is parked
if (calibrationStage == CAL_DUSTCAP_UNPARKING)
{
if (dustCap->isUnParked() == false) <<<<<<<< line 5197 changed by me from if (dustCap->isParked() == true)
return IPS_BUSY;
else
{
calibrationStage = CAL_DUSTCAP_UNPARKED;
appendLogText(i18n("Dust cap unparked."));
}
}

This is the output from Kstars. See the times from uparking Dust Cap to Dust Cap unparked - one second.

2019-07-23T23:24:20 Received image 1 out of 1.
2019-07-23T23:24:20 Remote image saved to /share/trash/Flat/Flat_017.fits
2019-07-23T23:24:15 Capturing 1.000-second image...
2019-07-23T23:24:15 Dust cap unparked.
2019-07-23T23:24:14 UnParking dust cap...

It actually takes 20 second as you can see from The FlipFlat output.

2019-07-23T23:24:34: [INFO] Cover open.
2019-07-23T23:22:47: [INFO] Device configuration applied.
2019-07-23T23:22:47: [INFO] Loading device configuration...

Ray
4 weeks 9 hours ago #41314

Please Log in or Create an account to join the conversation.

Time to create page: 0.661 seconds