×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

AstroPi3 Scripts revised

  • Posts: 2787
  • Thank you received: 784
It is possible there was a change in KStars. My script wouldn’t change it, but it does install the latest KStars

Are you running another INDI server such as with INDI Web Manager App, INDI web manager, or as a service?

You can always try quitting those. Or from the command line killall indiserver
3 years 1 month ago #42148

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Replied by AstroNerd on topic AstroPi3 Scripts revised

No, not running any other...and have made sure, but error still comes up, also have run update on older pi3 and Kstars is fine..so not sure, but was fine before I ran the script again.. :(
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
3 years 1 month ago #42149

Please Log in or Create an account to join the conversation.

  • Posts: 2787
  • Thank you received: 784
Did you try

killall indiserver?
3 years 1 month ago #42150

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Replied by AstroNerd on topic AstroPi3 Scripts revised

Yep, no other running..
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
3 years 1 month ago #42151

Please Log in or Create an account to join the conversation.

  • Posts: 1273
  • Thank you received: 221

Replied by Andrew on topic AstroPi3 Scripts revised

I get no IP address when I connect the Pi to my desktop. How do I set up the network manager to automatically connect to the LAN?

Ok I solved it. I had to remove the ethernet configuration from the network manager. It then automatically connected to my PC and assigned it an IP address in the correct range.
I re-ran the script and used that IP address. All is well now.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
Last edit: 3 years 1 month ago by Andrew.
3 years 1 month ago #42154

Please Log in or Create an account to join the conversation.

  • Posts: 2787
  • Thank you received: 784

I'm not sure I understand. You are connecting the PI to your desktop or laptop computer with an ethernet cable? Are you away from the network in a field, or are you trying to connect it to your router with ethernet? I'm not sure what you are trying to do here.

In my script, I set it up to respond to a plugged in Ethernet cable by doing 2 things. 1. Connect to your LAN and get an IP address via DHCP if you plug in an ethernet cable connected to your router. This "Connection" is called Wired DHCP Ethernet and it tries that first. 2. If the first one fails, to switch to a network with a static IP address for connecting directly to a laptop when there is no internet in the middle of an observing field. That is the "Link Local" connection.
3 years 1 month ago #42156

Please Log in or Create an account to join the conversation.

  • Posts: 2787
  • Thank you received: 784

I will try rebuilding kstars on my pi and see if I get the same error.
3 years 1 month ago #42157

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Replied by AstroNerd on topic AstroPi3 Scripts revised


I think you might as a few people have up to yet, nothing to do with your script I might add.. :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
3 years 1 month ago #42159

Please Log in or Create an account to join the conversation.

  • Posts: 2787
  • Thank you received: 784
No the error doesn’t have anything to do with my script but if there is some sort of KStars error, and it is revealed this way, we should see what it is.
3 years 1 month ago #42160

Please Log in or Create an account to join the conversation.

  • Posts: 1273
  • Thank you received: 221

Replied by Andrew on topic AstroPi3 Scripts revised

RLANCASTE:
I have resolved it, see edited comment above. But so you understand. No, I do not use a PC in the field. I have a portable display and keyboard directly connected to the Pi.
At home though, when I am setting things up and messing around on the Pi I like to use VNC connection to the pi from my PC via an ethernet cable connected to one of the 2 network ports my desktop has. So it doesn't even go through my home network router, but the internet is shared through the PC.
I think my issue was that the first time I ran the script I stated Yes to making a static IP, but then wasn't sure when to enter at the time. So I continued without entering the any IP. It seemed to recognise it was invalid and moved on with the process.
It did create the 'Wired DHCP Ethernet' connection, but not the second Link Local Ethernet when I did that.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
Last edit: 3 years 1 month ago by Andrew.
3 years 1 month ago #42161

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Replied by AstroNerd on topic AstroPi3 Scripts revised


Clever bloke like you might, but I ain’t gotta clue what I’m looking for.. :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
3 years 1 month ago #42162

Please Log in or Create an account to join the conversation.

  • Posts: 2787
  • Thank you received: 784

I just did a complete rebuild with the latest git. I can't reproduce the error you reported with KStars. The internal simulator started and worked fine and then I tried with INDIWeb Manager app "remotely" and it worked fine too. I don't understand why you would get a message that an INDIServer is running when one clearly is not. We can ask Jasem.
3 years 1 month ago #42165

Please Log in or Create an account to join the conversation.

Time to create page: 0.371 seconds