×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

AstroPi3 Scripts revised

8 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45413
Rob,
Many Thanks for the reply I've just tried ls /usr/bin/indi* all the drivers for the Mounts, Focusers, Filter Wheels and auxiliaries show up there, but there are no Camera drivers visible.

ls /usr/share/indi there is only following xml files showing, drivers.xml indi_tcfs_sk.xml

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

8 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45414
Rob,
The build seemed to go OK it didn't hang or crash in any way it appeared to run just like the previous successful setups I've done from the earlier versions of the script, I have also tried running the script on the light version of Raspbian Buster with the same result.

I have also re run on a Pi 4 one of the previous scripts from a backup I have and it has installed fine, all the cameras are fully installed

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

8 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45415
That sounds like either it didn't install the 3rd Party drivers, or they installed someplace different.

Can you try
ls /usr/local/bin/indi*
ls /usr/local/share/indi

Please Log in or Create an account to join the conversation.

8 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45416
Or better yet, instead of looking for them, look at the contents of the file

/home/pi/AstroRoot/indi-build/3rdparty-Drivers/install_manifest.txt

See if they installed, and if so, where?

Please Log in or Create an account to join the conversation.

8 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45417
Or alternately, try these commands:

cd ~/AstroRoot/indi-build/3rdparty-Drivers
sudo make install

And see if they install or if there is an issue.

Please Log in or Create an account to join the conversation.

8 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45418
Rob,
I've tried that for you here is the result

pi@raspberrypi:~/AstroRoot/indi-build/3rdparty-Drivers $ sudo make install
make: *** No rule to make target 'install'. Stop.

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

8 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45420
And if you do
ls ~/AstroRoot/indi-build/3rdparty-Drivers

Is that directory empty?

Please Log in or Create an account to join the conversation.

8 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45421
Rob,
I've just looked in the indi-build / 3rdparty-drivers and there's no manifest.txt screen dump attached

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80
Attachments:

Please Log in or Create an account to join the conversation.

8 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45422
well clearly the directory is not empty

we could try to delete everything from that folder, rebuild those drivers, and see what happens:


rm -r ~/AstroRoot/indi-build/3rdparty-Drivers/*

cd ~/AstroRoot/indi-build/3rdparty-Drivers
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -DWITH_FXLOAD=1 ~/AstroRoot/indi-3rdparty
make -j $(expr $(nproc) + 2)
sudo make install

Let me know where a problem occurs.

Please Log in or Create an account to join the conversation.

8 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45423
Rob,
see below the error message from the cmake command


CMake Error at CMakeLists.txt:364 (add_subdirectory):
add_subdirectory given source "asi-common" which is not an existing
directory.


CMake Error at cmake_modules/FindASI.cmake:68 (message):
ASI not found. Please install libasi www.indilib.org
Call Stack (most recent call first):
indi-asi/CMakeLists.txt:8 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/pi/AstroRoot/indi-build/3rdparty-Drivers/CMakeFiles/CMakeOutput.log".
See also "/home/pi/AstroRoot/indi-build/3rdparty-Drivers/CMakeFiles/CMakeError.log".

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

8 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Topic Author
AstroPi3 Scripts revised #45424
Ok, so that is the answer. Let me check that out.
The following user(s) said Thank You ar2star2

Please Log in or Create an account to join the conversation.

8 months 1 week ago
Kaczorek
Moderator
Moderator
Posts: 901
Karma: 6
More
AstroPi3 Scripts revised #45426
asi-common was removed from source tree yesterday. It is replaces by libasi which is required by indi-asi.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

Time to create page: 0.855 seconds