×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

AstroPi3 Scripts revised

3 months 2 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45423
Rob,
see below the error message from the cmake command


CMake Error at CMakeLists.txt:364 (add_subdirectory):
add_subdirectory given source "asi-common" which is not an existing
directory.


CMake Error at cmake_modules/FindASI.cmake:68 (message):
ASI not found. Please install libasi www.indilib.org
Call Stack (most recent call first):
indi-asi/CMakeLists.txt:8 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/pi/AstroRoot/indi-build/3rdparty-Drivers/CMakeFiles/CMakeOutput.log".
See also "/home/pi/AstroRoot/indi-build/3rdparty-Drivers/CMakeFiles/CMakeError.log".

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2112
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45424
Ok, so that is the answer. Let me check that out.
The following user(s) said Thank You ar2star2

Please Log in or Create an account to join the conversation.

3 months 1 week ago
Kaczorek
Moderator
Moderator
Posts: 785
Karma: 6
More
AstroPi3 Scripts revised #45426
asi-common was removed from source tree yesterday. It is replaces by libasi which is required by indi-asi.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

3 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2112
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45427
Yep, I found that out. I am submitting a pull request for a revision to CmakeLists in 3rd party. it's almost ready

Please Log in or Create an account to join the conversation.

3 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2112
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45428
Ok I put in a pull request to fix INDI 3rdParty cmakelists.

github.com/indilib/indi-3rdparty/pull/18

Depending on when Jasem or others can get to it, it might be fixed by tomorrow.

Thanks,

Rob

Please Log in or Create an account to join the conversation.

3 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2112
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45435
Ok my pull request just got merged. Please test it to see if this fixed the build problem
The following user(s) said Thank You ar2star2

Please Log in or Create an account to join the conversation.

3 months 1 week ago
Avocette
Expert Boarder
Expert Boarder
Posts: 89
More
AstroPi3 Scripts revised #45437

rlancaste wrote: Ok my pull request just got merged. Please test it to see if this fixed the build problem

Hi Rob,
Morning here so I reran your script on the Pi4. The Drivers for the cameras and GPSD have all returned. However there is another more serious problem now. Every time I try to launch Ekos with any equipment profile, KStars crashes. The Indiserver is left running, apparently, so waking up KStars brings up a message about closing down the Indiserver before starting up Ekos, but everything just crashes when you do this.

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to AstroPi3 Script
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

3 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45438
Rob,
Same here.
Re-ran the script and all the cameras display in the drop down menu and can be selected, but trying to start Ekos results in a crash and Indiserver is left still running in the background. Restarting KStars allows you to set up Ekos again, but when trying to start Ekos there is a warning about Indiserver running and it asks if you wish to close, as soon as you try to close the Indiserver it crashes KStars again.

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

3 months 1 week ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45439
Rob,
Success I’ve just ran the script on a fresh install of Raspbian Buster and it’s all working fine, all cameras, mounts, focuses, filter wheels are there & no crashing on starting Ekos.

Well done, many thanks

Alan

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

3 months 1 week ago 3 months 1 week ago by Avocette.
Avocette
Expert Boarder
Expert Boarder
Posts: 89
More
AstroPi3 Scripts revised #45442
New installation is working better, thanks, certainly in the main elements that are easy to test indoors in foul weather!
I have had a better chance to look more carefully at some hiccups that have confused me in the past (in the dark).
I will post some issues I have identified under the appropriate headings.

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to AstroPi3 Script
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

3 months 1 week ago
mpfjr
Senior Boarder
Senior Boarder
Posts: 67
More
AstroPi3 Scripts revised #45465
Had an error in the terminal that I saw that I wanted to make sure you knew about. Didn't seem to bother anything but hey, an error is an error.

Raspbian for pi4

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~ Checking items that will require your input while running the script, so you don't get asked so many questions later. Note that some installations later (VNC, samba in particular) may still require your input later on, this is out of my control.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ls: cannot access '/etc/NetworkManager/system-connections/': No such file or directory

Please Log in or Create an account to join the conversation.

3 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2112
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45466
Thanks! That one is just fine though. That file shouldn't exist yet if this is a fresh raspbian system. The check for that particular folder will only be needed later if you run the script again and the file does exist.

Please Log in or Create an account to join the conversation.

Time to create page: 0.702 seconds