×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

AstroPi3 Scripts revised

1 month 3 days ago
Avocette
Senior Boarder
Senior Boarder
Posts: 69
More
AstroPi3 Scripts revised #45437

rlancaste wrote: Ok my pull request just got merged. Please test it to see if this fixed the build problem

Hi Rob,
Morning here so I reran your script on the Pi4. The Drivers for the cameras and GPSD have all returned. However there is another more serious problem now. Every time I try to launch Ekos with any equipment profile, KStars crashes. The Indiserver is left running, apparently, so waking up KStars brings up a message about closing down the Indiserver before starting up Ekos, but everything just crashes when you do this.

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to AstroPi3 Script
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

1 month 3 days ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 32
More
AstroPi3 Scripts revised #45438
Rob,
Same here.
Re-ran the script and all the cameras display in the drop down menu and can be selected, but trying to start Ekos results in a crash and Indiserver is left still running in the background. Restarting KStars allows you to set up Ekos again, but when trying to start Ekos there is a warning about Indiserver running and it asks if you wish to close, as soon as you try to close the Indiserver it crashes KStars again.

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

1 month 3 days ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 32
More
AstroPi3 Scripts revised #45439
Rob,
Success I’ve just ran the script on a fresh install of Raspbian Buster and it’s all working fine, all cameras, mounts, focuses, filter wheels are there & no crashing on starting Ekos.

Well done, many thanks

Alan

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

1 month 3 days ago 1 month 2 days ago by Avocette.
Avocette
Senior Boarder
Senior Boarder
Posts: 69
More
AstroPi3 Scripts revised #45442
New installation is working better, thanks, certainly in the main elements that are easy to test indoors in foul weather!
I have had a better chance to look more carefully at some hiccups that have confused me in the past (in the dark).
I will post some issues I have identified under the appropriate headings.

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to AstroPi3 Script
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

1 month 2 days ago
mpfjr
Senior Boarder
Senior Boarder
Posts: 66
More
AstroPi3 Scripts revised #45465
Had an error in the terminal that I saw that I wanted to make sure you knew about. Didn't seem to bother anything but hey, an error is an error.

Raspbian for pi4

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~ Checking items that will require your input while running the script, so you don't get asked so many questions later. Note that some installations later (VNC, samba in particular) may still require your input later on, this is out of my control.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ls: cannot access '/etc/NetworkManager/system-connections/': No such file or directory

Please Log in or Create an account to join the conversation.

1 month 2 days ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2029
Karma: 19
More
Topic Author
AstroPi3 Scripts revised #45466
Thanks! That one is just fine though. That file shouldn't exist yet if this is a fresh raspbian system. The check for that particular folder will only be needed later if you run the script again and the file does exist.

Please Log in or Create an account to join the conversation.

1 month 2 days ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2029
Karma: 19
More
Topic Author
AstroPi3 Scripts revised #45472
Ok I revised it so that the error message should not appear anymore if the folder doesn't exist.

Please Log in or Create an account to join the conversation.

1 month 2 days ago
mpfjr
Senior Boarder
Senior Boarder
Posts: 66
More
AstroPi3 Scripts revised #45477
Just curious and I know I could literally install this and look for myself .. but was curious if you happen to have ASTAP support installed and configured with this script? I don't see it in the notes.

Is that something you might be interested in adding if you haven't already?

Thanks!

Please Log in or Create an account to join the conversation.

1 month 2 days ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2029
Karma: 19
More
Topic Author
AstroPi3 Scripts revised #45483
Not yet but that is easy enough to add
The following user(s) said Thank You mpfjr

Please Log in or Create an account to join the conversation.

1 month 11 hours ago
sjako
Fresh Boarder
Fresh Boarder
Posts: 2
More
AstroPi3 Scripts revised #45561
Hi,
I ran the Raspbian script on my new Pi4 and it worked fine. I can connect to all my devices and control them properly.
Only issue I detected is that the "Skywatcher Synscan Legacy" driver for my mount is not visible via INDI Web Manager and can't be connected remotely.
Local on the PI4 it is visible and working.
Any idea?
Thx for the great work - clear skies :-)

Please Log in or Create an account to join the conversation.

1 month 3 hours ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2029
Karma: 19
More
Topic Author
AstroPi3 Scripts revised #45577
That could have something to do with the fact that you might still be using KStars 3.3.6 on your client machine, I'm not sure. In a couple of days, you should have 3.3.7 and then maybe it will be fixed.

Please Log in or Create an account to join the conversation.

4 weeks 1 day ago
sjako
Fresh Boarder
Fresh Boarder
Posts: 2
More
AstroPi3 Scripts revised #45593
Thx, I checked your hint…
Even if I use the INDI Web Manager App on the PI4 and connect to the local drivers, the "Synscan Legacy" Driver is not listed - see attachment #1
If I use KStars 3.3.7 on the PI4, it is displayed - see attachment #2
I also checked some other mount drivers and I noticed some differences e.g. Celestron CGEM and AVX drivers not listed in WebManager, but in KStars!?
Why is there a mismatch between Web Manager and KStars app?
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.965 seconds