×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6)

5 days 40 minutes ago
DrawsACircle
Junior Boarder
Junior Boarder
Posts: 32
More
Topic Author
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43161
In previous versions of Kstars it was possible to enter UTC offset in EKOS when using a gps (gpsd driver), that is not possible anymore (version 3.3.4 & 3.3.6).
Is there any other way to adjust the offset? It doesn’t make sense to use a gps if it’s not possible.

Please Log in or Create an account to join the conversation.

4 days 16 hours ago
knro
Administrator
Administrator
Posts: 7150
Karma: 51
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43170
That's defined already by the GPSD driver and it was always this case. What has changed?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

4 days 12 hours ago
AstroNerd
Moderator
Moderator
Posts: 576
Karma: 1
More
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43179
Yes this still works on my system, and always had, when using the GPSD driver and a USB gos dongle... :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

4 days 7 hours ago
DrawsACircle
Junior Boarder
Junior Boarder
Posts: 32
More
Topic Author
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43184
That is strange, this is a screen dump of my Pi4 running Kstars 3.3.6, the offset is inherited from an older version (the one included in the first RPi 4 Stellarmate release) where it was possible to adjust the offset:

Attachments:

Please Log in or Create an account to join the conversation.

4 days 7 hours ago
DrawsACircle
Junior Boarder
Junior Boarder
Posts: 32
More
Topic Author
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43187
Have I been dreaming? I know you know better, but I'm 99,9% sure that I've adjusted the offset by entering the number in the UI, but I can see from your Youtube tutorials Jasem, that I'm rather 100% wrong :-)
The offset is adjusted automatically based on the location?

Please Log in or Create an account to join the conversation.

4 days 4 hours ago
AstroNerd
Moderator
Moderator
Posts: 576
Karma: 1
More
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43194
Yes, I have never had to adjust that on mine...once it gets the 3Dfix, it should update all the figures from the location, there was an issue with it about 18 months ago where it was putting in the wrong offset, as I had the issue and mine was 12 hours out...but that was a while ago now... don’t think it’s a regression, as not seen it since it was fixed..
Have you got a different USB dongle to try to eliminate that ..? :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

3 days 11 hours ago
knro
Administrator
Administrator
Posts: 7150
Karma: 51
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43222

DrawsACircle wrote: Have I been dreaming? I know you know better, but I'm 99,9% sure that I've adjusted the offset by entering the number in the UI, but I can see from your Youtube tutorials Jasem, that I'm rather 100% wrong :-)
The offset is adjusted automatically based on the location?


The UTC offset is read from system. So check your system (where GPS is running) and make sure it is using the correct UTC offset.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 days 4 hours ago
AstroNerd
Moderator
Moderator
Posts: 576
Karma: 1
More
UTC offset missing when using GPS (Kstars release 3.3.4 & 3.3.6) #43231
I have just done a complete fresh install on my laptop, and plugged my GPS in and it’s worked straight away, showing a 1 offset...which is correct, so not sure why yours has not worked..

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.389 seconds