×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Kstars crashes when taking flats

1 month 2 weeks ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 510
Karma: 3
More
Kstars crashes when taking flats #44168
Working with CR2 lights, flats and darks prevents conversion problems, no doubt about that!

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 510
Karma: 3
More
Kstars crashes when taking flats #44169

wvreeven wrote: So, why not use CR2 files?


Well, I think I just stuck to the standard without further thought. :-/ With CR2 files, is all the information that is normally stored in the FITS header, stored in a CR2 header, too? Maybe we should discuss this privately since it is unrelated to the OP's issues.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
david_taurus83
Junior Boarder
Junior Boarder
Posts: 22
More
Kstars crashes when taking flats #44182

knro wrote: Problem found and fixed. Appears a recent histogram performance improvement led to this. I will try to update Windows build as well.


Hello Jasem

Will the fix be available soon? I couldn't take flats at all tonight. Kstars closed each time. Even if a took a flat without the preview, when I opened it in Fits Viewer it still crashed.

David

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 7374
Karma: 51
Kstars crashes when taking flats #44192
You can find the Windows nightly releases here: binary-factory.kde.org/job/KStars_Nightly_win64/

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You david_taurus83

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 7374
Karma: 51
Kstars crashes when taking flats #44194

Herrhausen wrote: All cameras with a separate "B" mode would benefit massively from this modification. But other cameras would benefit to some extent, too since Ekos would no longer obtain inaccurately timed "B" exposures for fast shutter speeds when falling back to "B" mode. IMO 1/2000s cannot be timed by countdown. Even in a camera without separate "B" mode, requesting a 1/1400s (just an example) exposure would - as it is now - result in an inaccurately exposed frame.

The fallback to "B" mode is what should be prevented. With "B/M cameras" like the 5D it results in malfunction. With all other cameras it results in inaccurately timed exposures (at high shutter speeds).


Ok I just committed changes to force the exposure to be aligned with the DSLR preset exposures. Can you please test?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You Herrhausen

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 510
Karma: 3
More
Kstars crashes when taking flats #44199
Sure, will do today.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago 1 month 2 weeks ago by Herrhausen. Reason: I didn't notice the changes at first
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 510
Karma: 3
More
Kstars crashes when taking flats #44206
For me it was the first time to compile from git since the new structure was established with 3rd party drivers separated from Indi. I ran into a few problems but I hope I sorted them all out. When I start Indi I can see "Presets" in Indi - Canon DSLR - Main Control. The shutter speeds there 100% match those of my camera. However, in Ekos these shutter speeds are not applied do not show. In the CCD tab I can still choose 0.01 which is not in my cam's list. Also the shutter speeds displayed when clicking the up and down arrows next to the Exposure: field don't match those listed in Indi. I hope this is not due to any mistakes I made compiling. How can I find out the version of indi_gphoto_ccd driver?

FORCE BULB was enabled at startup, had to disable it manually again and again. Saving options didn't have any effect.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago 1 month 21 hours ago by knro.
jhoney
Fresh Boarder
Fresh Boarder
Posts: 4
More
Kstars crashes when taking flats #44212
I wouldn't recommend running this program every time you are imaging, but if there is a reproducible crash and you want to send the details about what causes it, this would be nice.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago 1 month 2 weeks ago by Herrhausen.
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 510
Karma: 3
More
Kstars crashes when taking flats #44218

knro wrote: Ok I just committed changes to force the exposure to be aligned with the DSLR preset exposures. Can you please test?


Jasem, now I can see the changes you have made. Thanks a lot for taking the time! The shutter speeds displayed by clicking arrows next to Exposure: remain the same but the actual shutter speeds executed are adjusted to what is offered by the camera. I can still enter 0.01s but Ekos now takes a 1/90s exposure when I do so. I didn't realize this when I posted earlier this evening. So for single exposures it looks like a success. The first logfile is for a 0.01s exposure. Ekos adjusted the shutter speed to 0.11111 which is offered by my camera (1/90s). Perfect!

For flats we're getting closer but didn't succeed yet. The second logfile is for flats of ADU=29500 being requested, starting at 0.01s again.
1) Ekos takes a 1/90s exposure (correct), ADU of the image received is 1070.
2) Ekos reacts by requesting a 0,012500s exposure. The closest match is 1/90s again, ADU is basically the same, 1069.
3) Ekos increases exposure time to 0.015625s which is adjusted to my cam's closest match of 0.01666667s (1/60s, correct). The image received has an ADU of 1086,96.
4) Ekos reacts by requesting a 9,2615s exposure, adjusted to 10s (correct).
5) For whatever reason the 10s picture is not taken by way of "widget shutterspeed" but instead Ekos falls back to "B" mode sending "eosremoterelease press full" and starting a 10s countdown. This is where the procedure fails. Immediately before that, Ekos correctly reports "Closest match: 10 seconds Index: 3 ". I can't see why Ekos does not request a "widget shutterspeed: 3" similar to what it did before. Is there something like a 1s threshold implemented that prevents Ekos from using widget shutterspeed for exposures of >1s? This is not necessary since available shutter speeds range from 1/8000 up to 30s.

Ekos should *never* fall back to "B" mode while the camera is in "M" mode.

Anyway, we're getting there!. I'll be available for more testing today and tomorrow.
Attachments:
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 7374
Karma: 51
Kstars crashes when taking flats #44228
So the *driver* was always falling back to BULB when the exposure > 1 second. I just removed this limitation in the indi-gphoto driver, so please test. Please note that in my camera (600D), I can still take proper exposures (e.g. 10 s) with camera being in Manual & Bulb modes without using camera predefined exposures. I think this behavior differs in different cameras so this is why.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You Herrhausen

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago 1 month 2 weeks ago by Herrhausen.
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 510
Karma: 3
More
Kstars crashes when taking flats #44237

knro wrote: So the *driver* was always falling back to BULB when the exposure > 1 second. I just removed this limitation in the indi-gphoto driver, so please test.


I am now able to successfully take flats! I ran a couple tests with several ADU values and it did work very well. I'd like to do more tests before sounding the all clear horn though.

It would be helpful to have a few minor modifications:
- FORCE BULB should be disabled 100% of the time when a "B/M camera" is detected just as you had suggested before.
- Ekos should display an error message once out-of-range shutter speeds are requested. During one of my tests I had entered a too high ADU value. Ekos increased exposure times (just as an example) to 34s which was adjusted to 30s. Since the ADU came in below target, Ekos increased the requested exposure time further to 54s or so which again was adjusted to 30s. In this case the process will fail requesting 3600s flats.
- If the value entered in the Calibration - Tolerance field is too tight, Ekos might be unable to successfully take flats due to the limited number of available shutter speeds.
- In the CCD tab's Exposure field only valid shutter speeds should be accepted/displayed. The up/down arrows should browse through the list of available shutter speeds.
- The CCD tab's countdown should be synchronized with actual shutter speeds. As it is now, Ekos does for instance a 54s countdown while in fact the camera takes a 30s exposure.

knro wrote: Please note that in my camera (600D), I can still take proper exposures (e.g. 10 s) with camera being in Manual & Bulb modes without using camera predefined exposures. I think this behavior differs in different cameras so this is why.


Exactly. The 5D can't take bulb exposures in "M" mode. The 600D can.
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 7374
Karma: 51
Kstars crashes when taking flats #44270

- FORCE BULB should be disabled 100% of the time when a "B/M camera" is detected just as you had suggested before.


How can we tell that camera is a "B/M camera"? and do it reliably?

- Ekos should display an error message once out-of-range shutter speeds are requested. During one of my tests I had entered a too high ADU value. Ekos increased exposure times (just as an example) to 34s which was adjusted to 30s. Since the ADU came in below target, Ekos increased the requested exposure time
further to 54s or so which again was adjusted to 30s. In this case the process will fail requesting 3600s flats.


I think that is tied again to the first question. In my camera, it would have taken 34 and 54 seconds respectively just fine. Actually it never adjusted the exposure down to 30s as it only adjust exposures that fall within the minimum and maximum ranges available.

- If the value entered in the Calibration - Tolerance field is too tight, Ekos might be unable to successfully take flats due to the limited number of available shutter speeds.


The default value 1000 is OK though?

- In the CCD tab's Exposure field only valid shutter speeds should be accepted/displayed. The up/down arrows should browse through the list of available shutter speeds.


I actually thought about that. We can make valid shutter speeds available there as decimals. I was thinking more along the lines of fractional exposures (i.e. 1/4000) but that would require a different GUI widget and more work. Maybe this change would confuse users, so I decided to sit on it for now.

- The CCD tab's countdown should be synchronized with actual shutter speeds. As it is now, Ekos does for instance a 54s countdown while in fact the camera takes a 30s exposure.


Again, this is tied to "B/M camera". Once this type of cameras are identified, such special-case adjustments can be made.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You Herrhausen

Please Log in or Create an account to join the conversation.

Time to create page: 0.447 seconds