×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

For those with focus issues

2 months 1 week ago
hy
Gold Boarder
Gold Boarder
Posts: 242
Karma: 2
More
Topic Author
For those with focus issues #51076
Søren,

Thanks for the feedback. Can you please do the following:

- Manual focus youself until you're in focus.
- Run the Linear focus algorithm with
- Full Field and the same anulus as you've used
- Detection: SEP (that should be better than what you were using with star detection & HFR)
- Experiment with gain, exposure & binning and see if you can get 50+ stars detected in each image (not absolutely necessary, but let's start there).
- Step size: same as you were using above.
- Make sure max travel is not limiting you--make sure it's very large for now
- I assume backlash compensation is off. Let me know if otherwise. (turn it off if you're having issues).
- Repeat several times or do whatever you have to do (and describe it) so that you get a failure .
- Send me a log

Notes:
The linear algorithm might work when you're way out-of-focus, but it's best to start it roughly in focus.
In your example above, even though it went back about 7 steps to start, it is still too far in to start.
I can't tell if you should increase the step size, or start with better focus. Try both if you have issues.

If you can, please retry and send me a log with at least the settings checked as in the attached picture.
Since you say it works about half the time, of course, please repeat enough times to get a few failures.

For my f/5.6 refractor with an ASI1600, I use 2x2 bins, gain of 200 and 3-5s exposure depending on the filter.

Appreciate your help in getting me to get this right,
Hy
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
universalmaster
Gold Boarder
Gold Boarder
Posts: 200
More
For those with focus issues #51090
Thanks for the reply.

The (1) dot is what I would call close to focus. HFR ~1.7 and "perfect" focus may be like 1.3-ish.

There is no backlash compensation in FCUSB, as far as I know, do it should be off.

There is a "reverse direction" switch in the FCUSB tab. Could that mess with the algorithm? (maybe the motor is always turning the wrong way?)

The more stars the better in the image, when using full field?

I'll try again and report back. Thanks for making this happen in the first place :-)

I have attached an image of NGC 3793 and its friend, to show that it is not "all work and no play". I feel that everything is continuously improving at the moment :-)
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
gilesco
Expert Boarder
Expert Boarder
Posts: 95
Karma: 1
More
For those with focus issues #51095
These are just some thoughts:

I have issues with the Linear focuser, so I'm just doing a manual focus for the time being (Capture frame, focus in or focus out, capture frame again).

I don't think, that I can improve or use the autofocus routines with any settings, but it is probably not the fault of those routines.

I think the main problem is that I essentially have a cheap focuser, attached to a DC (not Stepper motor).

Because it is a DC motor the "steps" is essentially a milliseconds setting, so when pointing at anything at any altitude >15 the focus in steps are actually a lot smaller than the focus out steps (gravity is helping the focus out, and working against focus in).

While it is probably a problem related to using a DC motor, it would be nice if the driver could somehow have a setting like - focus in / out step size ratio, or even Ekos focuser module to have different focus in / focus out step sizes (although probably better implemented in the HitecAstroDC driver, as this is strictly an issue with DC motors compared with Stepper motors).

__
I blog my progress: www.coochey.net

Please Log in or Create an account to join the conversation.

2 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 707
Karma: 3
More
For those with focus issues #51104

universalmaster wrote: Thanks for the reply.

The (1) dot is what I would call close to focus. HFR ~1.7 and "perfect" focus may be like 1.3-ish.

There is no backlash compensation in FCUSB, as far as I know, do it should be off.

There is a "reverse direction" switch in the FCUSB tab. Could that mess with the algorithm? (maybe the motor is always turning the wrong way?)

The more stars the better in the image, when using full field?

I'll try again and report back. Thanks for making this happen in the first place :-)

I have attached an image of NGC 3793 and its friend, to show that it is not "all work and no play". I feel that everything is continuously improving at the moment :-)


That is a beautiful picture, Soren!

Regarding the FCUSB and the AccuFocuser/analog DC motor focuser: I basically use the same system, although the motors I just got from Amazon for $15, so cheaper than the (now discontinued) AccuFocuser system.
It works beautifully in my hands, but there are a few things to consider.
I think the main issues you are facing results from the differential load on the motor due to the weight of the camera/filter wheel. That means the motor will move faster in the outward direction than the inward direction.
But that can easily be fixed. This is the way how I did it:

1) Note the position on the focus tube where your telescope is in focus.
2) Then attach a rubber band or a string with a spring to the telescope and the other end to the focuser tube.



3) Next, you move the telescope into a 60 degree vertical position, so that you have average gravity force pulling on the tube.
4) Loosen the clutch screw, so that the tube now moves freely
5) Add or remove rubber bands until the tube is in equilibrium at the focus point, i.e. it neither is being pulled inside by too much force from the rubber bands and neither does it slide out.

That pretty much equalizes the force the motor has to work against when moving the tube inwards and outwards and now the timed movements will be approximately equal. That will dramatically improve the ability of any of the algorithms to find focus. Basically, the principle is no different from balancing the mount. You want to minimize the strain on the motors there as well.

A couple of other things that I find important:

1) Do not make the steps the motor moves too small. If they are smaller than the variability of the HFR, the algorithm will have trouble calculating the V-curve.
2) Hy suggests using SEP, which is definitely better than the Gradient algorithm you are using. However, for some reason I find that the Centroid Algorithm works best for me, closely followed by SEP.
3) I just use Full Field, without Autostar.

Unless there was a change in the code recently that may have caused these problems, this methods works beautifully for me. Here another screenshot showing the quality of the V curve using Hy's Linear algorithm:


Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
gilesco
Expert Boarder
Expert Boarder
Posts: 95
Karma: 1
More
For those with focus issues #51148
I've made a little modification to the HitecAstroDC focuser driver, wondering whether it might help out with the disparity between the In / Out focus rate.

The old driver had a setting to set the number of Steps / Second it would drive the focuser at.

I have split this out to two settings, one to control the rate that it focuses inwards and another to control the rate that it focuses outwards.

The idea is, you can, say point your telescope at a 45 degree angle and adjust these values so that focusing in and focusing out occurs at the same rate.

Because the HitecAstroDC is a relative DC motor and not a stepper motor, steps are effectively milliseconds of focusing in a direction, and focusing out is usually faster than focusing in (due to the gravity assistance of your imaging train).

Patch is attached, quickly dry tested with my focuser, will try it out on the next sky watch outing.

Disclaimer - I know nothing of programming, and if I've done something very silly then maybe someone could help correct it!

__
I blog my progress: www.coochey.net
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Elias1234
Fresh Boarder
Fresh Boarder
Posts: 4
More
For those with focus issues #51160
Hi universalmaster,
I had very similar issues than you:
1.) The HFR values are "noise", so to get a reliable v-curve, I either had to use long focus-exopsures or averaging over many frames. This made autofocus very slow and not practical.
2.) When focusing with the full field, the different detection algorithms either detected to few stars, or to many "false" stars (noise, hot pixel).
3.) The the different focus algorithms move all very far out of the focus, so that eventually they don't recognize stars properly anymore. That gives completely wrong measurments for the HFR values at the edges of the v-curve.
All these issues prevented me from using autofocus automatically and without supervision.

I found a solution I am very happy with:
- Don't focus on your actual target, but focus on a bright star close to your target (really bright). (create a "fake" job in your scheduler, to slew to a bright star and focus, before slewing to your actual target).
- With a short focus-exposure time of 0.5 seconds, star detection "gradient", "Auto-select star" and "subframe", the algorithm reliably picks up the very bright star as the target to focus on. The short exposure time and the subframing means, that you can rapidly take many frames to get a more averaged (and less noise hfr measurments). (I average over 8 frames)
- The linear algorithm works best. Even if it moves far away from the minimum of the v-curve, the star is so bright that the algorithm still detects it reliably.
Because the v-curve is very clear and not noise at all, I can choose a tolerance of 0.5%.

With these settings, the automatic focuser works without intervention flawlessly and very quickly.

The only downside is the requirment to work with "fake" jobs in the scheduler, to slew to the bright focus-star of your choice.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 406
Karma: 1
More
For those with focus issues #51182
Hi!

I'm not sure if this fits here, but this is an issue I have. I use Polynomial. What happens is this: After having found a star and measured it a few times, at times the focuser goes some way out or in. Fine, if it so to speak would there measure a clearly more unfocused star. But what happens often is what is on the attached picture:



It seems to pick up some hot pixels, and then get data that severly corrupts the V-curve. ANd then might land on something that is far from good focus.

Does this make sense? What might I do wrong here?

Settings:
Algoritm Polynomial
Tolerance: 0,80 %
Initial step: 150
Max travel 600

I have a strong sense that longer exposure times limits this, as if higher SNR makes this less of a risk. However, sometimes, as now, it still happens.

Any ideas?

Magnus


C8, Losmandy G11, Canon 1000D astromodified.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by universalmaster.
universalmaster
Gold Boarder
Gold Boarder
Posts: 200
More
For those with focus issues #51197
To comfort you, I can say that I see the same kind of error all the time. And with any of the star detection algorithms. Other non-star features are also sometimes picked up, like edges of dust mites, ccd defects and so on. Also sometimes extremely large features are found (most stars hfr 1.5 and then one with hfr 50). Maybe, when using full field, ekos should throw away outliers, i.e. extremely large and extremely small 'stars' when compared to the mean size of all stars?
The following user(s) said Thank You TallFurryMan

Please Log in or Create an account to join the conversation.

2 months 1 week ago
hy
Gold Boarder
Gold Boarder
Posts: 242
Karma: 2
More
Topic Author
For those with focus issues #51198
I agree with the above comments, which is why I strongly recommend you use the "Full Field" focus setting (in focus tab, under settings sub-tab).
Use it with an Annulus of like 25% 80%. Doing this and it will detect many stars, throw away outliers, and then average the results. This is much more stable.
I recommend the SEP star detection algorithm also.

Finally, if you're not happy with the Polynomial algorithm, please try the "Linear" algorithm too ;)
The following user(s) said Thank You mlarsson, TallFurryMan

Please Log in or Create an account to join the conversation.

2 months 1 week ago
universalmaster
Gold Boarder
Gold Boarder
Posts: 200
More
For those with focus issues #51201

hy wrote: I agree with the above comments, which is why I strongly recommend you use the "Full Field" focus setting (in focus tab, under settings sub-tab).
Use it with an Annulus of like 25% 80%. Doing this and it will detect many stars, throw away outliers, and then average the results. This is much more stable.
I recommend the SEP star detection algorithm also.


Not all field show "many stars" when doing this, one example is the image of the two galaxies I posted above. Maybe 3-8 stars are found with a 5s exposure and if one of them is not really a star it seems to throw the focus way off course. A more stable star-locator seems to be needed. Since it is generally assumed that one starts all the focus algorithms pretty close to focus, the star-locator could maybe be told to only look for stars in the same places as it located stars in the first image? It seems to me that sometimes new stars or non-stars are located and possibly throw the focus algorithms way off course. And if it gets way out of focus, it may even not detect any stars. It should be the case that the stars do not move notably between focus images and their HDR value should only change a bit. They may be some useful information to the star locator algorithm.
Well, that's my experience anyway and I could of course be doing something wrong or crazy :lol:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
hy
Gold Boarder
Gold Boarder
Posts: 242
Karma: 2
More
Topic Author
For those with focus issues #51202
I get many more stars with my f/5.6 scope on a typical image.
For an R,G, or B filter I use 3s exposure, gain 200 in the focuser (ASI1600 camera) and on most of my attempts was getting ~70 stars.
For Ha/SII/OIII I use 5s and get a similar number of stars.
Also, fwiw, I use a binning of 2x2 on my focus images.

If you aren't getting lots of stars, can you try adjusting your focus exposure and see if that improves things?

Please Log in or Create an account to join the conversation.

2 months 1 week ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 406
Karma: 1
More
For those with focus issues #51203
Hi!

You use 2x2 binning? I've been experimenting with that. What is your pixel scale? Mine is 1.42 arcsec/pixel with this setup. Problem is that you would want the star spread over several pixels, wouldn't you? As opposed to alignment, where I use 4x4 bining to make it fast, and just a few secs exposure time.

I do not focus in Ha anymore, I have Ha loced to Lum in the filter dialog/window, and an offest of 97 ticks, measured as a mean over 25 focus attempts on a mag 2 star.

Magnus


C8, Losmandy G11, Canon 1000D astromodified.

Please Log in or Create an account to join the conversation.

Time to create page: 1.277 seconds