×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info

7 months 1 week ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49172
Since KStars release 3.4.0 (Ubuntu 18.04LTS, Stellarmate and other ARM), the connection buttons (Connect, baud rate...) for the indi_duino MeteoStation driver are non responsive (won't depress). I noticed that there were minor changes to the skeleton files but nothing that would explain this behavior. The problem does not occur on my MAC running KStars 3.3.9. Were there any changes done to the indi_duino driver that could explain that as there is no useful log info relative to what's happening.

Thanks for any insight.

Please Log in or Create an account to join the conversation.

7 months 1 week ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49177
I made some progress toward a solution/fix for that problem.

I modified the Arduino MeteoStation SQM skeleton file to move what was in the "Main Control" group into a "Weather Data" group and move what was in the "Connection" group into the "Main Control" group, as is done in the other indi_duino related skeleton files. I can now connect again to the meteo station but the "Connection" tab seems to be where the problem comes from. The buttons in that group (Baud Rate, Connection Mode...) seem to be read-only so I cannot click on a button to depress it.

I will look at the connection part of the indi_duino driver just in case I find something obvious but not having much driver experience, no promises.

Please Log in or Create an account to join the conversation.

7 months 1 week ago
ChrisRowland
Platinum Boarder
Platinum Boarder
Posts: 534
Karma: 9
More
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49182
This may be common knowledge but what I've found with Arduinos is that they do a reset when the serial connects and it takes a couple of seconds to get started.

A two seconds delay after the connect can help a lot.

Chris

Please Log in or Create an account to join the conversation.

7 months 1 week ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49189
Thanks for the tip!

I also found out that if I deleted the "Arduino MeteoStation SQM_config.xml" in ~/.indi, it partially solved the problem. I could set the Baud Rate and other configuration settings, but the problem came back after some time. The log files are not quite clear on what happens so I will continue looking at a solution, unfortunately its not as easy as I would have hoped for :-( .

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago 6 months 3 weeks ago by procras.
procras
Senior Boarder
Senior Boarder
Posts: 55
More
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49985
I have the same issue with the non-responsive Connect button.
It happens each time unless I
$ cd ~/.indi
$ rm Arduino*

Then it connects ok.

I am using the mlx90614, TSL2591 and BME280 sensors on I2C connected to an arduino Uno

My mlx IR T and mlx ambient T were giving strange values, the conversions in the meteostationSQM_sk.xml file seemed ok and corresponded with the
case 0: etc switch statement in the indiduinoMETEO.ino file.

However there was a / 100.0 in the mlx.read statements in the indiduinoMETEO.ino file, I don't recall if this is new.
<code>
if (mlxSuccess) {
//Tir = mlx.readAmbientTempC() / 100.0;
Tir = mlx.readAmbientTempC();
//IR = mlx.readObjectTempC() / 100.0;
IR = mlx.readObjectTempC();
} else if (mlxSuccess = mlx.begin()) {
</code>

I found where the /100.0 came from:-
github.com/indilib/indi-3rdparty/pull/59
There is another project called Weather Radio that looks interesting.


So I edited that and the temperatures look okay now.

But my lights/flags for Cloudy, Freezing daylight don't appear to work. They are usually just grey.

Sometimes the Freezing flag is green when it is not freezing,
The cloudy flag is grey when clouds are 100%.
The daylight flag is grey when it is daytime.

I attach the /usr/share/indi/meteostationSQM_sk.xml file,

File Attachment:

File Name: SQM_sk.xml.txt
File Size:5 KB


I also attach a log file,

File Attachment:

File Name: indi_duino_120438.log
File Size:42 KB


Strange!
Attachments:

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49988
I am not sure what's happening here as the meteostation used to work correctly before some recent changes to INDI, and the Arduino firmware hasn't changed since then. As I was involved in some other astronomy related projects recently I did not have much time to look into the problem but will look again.

Ultimately, I would like to write a driver for meteostation, independant of indi_duino and firmata, that would make it easier to add functionality (e.g. wind and rain sensors...) but, as I am not well versed in writing drivers, that may take some time. In the meantime I will try to find a solution for the current situation.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
procras
Senior Boarder
Senior Boarder
Posts: 55
More
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #49999
Thanks G_Gagnon.

I have got meteostationWEB working with meteostationSQM_sk.xml

I had to alter the meteoRRD_updater.py script so it wasn't looking for light
63d62
<         skyQuality=vectorMeteo.get_element("WEATHER_SKY_QUALITY").get_float()
65,66c64,65
<         #vectorLIGHT=indi.get_vector(INDIDEVICE,"LIGHT")
< 	#light=vectorLIGHT.get_element("LIGHT").get_float()
---
>         vectorLIGHT=indi.get_vector(INDIDEVICE,"LIGHT")
> 	light=vectorLIGHT.get_element("LIGHT").get_float()
72d70
<         daylightFlag=int(statusVector.get_element("daylight").is_ok())
74c72
< 	return (("HR",HR),("Thr",Thr),("IR",IR),("Tir",Tir),("P",P),("Tp",Tp),("Dew",dew),("Light",skyQuality),
---
> 	return (("HR",HR),("Thr",Thr),("IR",IR),("Tir",Tir),("P",P),("Tp",Tp),("Dew",dew),("Light",light),
76c74
<            ("frezzingFlag",frezzingFlag),("daylightFlag",daylightFlag))
---
>            ("frezzingFlag",frezzingFlag))

The cloudflag, dewflag,frezzingFlag initially were all zero. But then the frezzing flag went on
{'date': datetime.datetime(2020, 2, 23, 17, 33, 20), 'ds': {'HR': 67.14, 'Thr': 0.0, 'IR': 19.25, 'Tir': 18.55, 'P': 1019.3, 'Tp': 19.1, 'Dew': 12.85, 'Light': 6.93, 'T': 19.1, 'clouds': 100.0, 'skyT': 12.65, 'cloudFlag': 0.0, 'dewFlag': 0.0, 'frezzingFlag': 1.0, 'daylightFlag': 0.0}}

See image

I suspect that as it occurs with kstars and meteostationWEB, there must be a problem in the indiduinoMETEO.ino file or
at least a disagreement between the indiduinoMETEO.ino sketch and the meteostationSQM_sk.xml file.

Will have another peep!
Attachments:

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #50013
I, unfortunately, do not use meteostationWEB so I am not aware of potential problems but, from a previous post from a few months ago, I understood that there was no problem with the updated version of indiduinoMETEO.ino. Won't be able to help you much here, sorry.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #50169
Just found today (back at it after some time) that if the EKOS profile that I use is in"Local" and "Auto Connect" mode, the Indiduino MeteoStation will connect and display values normally but if the profile is in manual connection mode (not Auto Connect) many buttons on the "Connection" pane of the Indiduino MeteoStation, among which the Connect button, are non-responsive and, as such, connection to the MeteoStation is not possible.

I will give it a try in "Remote" mode (distributed INDI environment) to make sure that it works.

Please Log in or Create an account to join the conversation.

6 months 1 week ago
escriban
Senior Boarder
Senior Boarder
Posts: 54
Karma: 1
More
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #50671
Hi G_Gagnon

Are there some more insights by now?

After I found the indi-duino package I was exited: Its exactly what I was looking for! I intended to build a roll-off roof controller with indi-duino and began to work on a possible solution. Now the whole project stands, but
I'm struggling with the buttons of indi-duino not beeing responsive too!

I could trace down so far, that starting an indi-duino instance (e.g. switcher or stepper etc.) with the device manager the connect button does always work, but not other ones. For instance the "lightvector"-buttons do not reflect the state and are falling back to the initial state every "timerhit"-loop. Sometimes the option-tab buttons are working, sometimes not. All is very erratic! There is some really bad misbehaviour of some code in the core. I hope somebody can find the problem soon. Otherwise indi-duini will die!

Sincerly
Antonio

Please Log in or Create an account to join the conversation.

6 months 1 week ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Topic Author
Indiduino MeteoStation (legacy and SQM) buttons non responsive -- More info #50675
Heelo Antonio,

Since I had many problems with Indiduino MeteoStation (connection and buttons stuck problems), I moved to using the Weather Radio firmware and driver (in the third party drivers repository) developped by Sterne-Jaeger (Wolfgang). I haven't encountered a single problem since I moved my meteo station to that software and the interface is much better, to my taste. It also works very well with my INDI distribute system. It has a WEB interface that I haven't used yet and a wireless version is in the works if I understood correctly.

The nice thing about this new MeteoStation firmware/driver is that it runs on my legacy (Indiduino MeteoStation) weather station.

Hope this helps,

Gilles

Please Log in or Create an account to join the conversation.

Time to create page: 0.843 seconds