×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Rainbow Astro RST-135 and Basic LX-200

  • Posts: 5
  • Thank you received: 1
Latest RST Rainbow software V.200131
Raspberry Pie 4
KStars 3.4.2

I am unable to sync the position of the SkyMap/Handcontroller/OTA-Telescope with the object on the SkyMap using the Rainbow Astro RST-135 Setting EKOS-KStars.

Example Screens included.

1. When EKOS-KStars is set to the basic LX200 mode, the KStar-SkyMap/Handcontroller/OTA-Telescope all have the same sky object referenced.

When the RainbowAstro RST-135 is set to the Rainbow Astro > RST-135 mode, the KStar-SkyMap/Handcontroller/OTA-Telescope has the Handcontroller and the OTA-Telescope matching, but not the KStar-SkyMap referencing the same sky object. There is an unresolvable offset even after using the sync function in the Astro Astro Handcontroller and/or KStartars.

How do I get EKOS-KStar set with the Rainbow Astro > RST-135 mode for controlling the RST-135 mount to have the KStar-SkyMap match what the Handcontroller and what I see through the OTA-Telescope?

I have used the SYNC function without success.


As a reference, the iPhone-SkySafari Plus/Handcontroller/OTA-Telescope combination set up with:

"Meade LX200 Classic"

has the iPhone-SkySafari Plus/Handcontroller/OTA-Telescope all matching the same object in the sky. [ASCOM w/ MaxIM DL, TheSky6], Stellarium and Cartes du Ciel Open Source Planetarium all seem to work correctly too.

Any and All suggestions welcome.


Thank you

Art
2 years 5 months ago #52274

Please Log in or Create an account to join the conversation.

Select rainbow driver and submit logs for it (see my signature on how to submit logs).
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 5 months ago #52276

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
log ... sorry I did not zip

File Attachment:

File Name: log_12-33-51.txt
File Size:607 KB

File Attachment:

File Name: log_12-33-51.txt
File Size:607 KB

File Attachment:

File Name: log_12-33-51.txt
File Size:607 KB

File Attachment:

File Name: log_12-33-51.txt
File Size:607 KB



The mount gets lost and then crashes into itself.


Tell me what you want and how you want testing done. I will get to that and send you the logs.


A
2 years 5 months ago #52381
Attachments:

Please Log in or Create an account to join the conversation.

Ok the response from the mount is different from the official Rainbow documentation. Maybe it needs firmware update? Please contact Rainbow for more information on this.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Art Morton
2 years 5 months ago #52415

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
LOL

WOW, this is great.

www.rainbowastro.com/software-2/

I was having these problems with the mount so ... I upgraded my firmware. The most recently released firmware is what I am running. There is a new product that RainbowAstro is releasing, the RST-300, and maybe this is why you see the mismatch in what you reviewed from my unit and the log I forwarded.

– Change homing range to 200 degrees
– Fixed bug with meridian flipping when canceling GOTO

The RST-135 is kind of a new product, so these kinds of crazy things are expected.

Unfortunatly, I can NOT go back to the previous firmware release. Or I need to ask RainbowAstro how to do that. Unluckily, I do not know anyone who has not upgraded whos mount I can use to get a PRE UPGRADE log.

How can I help?

How do you want me to proceed?

Is there someone I should try to contact in Korea and Rainbow Robotics??
2 years 5 months ago #52450

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
1st:

Thank you for your support of the Astronomy Community and this spectacular cluster of valuable practical, functional software tools.

2nd:

I did follow your recommendation and contacted Rainbow Astro Support, and my Local Reseller, Cloud Break Optics, [described the problem and provided the log{KStar/Ekos Log}] about what I thought the problem was. And I received an immediate response acknowledging my technical question and then not too long after that a complete, understandable, and implementable resolution/solution.

3rd.

As a part of the solution, I downloaded and successfully upgraded my RST-135 with the most recent firmware upgrade from RainbowAstro's Support Page that corrects:

– Change the homing range to 200 degrees
– Fixed bug with meridian flipping when canceling GOTO
– Fixed a bug where the mount was reversed in Southern Hemisphere / ALT-AZI mode

Then, I followed the instructions and correctly set up the RST-135 to use KStars and EKos. [KStar & EKos/RST-135 Hubo-I Handcontroller User Manual ... of course there is always user error, I'm Human]

KStars and EKos NOW CONTROL MY RAINBOWASTRO RST-135 MOUNT PERFECTLY!!!!!! Now the tuning ....... process .....

Thank you for your assistance and recommendations for troubleshooting my technical challenge.

Regards,

A
The following user(s) said Thank You: Jasem Mutlaq
2 years 5 months ago #52617

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
I just got the same RST-135, which I plan on using with a StellarMate when traveling. Can you please tell me what settings are important for the mount on the hand controller, and what settings are important in KStars/EKOS? How do you set the meridian flip? Dose the mount inform KStars/EKOS of GPS location, time?

Any help is appreciated. Thanks!
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
2 years 3 months ago #55971

Please Log in or Create an account to join the conversation.

Time to create page: 0.529 seconds