×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Libraw19 and libraw20 conflict in 1.8.6?

2 months 2 days ago
Supaii
Fresh Boarder
Fresh Boarder
Posts: 12
Karma: 1
More
Libraw19 and libraw20 conflict in 1.8.6? #58586
Same issue, new instalation on 20.04 ubuntu

indi-full can't install if kstars-beelding installed

indi-gphoto and indi pentax seem to be an issue.

Please Log in or Create an account to join the conversation.

2 months 2 days ago
Minhlead
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
Libraw19 and libraw20 conflict in 1.8.6? #58593
Actually the gphoto and pentax both use libraw20. If you install libraw20 first, they install just fine. But then kstars will be removed

Please Log in or Create an account to join the conversation.

2 months 2 days ago
knro
Administrator
Administrator
Posts: 8446
Karma: 51
Libraw19 and libraw20 conflict in 1.8.6? #58614
I rebuilt KStars now and it depends on libraw20

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You Minhlead

Please Log in or Create an account to join the conversation.

2 months 2 days ago
Minhlead
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
Libraw19 and libraw20 conflict in 1.8.6? #58615
Thanks. I assume it is the stable build?

Please Log in or Create an account to join the conversation.

2 months 2 days ago
knro
Administrator
Administrator
Posts: 8446
Karma: 51
Libraw19 and libraw20 conflict in 1.8.6? #58616
Yes it is.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You Minhlead

Please Log in or Create an account to join the conversation.

2 months 2 days ago
plop3
Junior Boarder
Junior Boarder
Posts: 31
More
Libraw19 and libraw20 conflict in 1.8.6? #58629
Libraw20 breaks my distro (Ubuntu Focal).
I cannot install Kstars 3.5.
If i force update to libraw20 i remove:
- gthumb
- entangle
- krita
- shotwell
- siril
- more libs (libpasraw...)

Please Log in or Create an account to join the conversation.

2 months 2 days ago 2 months 2 days ago by plop3.
plop3
Junior Boarder
Junior Boarder
Posts: 31
More
Libraw19 and libraw20 conflict in 1.8.6? #58630
It's not possible to install libraw19 in the same time to libraw20 ?

Please Log in or Create an account to join the conversation.

2 months 2 days ago
Minhlead
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
Libraw19 and libraw20 conflict in 1.8.6? #58632
I think the problem is solved. Thanks

Please Log in or Create an account to join the conversation.

2 months 2 days ago
astro_kyb
Fresh Boarder
Fresh Boarder
Posts: 8
More
Libraw19 and libraw20 conflict in 1.8.6? #58634
How exactly it has been solver? 'Cause I am trying to install Kstars and getting ' kstars-bleeding : Depends: libraw20 but it is not going to be installed : Unable to correct problems, you have held broken packages.'
the same procedure:
'sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update
sudo apt-get install indi-full kstars-bleeding'
And the error is still here.
Thanks in advance

Please Log in or Create an account to join the conversation.

2 months 2 days ago
wvreeven
Supernova Explorer
Supernova Explorer
Posts: 1719
Karma: 8
More
Libraw19 and libraw20 conflict in 1.8.6? #58635
What happens if you add libraw20 to that command line?

sudo apt-get install indi-full kstars-bleeding libraw20

ASI6200 and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

2 months 2 days ago
astro_kyb
Fresh Boarder
Fresh Boarder
Posts: 8
More
Libraw19 and libraw20 conflict in 1.8.6? #58636
Thanks wvreeven! It did the trick! :)

Please Log in or Create an account to join the conversation.

2 months 2 days ago
plop3
Junior Boarder
Junior Boarder
Posts: 31
More
Libraw19 and libraw20 conflict in 1.8.6? #58637
Does not work for me:
apt install libraw20
Les paquets supplémentaires suivants seront installés :
indi-gphoto indi-pentax kstars-bleeding kstars-bleeding-dbg libraw-bin
Les paquets suivants seront ENLEVÉS :
entangle freecad freecad-python3 gimp gimp-gmic gimp-gutenprint gimp-lensfun gimp-python gimp-texturize
gthumb kicad krita libfreecad-python3-0.18 libfreeimage3 libgegl-0.4-0 libgimp2.0
libocct-data-exchange-7.3 libocct-ocaf-7.3 libocct-visualization-7.3 libpasraw libraw19 shotwell siril
Les NOUVEAUX paquets suivants seront installés :
libraw20

Please Log in or Create an account to join the conversation.

Time to create page: 0.842 seconds