×

INDI Library v1.9.8 Released (Yesterday)

Bi-monthly INDI Library released with new drivers and bug fixes.

Why is the UTC time in KStars/Ekos different from my mount?

  • Posts: 527
  • Thank you received: 138
I have KStars/EKOS set to get updated by the mount which is using a GPS device to set the time.

I have the mount set only to show UTC time, with no local offset and no daylight savings time. It shows the correct UTC time of 15:44, However, in KStars when I open up the mount in the Indi control panel it shows UTC as 16:44, one hour difference?

This is making my schedule start one hour early, and meridian flip start one hour early. Where would this discrepancy come from?

Mount time:


INDI control panel for mount:


KStars settings:
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
1 year 11 months ago #61134
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
Still digging into this, and have no further information than the following log.

This one line shows it setting the time.

[2020-10-06T12:54:55.687 CDT INFO ][ org.kde.kstars.indi] - Setting UTC time from device: "LX200 10micron" "Tue Oct 6 18:54:51 2020 GMT"

When it said this, I checked the mount and the mount shows 17:54:51, so one hour difference with what INDI reads, and what the mount shows. How can this be?

File Attachment:

File Name: log_12-54-34.txt
File Size:114 KB
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
1 year 11 months ago #61143
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1117
  • Thank you received: 182
That looks like a problem with DST in your mount. Is DST set to Y?

You may have to offset UTC by 1 in your Control panel to compensate for DST.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You: Andrew Burwell
Last edit: 1 year 11 months ago by Jose Corazon.
1 year 11 months ago #61146

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
I think I just got to the bottom of this. It is related to DST, but it doesn't make any sense.

In my original post, I had the mount running purely on UTC time with no offset for my local zone, and daylight savings time off.

EKOS should have read that across exactly and applied UTC time but looks like EKOS was somehow compensating for DST by adding an hour.

The only combination I was able to get to finally work correctly is to set UTC time on the mount to -6 (Central time zone US). Daylight Savings time off.

Now EKOS and the mount show the same time. Somehow EKOS detects whether or not DST is in effect in your local area regardless of the time the mount sends. If I set DST on in my mount, then my mount feeds EKOS with the DST time, and EKOS compensates by adding an hour thinking it is correcting for DST time.

The correct combination of all settings in the mount, produce a problem in EKOS because only the time is sent over from the mount, and not the DST status, and it looks like EKOS is applying the DST status to the time it gets from the mount.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
1 year 11 months ago #61149

Please Log in or Create an account to join the conversation.

  • Posts: 2138
  • Thank you received: 205
I have the same issue with my CEM25p, there is one hour difference between the mount set with DST:N and Ekos, same thing as you "I have KStars/EKOS set to get updated by the mount"
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
1 year 11 months ago #61154

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
Check your location settings in Ekos and make sure that DST is switched off there. I don’t think this is a mount problem.


Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
1 year 11 months ago #61158

Please Log in or Create an account to join the conversation.

  • Posts: 154
  • Thank you received: 22
Mine turned out to be KStars had the DST rules for my geographic location incorrect, I just made a copy of my location and put -5 hrs instead of -6 that was the rule in KStars. Fixed the issue.
1 year 11 months ago #61160

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
It's pulling the location from the mount, and clearing out the location settings I manually put into KStars.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
1 year 11 months ago #61161

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
Maybe open a new topic here describing the issue for your location so it can be fixed? I did the same for my location a few months ago and Jasem fixed it right away.
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Last edit: 1 year 11 months ago by Wouter van Reeven.
1 year 11 months ago #61162

Please Log in or Create an account to join the conversation.


What's the rule that requires fixing?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 11 months ago #61163

Please Log in or Create an account to join the conversation.

  • Posts: 154
  • Thank you received: 22
Mine was McAllen, Texas USA - Central US time zone.
1 year 11 months ago #61164

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138

What I discovered through my own trial and error is that the only things that sync from the mount to KStars is the actual UTC time (with no offset and no DST setting), and your GPS coordinates. It appears KStars then knows based on your location what offset and DST to apply to your current location and then corrects the time.

This means that if I plug in DST settings into the mount, KStars doesn't know that there is a DST set, because it thinks it's only getting the UTC time, and it offsets the time by DTC even though you've already done it in the mount now making KStars have the wrong time by one hour.

I don't know if this is driver dependent or not. But that seems to be the way the 10Micron driver works. It could be different for other mounts.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
1 year 11 months ago #61167

Please Log in or Create an account to join the conversation.

Time to create page: 0.649 seconds