×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Alternatives to Raspberry Pi4?

  • Posts: 629
  • Thank you received: 62
Just FYI. My RPI4's are about a year apart but both show similar behavior.
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
The following user(s) said Thank You: Gary McKenzie
1 year 1 month ago #64213

Please Log in or Create an account to join the conversation.

  • Posts: 210
  • Thank you received: 25

Replied by PDB on topic Alternatives to Raspberry Pi4?

Those camera hangs have turned lately, but I see these also when I connet 2 ASI cams to my Intel PC. (If I connect 2 diiferent makes eg ASI and Omegon no problem and no hangs) Looks more like a driver issue (timing) or a ZWO SDK issue.

Anyway I run an RPI4 and so far it works ok. Must say I connect everything on the RPI via a Pegasus Powerbox V2 and that makes it more stable.
And of course a good power supply for the RPI is a must.

Paul
1 year 1 month ago #64214

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Now that I have everything satisfactorily running on a Pi3a, albeit slowly, I'm looking to upgrade to something more suited myself.

I'm leaning towards the Asus Tinkerboard mainly for the "SSD Like" 16gb onboard memory, and a 4x increase in RAM vs. the Pi3.
1 year 1 month ago #64217

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
+1 for a good power supply. I use all RPi4s with a good battery and with 2 ZWO cameras. No powered hub. The ASI120MC-S is connected to the USB hub of the ASI2600MC or ASI6200MM which gets connected to one of the USB3 ports of the RPi4. No issues whatsoever.

Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
1 year 1 month ago #64218

Please Log in or Create an account to join the conversation.

  • Posts: 132
  • Thank you received: 19

The point of two RPi4's is that I am running everything from inside my travel trailer - too cold to sit outside.

jmh
1 year 1 month ago #64220

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182

The only issue I have with the Pi4 is that under Ubuntu 20.04 the network periodically disconnects. Note that this has nothing to do with the internal Wifi, since the same thing happens when I use an external dongle. All my peripherals are connected to a powered USB3 hub, to prevent any excessive power drain on the USB bus. All devices are fed to the Pi through a single USB3 connection from the hub.

Strangely, the disconnects happen only when I am connecting to a Wifi network, NOT when I am using the internal (or external) Wifi to create a Hotspot. So to avoid being locked out of the Pi, I am now routinely running it using the internal Wifi to create a Hotspot and the external Wifi to connect to my Wifi router. Also strangely, I cannot restart the Wifi connection once it has stopped working periodically and for unknown reasons when I enter the Pi through the Hotspot connection. It will never find the network again unless I restart.

That is my only concern with the Pi4, otherwise it just works like a dream machine. By now I have use 6 of them, 3 4 GB models and 3 8 GB models.

The only one that fatally failed on my was one that got doused when my sprinkler system came on one night and submerged the Pi. I could never resurrect it.

So yes, I am miffed! These Pis should really be water-proof. I mean, what were they thinking!? ;)

Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
1 year 1 month ago #64240

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 3
Thanks for all the replies!

I decided to see how things work using an old laptop, just to make sure that the problems were not potentially software related. With the Latest Mint Cinnamon, Kstars etc, everything works perfectly, connects first time and has no issues I can see. I can connect to this and run everything from a windows pc, and also via a VNC connection to the laptop.

I have upgraded the firmware on the Pi to no avail. A search shows that the problems I have had with USB 3 are not unusual, not common, but by no means unknown. I will try one more option and set up ubuntukstars on the Pi over the weekend and see if that makes any difference.

Thanks all
cheers
Gary
1 year 1 month ago #64255

Please Log in or Create an account to join the conversation.

  • Posts: 629
  • Thank you received: 62
Ha-ha... Makes sense..
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
1 year 1 month ago #64320

Please Log in or Create an account to join the conversation.

  • Posts: 312
  • Thank you received: 13
There is an x86 single board computer out now to compete with the Rpi for under $100. I also am using an Rpi 4 (new one with 8 GB Ram) and an Anker powered USB3.0 7 port hub to connect all the equipment to. I also have occasional drop outs to the Server (I am hard wired over ethernet to a laptop in the garage that I run the AStroberry server using a browser) but it almost always happens when I try to make some change during an imaging or guiding session, not just changing screens but click on something in the program. Not all things just some and it seems much less with the new Rpi. I imaged the other night for 4 hours with 2 dropouts. Each time I was able to just restart Kstars and pick right up where I left off as the Server kept all the equipment connected. The delay caused by the drop out was less than a minute, getting everything up and running again. Of course, it would have been a real pain if I had not been sitting at the laptop to see it happen, but then if it were running on its own it might not have dropped out in the first place. I have yet to try the sequencer, but should.

Ron
1 year 1 month ago #64343

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182

In my case, only the network drops out, not Kstars. In fact, if it happens during the night while Kstars is running my rig unattended, it always faithfully continues to work down the scheduler and parks the mount after the end of the session.
It is only for the rare cases where there is a problem, like lost guiding due to clouds or similar where intervention is required that this becomes a problem.
I may be able to fix it with a cron job that periodically checks the connection to the main router and if it is interrupted just restarts the network using ifupdown.
Does anyone have a script ready that will do just that?
Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
1 year 1 month ago #64349

Please Log in or Create an account to join the conversation.

  • Posts: 85
  • Thank you received: 18
My current rig employs a Lenovo ThinkCentre M93P 'Tiny' "desktop" machine, though it uses a laptop power connector.

The specs of mine include 5 USB 3.0 ports (no 2.0), an Intel Dual-Core i5-4570T Processor up to 3.60 GHz, 8GB RAM and a 240GB SSD. I installed Kubuntu 20.10 alongside Win10Pro. I bought it refurbished so I didn't spend an enormous amount. It also came with a rather lame USB 2.0 2G wifi stick, a cheap keyboard and a mouse that rattles (for real). I upgraded the USB wifi to a USB 3.0 5G dongle with an antenna. I also made some changes to the BIOS to allow booting without a keyboard. I run krfb on it as a remote desktop server (it seems to default to 1024x768 when no monitors are plugged in).



It's about the size of a counterweight and weighs almost as much as well. To mount it I also bought a VESA bracket that holds the computer and which is usually intended to suspend the unit off the back of a monitor or television (obviously not one that's actually mounted to a VESA mount). I built a receiver for the VESA bracket out of plywood that attaches to the end of my EQ6's counterweight bar, so it acts as a counterweight.



It almost weighs enough to properly counterweight the rest of the rig (!), at least when the Evostar72 is on and would probably do so if the guidescope were omitted. I only have 10lb weights (the mount originally carried a 10" Newtonian which I still have) and if I add even one right at the top of the bar it dramatically overbalances the counterweight end, so I'll need to find a way to add some smaller weights to the rig but it is pretty close to balanced already.



As you can see I have a powered USB 3.0 hub velcroed to the backside of the EQ6, so all rig-related USB cables emerge from here. The hub itself uses 12v, so it can be powered from the same distribution centre as everything else, which I have velcroed onto the control panel side of the EQ6.



What's great about this is that the SSD is big enough for all the Astrometry.net FITS for plate solving and with fast processors aboard it solves in a second or two. The SSD also has legions of space for saving FITS from the camera.
1 year 3 weeks ago #64866

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 136

Nice idea...BUT
One should never run an imaging rig with the counter weight that far down the shaft, it can cause huge loads on the motors when slewing, it’s much better to have much more weight and further up towards the mount head, there has been a lot of research done on this, the initial inertia with a weight that far down I’d bad for the mount.... :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
1 year 3 weeks ago #64871

Please Log in or Create an account to join the conversation.

Time to create page: 2.078 seconds