×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Inverted KStars movement?!

  • Posts: 17
  • Thank you received: 4
Hey Everyone,

I started using stellarmate a few weeks ago, and had a few issues which I got sorted out. I have however decided to start from scratch per se, and installed indi on a fresh install of Ubuntu on my raspberry pi, with KStars / Ekos on my macbook.

Connections all work fine, and control to my dslr and scope work (almost) fine. The issue is... the mount controls through KStars do the right thing.. left moves the scope left, right right, up up, down down. *However*.. within KStars the direction indicated moves the *opposite* direction.

I've got my time and geo set in KStars correctly (was my first thought, as i'm in the southern hemisphere).. and i'm sure it's just a setting i'm missing somewhere or something that's strange.

Any pointers?!

Cheers,
Jack
1 year 10 months ago #65995

Please Log in or Create an account to join the conversation.

You mean KStars Mount Control Panel? There is "reverse" button you can check.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 10 months ago #65997

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Jack on topic Inverted KStars movement?!

Oh yes I know that's there. It's unchecked (I did try check it, with the opposite outcome).

But to be clear, I slew the telescope left using the left pointing arrow in the mount control, and my telescope slews left correctly. *However* the little reticule in KStars showing the position of the telescope moves RIGHT.

Same goes for all directions. If i flip the reverse button, and click the left button the telescope slews right.. but then kstars moves left.

It's very strange.

Jack
Last edit: 1 year 10 months ago by Jack.
1 year 10 months ago #65998

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Jack on topic Inverted KStars movement?!

Ok in some further testing this morning, KStars on Windows works 100% fine. The issue only occurs on OSX.

Given it's not an INDI issue, i'll see what I can find out on the KStars side.

Will come back with the outcome either way!

Cheers,
Jack
1 year 10 months ago #66031

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Jack on topic Inverted KStars movement?!

For future posterity, this behaviour seemed to correct itself once I upgraded OSX from Catalina to Big Sur.

Likely an incompatibility with the last version of OSX... not great.. but fixable as long as your laptop isn't too old!

Cheers,
Jack
The following user(s) said Thank You: Eric
1 year 10 months ago #66033

Please Log in or Create an account to join the conversation.

Time to create page: 0.436 seconds