×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Omegon Pro / Touptek drivers

  • Posts: 12
  • Thank you received: 3
It's been a long while since I used my Stellarmate but I will defenitely give it a go once the new INDI-lib version comes out and I'll let you know how it went.
The following user(s) said Thank You: Wiktor Latanowicz, Hartmut
2 months 4 weeks ago #82788

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 4
May I ask a question related to this problem?

I'm using a veTEC533c with Astroberry & Stellarmate via RPi4 USB3 port.
Additionally I'm using a ZWO ASI120MC-S connected via USB-3 cable to the veTEC USB-2.0 HUB.
The veTEC is powered by external 12V.

This works great and as expected using the internal Guider, not PHD2.
Now I want to exchange the ASI120MC-S by a veTEC GUIDE 2000M (has an USB2.0 Port).

Could the above stated problem also occure if using the "Internal Guider" or is is only related to the usage of PHD2?

Cheers
Hardy
2 months 4 weeks ago #82813

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 3
The bug that I fixed was in the driver. Session management software doesn't matter until it connects to the indi server. And it didn't matter if the camera was used for guiding or main expositions.

Long story short: the driver didn't wait long enough (sometimes didn't wait at all) for the camera to finish the exposition.
The following user(s) said Thank You: Hartmut, max
2 months 4 weeks ago #82817

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 3
I too have the Omegon Guide 2000M and the problem is the same in PHD2 as in the internal guider. I have the same problem on my MacBook Pro with the Omegon camera. Only under Windows and the ASCOM driver does the guide camera performs reliably.
The following user(s) said Thank You: Hartmut
2 months 4 weeks ago #82818

Please Log in or Create an account to join the conversation.

  • Posts: 194
  • Thank you received: 16
It is really interesting cause I’ve never seen this issue, at least with internal guider.

I have my Omegon 533 connected directly with a USB 3.0 cable to my mini pc. The Omegon 1200b M connected to 533’s usb hub. I have selected Omegon Pro as driver in CCD and Guider tab into Indi.

Here is the setup astrob.in/rdxygc/0/

The only difference between our guide cameras are the MPixels and bit depth. Is it possible the extra “weight” of your files to cause that? Have you tried setting the camera to 8bit?
2 months 3 weeks ago #82824

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 4
I'm a little bit afraid if the problem will occure or not...

Would be great if the final solution will be part of INDI 1.9.6. Unfortunately for Astroberry this packet will be updated 2-3 weeks after Stellarmate.
So I will wait before buying the camera. and hopefully we will see the solution in the release-note..
2 months 3 weeks ago #82837

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 3
Yes, I have tried the camera in 8 and 16 bit mode and even with binning 2 and 3 the issue occurs. As well in in Stellarmate internal guiding as in PHD2
2 months 3 weeks ago #82840

Please Log in or Create an account to join the conversation.

In StellarMate you can try the latest changes either by switching to Beta channel or running the following commands in the terminal:
update_indi_core
update_indi_drivers
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Hartmut
Last edit: 2 months 3 weeks ago by Jasem Mutlaq.
2 months 3 weeks ago #82845

Please Log in or Create an account to join the conversation.

  • Posts: 194
  • Thank you received: 16
I’ve updated my mini pc to the latest Kstars beta and I’ve noticed that if I select the Touptek driver for my Omegon cameras, the app crashes, but if I select the Omegon Pro works fine.
2 months 3 weeks ago #82877

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 3
Hello Jasem,
I recently bought the Omegon GUIDE2000C (Color Version) and was unable to get it to work with the default toupcam driver.
However, browsing the sources, I noticed the Product ID (0x1367) missing in the files.
Maybe they have a new version released?
So I assumed this model would not work for now.

Desperate I tried integrating the PID which lead to a lot of crashing.
But I than noticed Omegon has a new SDK released, which is different from the toupcam SDK.
I now integrated this Omegon SDK like the other subtypes of cams (mallincam etc).
With these changes I can use both of my Omegon cameras (veTEC -> Omegon Pro) and the Guide CAM simultanously.

After some testing I provide the changes via Pull Request.

If you want to check it out: github.com/kneo/indi-3rdparty/tree/New_Omegon_SDK_integration

Maybe this solves some issues with the Mono version as well? Unfortunately I can not test this.
The following user(s) said Thank You: Jasem Mutlaq, Euripides, Hartmut
2 months 1 week ago #83143

Please Log in or Create an account to join the conversation.

  • Posts: 194
  • Thank you received: 16
Good catch!

Something is going on for sure, cause as I can see they have uploaded a new version for ASCOM too.
The following user(s) said Thank You: Hartmut
2 months 1 week ago #83144

Please Log in or Create an account to join the conversation.

Thank you, I didn't know there was a separate SDK until now. Please test it further and submit a PR. I will test it locally to verify everything.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Hartmut
2 months 1 week ago #83146

Please Log in or Create an account to join the conversation.

Time to create page: 0.949 seconds