INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astrotrac 360 INDI Driver documentation development

  • Posts: 23
  • Thank you received: 3
Various Tabs related to Astrotrac mount in the INDI control panel

1 year 4 months ago #75935

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 3
Polar Alignment screens tested in simulation in these pictures , works perfectly in Actual imaging
1 year 4 months ago #75936

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 3
 Astrotrac 36O Documentation short version Equipment usedAstrotrac mountLatest Astrotrac FirmwareStellarmate/RPI 4 with 8gb OptionalRTCExternal USB dongle Order of connection Notes
  • Make sure all cables connected and power off
Please note 2 ways to connect RA/DEC drives
  1. RA power first then once on then after 15 or so seconds connect cable from RA to DEC , that should trigger the RA to configure the DEC as a DEC automatically
  2. However with some peoples mounts that doesn’t happen due to some issue that Richard from Astrotrac does not know how to fix in which case you have to manually configure the DEC drive as a DEC drive
    1. In this case you can connect the RA and DEC connecting cable before powering on everything or after it does not matter
    2. You then connect to the drive you will configure as a DEC drive and connect to its wifi (AstroTrac360:RA:XX.XX.XX.XX) from any device can be same or for example your phone. Navigate to the IP address via the browser and go to the console (in the UI)
    3. You type 1i50 and hit enter
    4. The drive will now disconnect itself and in a few moments will appear as AstroTrac360:DEC:XX.XX.XX.XX ( WHERE XX IS THE IP address OF YOUR DRIVE)
    5. Now the RA drive will be able to send commands via the cable to control the DEC drive
 Make sure adequate power to mount and also the RPI Steps
  1. Turn on power
  2. Configure RA/DEC drive either using step 1 or 2 as above
  3. Connect to stellarmate either via ethernet or via its internal wifi (for initial setup it maybe better to connect via ethernet to rule wifi as issue in setting up and for easier updating of driver etc)
  4. Use VNC viewer to connect to Stellarmate
    1. If connected directly to its internal wifi (hotspot) IP address
    2. If connected via ethernet then IP address is whatever was assigned to it (login to your router or whatever usual means you use to figure out the assigned IP)
  5. The following steps are only one time setups (except if you want to keep the drivers up to date can run step 8 when you have to, need internet connection so easiest option is to connect via ethernet to home router, otherwise can connect via wifi connection that has internet but you may have to connect and reconnect things in order to use it) For example the Astrotrac always requires a WIFI connection to so if you want to use it in the field with no ethernet you must have an external USB dongle so that you can connect to the mount and also to the stellar mate/RPI so that you can setup it up and control it via VNC viewer.
  6. Navigate to Raspberry Pi  Configuration from the app icon (upper left most stellar mate galaxy icon) -> preferences - Raspberry Pi Configuration - set locale and Timezone ( I usually leave others standard)
  7. Reboot the RPI
  8. Open terminal and type “update_indi_core”
  9. Install drivers for any usb dongle you use (sometimes it is not needed if drivers are included)
  10. Install drivers for any RTC module you use ( depends on one used)
  11. Open k stars -> Open EKOS
  12. It will open a equipment profile wizard
  13. Select equipment connected locally
  14. I select sky safari as an additional thing to set (you can set this up later by adding as an ‘AUX’ device in the equipment tab) and then press create profile
  15. I then setup my location In kstars using the geographic icon, I also configure k stars update everything location wise. You must have an RTC module if you want this to be remembered and the time date to be accurate in the field without an internet connection. If you use a GPS module etc then you can select the other options.
  16. I then add the mount, ccd I use simulator initially and I set my telescope information in the ‘select telescopes’
    1. I don’t add everything at same time as sometimes the RPI/OS does not setup the ports correctly and things do not work properly, this way each device is allocated a port and the profile is remembered next time you connect everything as long as the usb devices have not been moved. You may or may not have this issue depending one your devices and whether you use a hub or mix USB2 /USB 3 devices
    2. Then go to setup tab, select your profile, press the play button to start Ekos (which start the Indi server and drivers for your equipment and connect them)
    3. First time the mount is not picked up from the Network scan (this event with the new port selector), never mind, let it connect and it will fail, then navigate to the Indi control panel - Astrotrac tab - connection subtag and setup up the IP address of the RA drive your mount has and leave the port as 23 and press set.
    4. Make sure you then go back to main control tab for Astrotrac and press disconnect and before you reconnect select GEM ( you can also use single ARM mode but I don’t use it at this stage but would allow the use of no counterweights with a light setup and still allow full GOTO etc)
    5. Now press connect
    6. The mount should now automatically connect as the IP is remember and assuming you use the same wifi device on the RPI/stellarmate it would always be the same IP for the mount
    7. Note that on first connection the mount is noted to be ‘PARKED’ however if you go to encoder status in motion control tab of the Astrotrac panel you will see it tracking. On first connect simply press unpack in the main control tab and then park and thereafter the mount is under control of the Indi driver completely, otherwise I think that the inbuilt firmware of the Astrotrac forces tracking from the first powering on ( I can’t verify this but based on the proposed behaviour from the original documentation this would make sense)
    8. You should be able to see the star chart with your mount pointing to Celestial pole. You can try controlling it in the motion control and moving around the star chart to familiarise yourself with it.
  17. Attached are the screenshots for the tabs related to the Astrotrac
    1. Main control
      1. Note this is where the mount can be parked/unparked and the tracking rate, the tracking rate can be set custom in which case you enter what you want and set it and click the rate to custom and turn off tracking and then on again and that should track at your custom rate
    2. Connection
      1. This is set once ignore the version and interface it never seems to change even with updates of the driver
    3. Options tab
      1. Nothing really is changed here
    4. Alignment
      1. Make sure to press nearest plugin and press OK to reinitialise the plugin
    5. Motion control
      1. Here you can control the mount and the rate and set acceleration etc here you can also tell what the encoders are doing, for example in parked position they should 0.00 0.00 and not move at all sometimes it changes from - to + this is just jitter in the encoder and it doesn’t affect the behaviour as the driver accounts for this jitter, in earlier versions of the driver we were getting jumping RA values during slewing and it was caused by this jitter in the DEC, it is now accounted for
    6. Site management
      1. No changes are made
      2. Not sure if the park options actually do anything there
  18. Control of the mount from kstars sky chart is pretty self explanatory
    1. Attached are screenshots, make sure it is unmarked and then click somewhere and goto, the behaviour of left and right click and how the star charts presents itself can  be setup in kstars that is outside the scope of the mount behaviour per se.
    2. Although setting up a custom parking position is possible
      1. Unpark
      2. Select goto and set as parking position in the star chart
      3. If you want to reset this back to home you can to ‘Site management’ and purge the park data and press default and then press SET  ( the values of the encoders should be set to 0, 0)  and that would reset park position
  19. To connect Skysafari to Ekos, within Skysafari go to Telescope Setup and select Meade Lx200 GPS as the mount. Use the IP address of the INDI server and port 9624 and connect. It should connect and be around celestial pole.
  20. Add other equipment as required , suggest add it sequentially
  21. Try connecting with Astrotrac mount and the RPI using completely wireless setup
  22. Now the setup should work perfectly in the field
  The following steps can be used once initial setup has been completed
  1. Connect everything with power off
  2. I don’t use guiding but use Sameer’s guide for this as the steps are correct
    1. Connect the ST4 cable for autoguiding from the guide camera to the Astrotrac RA drive before powering it up.
    2. I do note that the driver logs do show that the Astrotrac guider port is ready despite me not connecting anything so perhaps the St4 cable is not needed to connect before power on as the indi driver forces mount to behave with an extra layer of control not just built in firmware settings, maybe Jasem can say something about this behaviour.
  3. Power everything up
  4. Wait a few moments then connect the link cable to DEC drive
    1. In my case if I would have to then still configure my DEC drive as a dec drive as outlined above
    2. Otherwise since I don’t guide (for now) I connect my link cable between the RA and DEC drives before power up and then setup up the DEC drive as a dec drive later as outline above
    3. Normal behaviour is for the RA drive to set the DEC drive once its connected but see the issues outlined above
  5. Go to kstars and open Ekos
  6. Load profile and start and connect equipment
  7. I then  focus or run an autofocus routine before next step
 At this I polar align with Ekos
    1. Go to align tab
    2. Go to polar alignment
    3. Set speed to x800, rotation at 30 degrees, slew east or west depending on where you have access to the sky if not limited then can do whatever. Speed can be anything but to get done faster better quicker.
    4. Press Start
    5. It will take a picture, solve, then rotate 30 degrees
    6. Then take second picture, solve, then rotate 30 degrees
    7. Then take third and final picture
    8. It will calculate Polar alignment error
    9. Then you select next and press refresh (every 1 sec is ok can go higher or lower if you want)
      1. Begin adjusting the altitude along the yellow align
        1. With the astrotrac wedge do small turns if very close or larger turns if far away and the closer you get the smaller your turns get sometimes 1/16 of a turn or smaller, make sure the various knobs are just loose (see the astrotrac manual for how to use the wedge properly)
      2. Adjust the azimuth along the green line
    10. You can repeat the run if you want
    11. Notes
      1. Don’t use a super zoomed in view of the of the picture otherwise it lags and crashes , I suggest zooming in a click at a time till you can see what you need and not to go to fully zoomed in
      2. Live PA error updating works but can be slow and causing it to behave erratically
      3. Refresh more frequently than one second helps PA but at risk of not seeing the star correctly
      4. Make sure GAIN and exposure are set properly
      5. The solver has no issue with using 2x2 binning etc, I used to use 1x1 as on other software it cause failed solves but Ekos seems to account for the binning and correctly calculates the appropriate location
      6. I can get within 15arc sec before I get inpatient and I get easily 10min unguided at 250mm FL with APS-C sized camera sensor
      7. It takes approximately < 5min to do so
    12. Close k stars and shutdown the RPI
    13. Proper shutdown is critical otherwise the software can get corrupted and the mount is not connected to correctly
 Issues/Important Notes
  1. Serial timeout error
    1. I have not had any in relation to power issues although sameer has had so
    2. The MAJOR problem appears to be wifi interference
    3. Most current RPI OS seems to have disable the low power states and wifi power management, there are useful commands online to check and force to turn it off but in Stellarmate it appears off.
    4. The other ODD behaviour is if you hover over the ethernet/wifi icon in the taskbar of the OS it immediately throws a serial timeout error, this is repeatable.
    5. Initially I thought its because it refreshes the list of wifi devices seen by the internal wifi , I disabled this from booting completely and it showed the same behaviour
    6. So once the astrotrac is connected, DO NOT check the wifi signal or connection from the operating system icons.
    7. Sometimes though you accidentally hover there and it will throw an error. I find disconnecting the Mount and reconnecting from the indi control panel stops any further serial timeout errors, if you don’t the errors build up and it becomes unstable till you do a hard reset
    8. I use USB 3 SSD drive and various wifi devices including other 5ghz and 2.4ghz things. The mount does not have 5ghz wifi as I have confirmed with Richard from Astrotrac.
    9. The serial errors also show up in The sky X and seem to also have to do with getting a robust signal , the aluminium of the mount and surrounding hardware must cause some packets to be corrupted
    10. I fixed this issue with purchasing a high gain usb external wifi dongle
      1. SINCE this I have not had any serial timeout errors
    11. The combination of a strong wifi dongle and avoidance of the things mentioned above has resulted in 0 serial timeout errors for me
  2. Hotspot connection
    1. This appears to be perfectly adequate for maintaining a strong connection especially since the default behaviour is 5ghz rather 2.4ghz in version 1.6, previous version would not connect the hotspot in a 5ghz mode , there seems to something baked into the Stellarmate OS that makes the behaviour of the hotspot persistent
  3. If you bring your own RPI make sure the RTC module is installed otherwise the alignment with the mount is confused
    1. Jasem has built in drivers in Stellarmate for some RTC and GPS modules in his documentation I can not remember which one
    2. Without that you may have issues in getting time and date and therefore correct tracking , solving and star charts in kstars, this is not a problem when connected to the internet but in the middle of nowhere it can be.
  4. You can still connect to the RA and DEC drives via the UI and web browser as documented in the Astrotrac manual even whilst connect to the mount via the indi driver, although I advise not to stay connected to it as it may confuse it. Furthermore certain functions like changing tracking rate etc appear to do nothing once connected via the indi driver although things like turning of lights etc still work
  5. Skysafari works fine and it updates both the location of the mount in the kstars chart and on your phone, it can be a bit laggy I have found and at least Its iPhone 12max it appears to take a minute or to connect the interface but then it works ok, I would not advice to sync via just to navigate around the sky, no option. There seems to be some lag or sometimes the skysafari and the sky chart don’t correlate if you do a manual rotation by loosening clutches.
  6. Single ARM mode has not been used but I assume the driver would work there as well (Jasem can confirm or not)
  7. You can adjust the mounts position manually with the clutches off and the drivers know exactly where it is due to the encoders. The kstars accurately reflects the position change.
  8. Sometimes if things behave erratically just do a hard shutdown and then power down and wait a few minutes and restart as per and everything works ok.
  9. Mount modelling is not the same as Tp point in the Sky X plugin which is also available for this mount as that account for different things , I am not quite sure if this is a traditional model similar to EQMOD, maybe Jasem can help here.
 Conclusion:I have been able to use this setup with the above devices in fully headless mode completely wireless with the astrotrac mount.
1 year 4 months ago #75937

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 3
No problem

Below/above is the 'short' version with little reference to other devices

Its a device that needs some detail to setup correctly unfortunately.

You can ignore the Polar Alignment component if you want but some of it is relevant

The rest is pretty important to know I think
Last edit: 1 year 4 months ago by Abdi. Reason: Location of previous post
1 year 4 months ago #75938

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
Hi guys,

I went and got the Brostrend antenna mentioned above. I was able to install the driver, with some difficulty at first buy I managed to do it in the end. I think it is working but I am not really sure. Is there a way to see if it is actually working?
I will try it with the astrotrac as soon as I can. Hopefully the connection will then be a lot more stable as I have had problems with that as well.
I recently talked to Richard to see if there will be goto available for the mount any time soon via his own web interface or even directly via Skysafari, which by the way I cannot seem to connect via Stellarmate for some reason ( from my Ipad). I get the impression that I have a version that does not work for that. Anybody have any idea?
Anyway Richard said that he didn't have any plans to implement that any time soon but that anybody with the proper coding skills could do it as it is open source software that can be expanded beyond the basic capability that is there now. Would something like that be possible, since a lot of knowhow has gone into this driver that is now available? Or is that something completely different? I unfortunately do not have those skills or I would definitely give it a shot.
Also are any of you talking to the people behind Asiair for the incorporation of this driver in their software?


1 year 3 months ago #76481

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
Hello Gents,

I could use some help here. I tried to use my StellarMate again to connect to the Astrotrac. It connected fine, no problem there. It is the parking and unparking that does not seem to work. When I first connect, the mount is immediately unparked and tracking. I can turn tracking off, that works. I can move in all axis with motion control and I can give a goto command in Kstars. When I try to park the mount however it only parks the RA drive and not the Dec drive. It just stays where it is. Encoders are working normal. I tried via the regular Astrotrac interface as well as in the driver is show the different encoder positions. I did update all my drivers before I started, however the Astrotrac version still is on version 1.0 and interface 5. Don’t know if that is correct.
Hope somebody can help me troubleshoot this.


9 months 1 week ago #82477

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 4
Happens to me sometimes but doesn’t happen at other times. Not a showstopper.

On the version, even mine shows 1.0 even though I have updated the drivers.

9 months 1 week ago #82478

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
Thanks Sameer, strange, but I’ll see if I can get it to work under the stars this week.
I was thinking that maybe things would get confused if it didn’t respond to those commands.


9 months 1 week ago #82479

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
Looks like it is not bothered by the park and unpark commands not working properly indeed. Seems that every time I make some kind of command that involves the dec drive it shows a timeout serial error, even though it seems to be doing what it is supposed to do. I also use an external dongle to connect StellarMate to the mount and that seems to work ok, but still getting a lot of those timeout errors.
9 months 1 week ago #82492

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 3
The serial times out errors are a problem.

I found that using a high gain external wifi dongle on the stellarmate via one of its usb 2 ports is the best bet with regards to minimising the errors. The antenna has to be setup just so and I’ve posted about my setup before. I feel that there must be some interference with the aluminium body of the mount and the stellarmate despite Astrotrac saying there shouldn’t be. I briefly discussed with Colin who wrote the theskyx drivers and he noticed frequent wifi issues even and timeout issues even when using a windows laptop.

Once you get a run of serial timeout errors its more likely to keep happening in which case I suggest disconnecting mount from ekos/k stars and reconnecting it. Also whilst the mount is doing slews etc avoid lookout at the taskbar of the stellarmate. I noticed everytime I hovered and pressed over the taskbar for example to check the network connection strength etc a serial timeout error would be triggered. And if I didn’t stop doing it it kept happening and in my view it “corrupts” the session so disconnect and reconnect renews the setting. This is whilst using vnc to connect to it from my mac.

Now no one seems to know why that error happens for sure but this is what I have found. On its own the wifi broadcast from the mount seems robust it’s just a matter of the other device consistently picking it up or not.

When I spoke to Richard from astrotrac he stated that during testing the wifi connection were tested for days at a time to check data transmission and integrity and apparently was ok. But obviously the same error happens on both the skyx driver and also this indi driver.

Maybe you all might have an idea.

But short of it is if use high gain antenna as desribed above and dont play around in the stellarmate /os taskbar outside of ekos/kstars it seems not to have any errors.
9 months 1 week ago #82498

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 4
My observations are consistent with your findings. The serial error is definitely linked to interference. Happened to me indoors while testing the driver. Less often outside. Unfortunately, I haven’t had much sky time with the mount in the last few months.
9 months 1 week ago #82499

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 3
And additionally apparently its not best practice to be connected to mount via the ui and a web browser AND external control software such as stellarmate or theskyx.

So you can get into the Ui first via web browser setup the mount /or in my case force the dec to be a dec /other settings/ then close that connection/refresh browser, then connect to the mount via ekos/kstars.

Turn on mount without turning on stellarmate
setup mount via web browser as required
close browser
turn on stellarmate ensure antenna is best positioned minimise usb 3 interference
connect to mount and gear from ekos/kstars
avoid using the stellarmate os taskbar once connected

9 months 1 week ago #82500

Please Log in or Create an account to join the conversation.

Time to create page: 1.377 seconds