×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Skywatcher AZ GTi with Ekos

1 year 3 months ago
tkottary
Expert Boarder
Expert Boarder
Posts: 125
More
Skywatcher AZ GTi with Ekos #31079
Sorry , I am travelling so have limited access to internet.

I don't use stellarmate so i cannot answer from that perspective. Assuming everything went fine, fire up ekos choose indi_eqmod_telescope as telescope driver and in the connection settings chose UDP 192.168.4.1 and 11880 and try to connect.

Please Log in or Create an account to join the conversation.

1 year 3 months ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31080
this ip/port worked when stellarmate was connected to the mount.
now, if we assume that the mount is connected to the stellarmate the port doesn't work.

btw, when you enable the Station Mode, do you disable the AP mode?
If the AP is disabled how would one connect to the mount with synscan to use the mount or change settings?
confused..
thanks!

Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago
stash
Platinum Boarder
Platinum Boarder
Posts: 350
Karma: 4
More
Skywatcher AZ GTi with Ekos #31109
An alternative I use for mobile use(in the field) is to use a Std AP (mine is a TP-Link 2.4 and 5GHz) - IMHO The RPI3 wireless is stable its just not powerful !

My AP is 12v DC powered (most are DC powered even if the use 240ac/dc wall adapters) - its not the most elegant solution but it work 99.99% of the time and RPI3 ,RPI Zero (w) i use stay connected for hrs without missing a beat.

The AP provides the DHCP addressing (if required) and the RPI and any other device can be set in "Station Mode" which means less work for the Soft AP software and better wireless connections. Note as there is no DNS I use IP addresses.

As my AP also has wired lan ports I could ,if I wanted to, connect the RPI3 using its wired port for the best Lan connection - My AP sits on a tray under the scope.

Doing some testing I am able to connect to my system from over 50m away and the Wireless survey APP on my phone says 95% signal (2.4ghz) and I get a consistant 72mb between the RPI3 and the AP.

When I use the same kit at home I don bother to put the AP outside I just connect it to my Home network via its WAN port and the "Mobile" set up continues as normal except it now has a Internet connection.

An alternative solution, to think about, to solve your problem.

P.S. Switching off Wireless encryption also improves wireless speeds/reliability .
I dont use Stellarmate but Ubuntu Mate 16.04 with Indiserver - The RPI Zero(w) uses std Stretch Deb OS running Indiserver - but normally I just use the RPI3 running Indiserver for Mount/Camera - Ekos/Kstars runs on a PC.

Hope that has "clouded" the picture :-)

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????

Please Log in or Create an account to join the conversation.

1 year 3 months ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31111
Stash - thanks!
Something like this? www.amazon.com/TP-Link-Wireless-Portable...Router/dp/B00TQEX8BO
I used to use similar thing for my CarPC setup a few years ago. Forgot all about it.

Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago
stash
Platinum Boarder
Platinum Boarder
Posts: 350
Karma: 4
More
Skywatcher AZ GTi with Ekos #31112
No mine is this beastie - www.tp-link.com/us/products/details/cat-9_Archer-C7.html - yes sledge hammer etc

but the Nano portable should work - worth a try :-)

At least you won;t have to worry about doggle drivers for the RPI :-)

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
The following user(s) said Thank You maxthebuilder

Please Log in or Create an account to join the conversation.

1 year 3 months ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31114

Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago 1 year 3 months ago by maxthebuilder.
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31370
Still fighting with this...
Stellarmate, by the way, is just an RPI with kstars/ekos and some other stuff preinstalled/preconfigured and it's great.

Anyway, in my case, if RPI/stellarmate hotspot is active, it can't connect to any other wifi network (i.e. to the mount).
As far as I understand, Stellarmate team did some tricks to make it possible - one adapter, two connections. But it doesn't work for me for some reason.

OK. I succeeded in putting the AZ-GTI in the Station Mode for it to auto-connect to Stellarmate hotspot.
It connects and the mount gets 10.250.250.16 address.
When I use this address instead of 192.168.4.1 in Ekos to control the mount it works!
So, I am good for now - thanks!

Jasem - if you are reading this - I made it work but it should be different/easier in SM, right? What's wrong with my setup?
Thank you!
Max

tkottary wrote: Sorry , I am travelling so have limited access to internet.

I don't use stellarmate so i cannot answer from that perspective. Assuming everything went fine, fire up ekos choose indi_eqmod_telescope as telescope driver and in the connection settings chose UDP 192.168.4.1 and 11880 and try to connect.


Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago 1 year 3 months ago by maxthebuilder.
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31371
double post (for some reason). Please delete.

Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31372
Got this thing. It worked for a couple of hours and then died. Too cheap... the unit is great if you can get a good one. I returned (defective) mine.

maxthebuilder wrote: Thanks for the idea! Ordered this - www.amazon.com/GL-iNet-GL-MT300N-V2-Repe...atible/dp/B073TSK26W


Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago
knro
Administrator
Administrator
Posts: 7602
Karma: 51
Skywatcher AZ GTi with Ekos #31376

OK. I succeeded in putting the AZ-GTI in the Station Mode for it to auto-connect to Stellarmate hotspot.
It connects and the mount gets 10.250.250.16 address.
When I use this address instead of 192.168.4.1 in Ekos to control the mount it works!
So, I am good for now - thanks!

Jasem - if you are reading this - I made it work but it should be different/easier in SM, right? What's wrong with my setup?


I didn't know you can put mount in Station Mode, how did you do that?

I will write documentation for AZ-GTi.. now the documentation is part of EQMod, I think I should split it to add these specific instructions.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 3 months ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 285
More
Skywatcher AZ GTi with Ekos #31387
-- Connect to AZ-GTi "SynScan_xxxx" wifi hotspot
-- Start/connect SynScan app
-- Go to Settings/Wi-Fi settings
-- There are two sections - Modify Access Point and Modify Station
-- Click Modify Station - there you can enable it (it's disabled by default) and put Stellarmate SSID and password
-- Both modes can be enabled at the same time

Also. From firmware changelog:
Version 3.13
  July 20, 2018
    1. Change timer for defaulting WiFi to 1 hour
    2. Force to use AP only mode if the WiFi module cannot join a valid WiFi network in STA only or AP-STA mode.
Version 3.10
  Oct 17, 2017
  1. Fix a bug which prevents the build-in Wi-Fi module working in STA only mode.
  2. If the access point for the STA mode is not valid, turn on build-in Wi-Fi's access point automatically.

Thanks!
Max

knro wrote:

OK. I succeeded in putting the AZ-GTI in the Station Mode for it to auto-connect to Stellarmate hotspot.
It connects and the mount gets 10.250.250.16 address.
When I use this address instead of 192.168.4.1 in Ekos to control the mount it works!
So, I am good for now - thanks!

Jasem - if you are reading this - I made it work but it should be different/easier in SM, right? What's wrong with my setup?


I didn't know you can put mount in Station Mode, how did you do that?

I will write documentation for AZ-GTi.. now the documentation is part of EQMod, I think I should split it to add these specific instructions.


Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

1 year 3 months ago
stash
Platinum Boarder
Platinum Boarder
Posts: 350
Karma: 4
More
Skywatcher AZ GTi with Ekos #31389
Maxthebuilder - glad you have your set up working and I did expect he "Cheap AP" to fail but hoped it would be ok :-( - hence I use a TP-link - still cheapish but good robust h/w.

IMHO The problem with making the RPI be the AP it has to do a lot of work - be a AP,DHCP,DNS and as the RPI3 still shares the USB channel with he Ethernet/Wifi I think we are asking a lot of the little device if you add in Mount,Camera etc - remembering the AP,DHCP,DNS carry a lot of overheads in terms of network management messages.

If Stallemate can work in Station Mode (RPI3 default) and you can attach your "comms" to your home or travel AP network I think performance and wifi problems will diminish. Especially as the RPI WiFi signal is not that strong IMO

But I understand the "does it all" commercial approach :-)

"Both modes can be enabled at the same time" - IMHO I would never do this again asking a lot of what is most likely a ESP826 or ESP32 chip.

Again glad you are getting somewhere !!! :-)

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????

Please Log in or Create an account to join the conversation.

Time to create page: 0.571 seconds