×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

EQMod alignment/slewing

  • Posts: 38
  • Thank you received: 4

EQMod alignment/slewing was created by Lichtagent

Dear star friends,

it‘s me again :)

Despite numerous threads and really informative tutorial videos from Jasem I‘m still lost with my EQ6-R when it comes to pointing and slewing.
I‘m using a mobile setup and have to start over the alignment each and every night. My equipment is connected to my RPi running StellarmateOS and ist up to date with KStars/INDI bleeding/nightly. After trouble with different timezones I retired my GPS-module for the moment, so that the system time and thus KStars is getting correct timestamps via NTP.
I‘m controlling KStars/Ekos via VNC .

Let me tell you my normal routine (which has worked for me on SGP/Ascom really well) and please feel free to give advice at any point.
After setting up my equipment and polar aligning the mount the telescope is pointing in direction of the NCP.
Normally I‘d take a photo and platesolve and sync my mount.
When trying to slew and sync to a target afterwards my mount moves to absolutely erroneous positions pointing my telescope to the horizon, directly in the trees or even worse observing the ground...

The problem seems to be the initial positioning, but I don‘t get the point where I‘m doing wrong. The parking position is set pointing to the NCP, so that parking/unparking gets me to the initial position.

What is the optimal sync/alignment behavior in the settings for mobile equipment?

I hope you can help

CU & CS Chris
Last edit: 9 months 3 weeks ago by Lichtagent.
9 months 3 weeks ago #31168

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 4

Replied by Lichtagent on topic EQMod alignment/slewing

BTW
I definitely understand that the orientation of the camera is absolutely random, but I‘m not sure if this has anything to do with the problem, since as far as I know the syncing uses the coordinate of the center of the picture.

Cheers Chris
9 months 3 weeks ago #31171

Please Log in or Create an account to join the conversation.

  • Posts: 510
  • Karma: 1
  • Thank you received: 73

Replied by AstroNerd on topic EQMod alignment/slewing

Hi,
First of all I had this same issue myself a few months ago, and mine turned out to be linked to using a GPS dongle, it was behaving just like yours and pointing all over the place.
So I got rid of the GPS dongle and just used the time and location from the PC, at first I still had the issues, like you, but realised it was because Ekos was still trying to use a GPS fix that was not there, in fact the GPS even though unplugged was still showing g in the INdI driver list as being there...
In the end I had to completely re install the OS...there was probably an easier way, but it worked... :)
Stellarmate OS on Raspberry pi3b+ controlled with Kubuntu laptop
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
The following user(s) said Thank You: Lichtagent
9 months 3 weeks ago #31173

Please Log in or Create an account to join the conversation.

  • Posts: 510
  • Karma: 1
  • Thank you received: 73

Replied by AstroNerd on topic EQMod alignment/slewing

The camera has nothing to do with it, orientation has no bearing at all..
Stellarmate OS on Raspberry pi3b+ controlled with Kubuntu laptop
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
9 months 3 weeks ago #31174

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 4

Replied by Lichtagent on topic EQMod alignment/slewing

@AstroNerd

Thanks Nerd ;)

The GPS dongle wreaked havoc over my time zones and although the observing coordinates were absolutely en point, the time was off by hours (at one point finding my stellarmate/RPi had the Asia/Kuwait timezone set, which I believe is Jasems natural zone, but beforehand the time worked fine).

Unfortunately this strange slewing started even before the first usage of the GPS-dongle, so I doubt that this is the origin of the problem.

As far as I analyze it, the mount (or the INDI driver btw.) is supposing that it is oriented wrong or as being on the other side of the globe (aka southern hemisphere). A straight slew from the NCP-region to M31 should be short and straight forward - nevertheless my mount tries to perform some kind of negative meridian flip (is it a nadir flip then?).
I remember my first night with Stellarmate/INDI/Ekos the slewing to M31 worked like a charm - afterwards It didn't crash that often but the strange behavior began.
While writing I realize that at some point the observatory coordinates didn't show up in the EQMod-properties - this may be part of my problem, who knows...

I'd like to know how other EQMod-users with mobile equipment are starting the night...
Or what has to be specified/entered now that I have cleared any mount-/alignment-/or other model I could find

Cheers Chris
Last edit: 9 months 2 weeks ago by Lichtagent.
9 months 2 weeks ago #31181

Please Log in or Create an account to join the conversation.

  • Posts: 510
  • Karma: 1
  • Thank you received: 73

Replied by AstroNerd on topic EQMod alignment/slewing

Yes the time zone was also part of my issue, I think it was a few issues combined to be honest, hence re installing SM and starting from scratch...
At the start of a session, it is useful to do a sync on the NCP or at least Polaris, I do, whether that helps or not I don’t know but works for me, then I usually sync on another target near to my intended imaging target, and then onto the main target of the evening...by sync I mean platesolve and sync...
Also my park position is Polaris too, so when I fire up it’s just a case of syncing straight away, but I don’t platesolve on Polaris, just sync, and then platesolve to my target.
Sometimes depending on target I may platesolve on a couple of objects on the way just to build up decent alignment data.
Stellarmate OS on Raspberry pi3b+ controlled with Kubuntu laptop
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
9 months 2 weeks ago #31183

Please Log in or Create an account to join the conversation.

  • Posts: 510
  • Karma: 1
  • Thank you received: 73

Replied by AstroNerd on topic EQMod alignment/slewing

In the EQMOD INdI driver, ha e you saved the driver settings...which you should do in all the INdI drivers I think after first use...
Stellarmate OS on Raspberry pi3b+ controlled with Kubuntu laptop
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
9 months 2 weeks ago #31184

Please Log in or Create an account to join the conversation.

  • Posts: 422
  • Karma: 3
  • Thank you received: 62

Replied by pentaxian23 on topic EQMod alignment/slewing

Ok, so its good to back off using the GPS until you've got everything else working, then review the tutorial videos about it before proceeding.

You really have to take things one step at a time. First thing is DO NOT use bleeding edge of anything or you're just asking for trouble, leave those for the developers unless you like have things break down on you or you doing it for testing purposes.

Back off and install the latest full release of StellarMate which is 1.3. Even official releases of Kstars sometimes have installation issues or bugs because the code has been tested in linux but cross compiled for other platforms.

I just updated the Ekos EQMOD module in the documentation to simplify the procedure. Read about initial setup and parking here: indilib.org/devices/telescopes/eqmod.html

So it sounds to me like you are doing what I do - .i.e. connecting kstars through the hand controller. Thats great, we need more people like you! ;-)

You don't have to do anything with the hand controller other than get to the PC Direct utility. All the information like Lat long will be written by Ekos.

All you have to do it polar align you scope with a polar scope and then connect with Ekos. When you power up the mount and it goes through initialization, you can just hit enter for every menu or if you feel better you can enter the proper info but it will be overwritten when Ekos connects.

Then set Ekos to use the default (home) park position as mentioned in the above reference and you should be ok.
The following user(s) said Thank You: knro
9 months 2 weeks ago #31185

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 4

Replied by Lichtagent on topic EQMod alignment/slewing

@gbeaton

Installing KStars/INDI bleeding/nightly was due to Jasems advice because of crashes connected with the FITS-viewer - he considered the version to be mature enough because of beeing close to the 3.0 release.

But you're right - being quite experienced in another driver/software world means little when jumping into the INDI/Ekos-universe and one should take one step after another. So I'll have a look if I've got a backup before the change to bleeding/nightly. I just have to avoid the FITS-viewer ;)

CU & CS Chris
9 months 2 weeks ago #31190

Please Log in or Create an account to join the conversation.

  • Posts: 728
  • Karma: 13
  • Thank you received: 229

Replied by TallFurryMan on topic Re:EQMod alignment/slewing

Just never sync near NCP. Move at least 15 degrees away to avoid rounding issues in the solution coordinates. Sync on Kochab.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
The following user(s) said Thank You: DerPit
9 months 2 weeks ago #31203

Please Log in or Create an account to join the conversation.

  • Posts: 510
  • Karma: 1
  • Thank you received: 73

Replied by AstroNerd on topic Re:EQMod alignment/slewing

Hmmm, interesting I always do... :) seems to work for me..
Stellarmate OS on Raspberry pi3b+ controlled with Kubuntu laptop
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
9 months 2 weeks ago #31207

Please Log in or Create an account to join the conversation.

  • Posts: 934
  • Karma: 6
  • Thank you received: 239

Replied by wvreeven on topic Re:EQMod alignment/slewing

I do and it doesn’t work for me, Whenever I slew to my first target it always is 10 to 15 degrees off. Nothing that plate solving won’t fix though.
ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
9 months 2 weeks ago #31210

Please Log in or Create an account to join the conversation.

Time to create page: 0.463 seconds