×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

indi_lx200_10micron driver: small issue setting Long in scope location [SOLVED]

  • Posts: 194
  • Thank you received: 52
On a 10Micron mount, when entering a Longitude value in 'Site Management' the driver updates the mount coordinates but skips the seconds (ss) value.
For example, entering '02:38:30' in Ekos, will results in 'E002 39 00' on the 10micron handpad.

For Latitude the behavior is different: seconds are stored correctly.
Looking at the log, the reason seems to be different decimal places for Long (5) and Lat (only 2) when setting the Observer location.

<code>
[2020-11-27T19:03:52.453 CET INFO ][ org.kde.kstars.indi] - LX200 10micron : "[INFO] Site location updated to Lat 37:44:24 - Long 2:38:30 "
[2020-11-27T19:03:52.458 CET INFO ][ org.kde.kstars.indi] - LX200 10micron : "[INFO] Observer location updated: Longitude (2.63556) Latitude (37.74) "
</code>

Tested using Kstars 3.50, Indi 1.8.7 but was also on previous version.

I wasn't able to find in the source code where the Observer location is set. It's not in the telescope / mount drivers.

Ferrante
Last edit: 3 months 3 weeks ago by fenriques.
4 months 3 weeks ago #63499

Please Log in or Create an account to join the conversation.

  • Posts: 64
  • Thank you received: 32
Adding a cross-reference: this issue is tracked here github.com/indilib/indi/issues/1270

I have the beginnings working too, here's some debug output that shows seconds and a fraction :
```
#:U2#
#:Gg#
-005:31:46.2#
```

The PR with the fix : github.com/indilib/indi/pull/1296
The following user(s) said Thank You: fenriques
Last edit: 3 months 4 weeks ago by H__.
3 months 4 weeks ago #64905

Please Log in or Create an account to join the conversation.

  • Posts: 194
  • Thank you received: 52
thanks Hans for taking the time to fix this!
I will test as soon as the PR is merged and build (i cannot build on my remote system where the mount is)

Ferrante
3 months 4 weeks ago #64921

Please Log in or Create an account to join the conversation.

  • Posts: 64
  • Thank you received: 32
The Pull Request is merged into the master branch. This means that ultra high precision geographic coordinates are now part of INDI and will be available in the next build.
The following user(s) said Thank You: fenriques
3 months 3 weeks ago #65206

Please Log in or Create an account to join the conversation.

  • Posts: 194
  • Thank you received: 52
Installed the latest build and tested the new geographic coordinates setting.
Now both Lat and Long now have s.f precision.
Ekos was set as 'Mount updates Kstars' with time and location checked but this setting should not affect the behavior.
Also used the [-180, +180] notation for Long.

Thanks Hans for taking care of that!

Ferrante
3 months 3 weeks ago #65264
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 64
  • Thank you received: 32
Cool that it works for you.
I have not found the cause for Latitude roundings (like your 23.9 to 24.0) . I saw it only in EKOS, and could not reproduce in dcd . py (dcd . py did not round)
update: added spaces around the dot in dcd . py so that it's not made a URL :/
Last edit: 3 months 3 weeks ago by H__.
3 months 3 weeks ago #65267

Please Log in or Create an account to join the conversation.

Time to create page: 0.438 seconds