×

INDI Library v2.0.0 Released (01 Feb 2023)

Bi-monthly release with major changes to INDI properties and client API in addition to new drivers and improvements.

New AZ-EQ5

  • Posts: 5
  • Thank you received: 4

New AZ-EQ5 was created by Martin

Hello after reading about the indi project I was excited to give it a try,

I am getting the following error with my AZ-EQ5. This is a new mount and even with EQMOD it needs custom advance settings for the stepper motors to be intialized: Total Steps 5184000 Worm Steps 384000

Failed to connect to port /dev/ttyUSB0. Error: Parameter error

I set the dialout group and that all seems to work the usb port is identified. I am connecting directly to the USB port on the mount. Everything works fine with EQMOD however I can't get any other info out of the log file other than "Parameter error"

Thanks for any advice,
7 years 1 month ago #6237

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic New AZ-EQ5

Did you try using the synscan driver?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 1 month ago #6263

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 4

Replied by Martin on topic New AZ-EQ5

Thanks, Yes I tried the Synscan and a few others that looked interesting however each one returned that message.

Is there a way of getting more information out of the log? I tried clicking all the log checkboxes however nothing else. I noticed there is a debug version of indi if that would help. Anyway thanks just looking at other solutions out there this looks like a fun project.

I am using the virtual machine that was assembled, and then I applied all the updates.
7 years 1 month ago #6311

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 88

Replied by Jean-Luc on topic New AZ-EQ5

It seems to be a communication error with /dev/ttyUSB0. Either when setting the parameters, or when reading response and getting -1 as number of bytes read.The AZEQ5 has a USB client port (type B ) which can be used to communicate directly with a computer. I suppose this is the one you use. Try typing lsusb in a terminal to see which USB-RS232 chipset is in use. Concerning indi drivers, you may use either indi-eqmod or indi_skywatcherAPIMount (in altaz mode). Recent Skywatcher firmware use autobaudrate when initializing the RS232 communication, so if the mount has already been initialized, this may be a problem as indi-eqmod defaults to 9600 bauds. So you may try to change the baudrate in the indi-eqmod driver. Finally you could also check the connection by hand using minicom or picocom to directly talk to the mount and sets the communication parameters (should be 8N1 i.e. 8bits, no parity, one stop bit). If you succeed to connect using minicom or picocom, try sending :e1 followed with ctrl-J and sees if there is a response (should be a = sign followed with some figures).
If you use a virtual machine, the host os (or a process on the host os) may also interfere with the communication.
The following user(s) said Thank You: Martin
7 years 1 month ago #6346

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 4

Replied by Martin on topic New AZ-EQ5

Thank you for the reply this was quite useful.

First of all the onboard USB Chipset is: "pl2303 prolific"

I was unable to connect to the mount with the minicom. However I tried it with my host machine and it worked (through Putty) the :e1 command reported the motor drive version 030106.

I also tried on a second computer (virtualbox). So it would seem the biggest issue I have is it does not appear to be working through the virtual machine at this point. This is unfortunate for testing purposes but I may have an older computer that I may be able to install Ubuntu native so I can test with.

Thanks again.
7 years 1 month ago #6350

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 88

Replied by Jean-Luc on topic New AZ-EQ5

Did you google for virtualbox usb share on windows host? It seems that virtualbox should install an USB filter driver, and that you have to make some adjustments when switching from host to guest OS. But I don't use it so can't really help.
7 years 1 month ago #6353

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 4

Replied by Martin on topic New AZ-EQ5

Hi everyone, just an update. I installed Ubuntu 15.10 on a separate physical machine and had the exact same problem. I do have some more information:

It's reporting that it's attempting to set the baud rate to 49664 instead of 115200 which is selected. When choosing other baud rates it shows the correct parameter.

When I try minicom it did not work connecting to the port so I installed putty for ubuntu and it worked perfectly reporting the motor version!

So I ask if someone could check the baud rate 115200 is in fact setup to be passed, and if so where is this 49664 number coming from.

Thanks!

PS. 115200 is the required baud rate for this mount.
The following user(s) said Thank You: Jasem Mutlaq
Last edit: 7 years 1 month ago by Martin.
7 years 1 month ago #6411

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic New AZ-EQ5

You are right, there was a problem with the baud rate and it is now fixed. Should be available in tomorrow's PPA. Thanks!
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Fausto Barbosa
7 years 1 month ago #6412

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 5

Replied by Fausto Barbosa on topic New AZ-EQ5

I have the same mount and I'm experiencing the same problems in ubuntu 14.04.
When I set the baud rate of the Eqmod driver to 115200 it gives the following message:
Connecting to port /dev/ttyUSB0 at speed 49664
I checked that the 230400 has a similar error but the other baud rates report the correct speed.

I searched in the source files for this option but didn't found it.
While the change is not included in the PPA, could you tell us in which source file can we make the correction?
7 years 1 month ago #6418

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 5

Replied by Fausto Barbosa on topic New AZ-EQ5

Entilza,
have you been able to connect with eqmod driver?
Let me know about your progress.
Using the screen serial terminal set to 115200, I receive =030106 in response to :e1
But the driver still cannot connect at 115200.

The good news is that I have successfully connected trough a separated USB->SERIAL converter and the SERIAL->AUTO-GUIDE port in the hand controller using the indi_synscan driver. With this set up the kstars program is able to slew nicely the mount however, with the program I wanted the most, PHD2 (autoguiding program), I'm having some problem that I cannot solve.
In PHD2 the indi configuration window connects nicely to the mount but when I close this window and try to reconnect from the main program window, I get only Connection Failed. :(
So none of the ways are working for me.

Thanks for any help.
7 years 1 month ago #6508

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic New AZ-EQ5

The prior fixes were not propagated to EQMod, so I just did that. With tomorrow's PPA, you can connect @115200. Regarding PHD2, did you try Ekos guide module first?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 1 month ago #6509

Please Log in or Create an account to join the conversation.

  • Posts: 193
  • Thank you received: 46

Replied by Gerry Rozema on topic New AZ-EQ5

I have realized today, the changes I propogated out the other day for the synscan driver are indeed broken. The quick work around, dont set any sync points. If you do, then you need to turn off the alignment layer in the alignment tab after setting a second one, because the data will quickly become garbage if you dont.

I'm working on trying to figure out what's wrong, and how to fix it, but I dont have a solution that works in all cases yet. If I cant get it working this evening, I'll revert the current driver code back to what it was before this round of updates went in.
The following user(s) said Thank You: Fausto Barbosa
7 years 1 month ago #6511

Please Log in or Create an account to join the conversation.

Time to create page: 1.277 seconds