×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

SOLVED: SM 1.6.0 - polar alignment DISABLED: FOV must be 10 arcmins and guider timeout

  • Posts: 613
  • Thank you received: 58
Hello,
After updating my RPI4 to SM 1.6.0, intermittently, I am getting a "DISABLED: FOV must be 10 arcmins or wider. 60+arcminutes is recommended." in Polar Alignment Tab.
My FOV is more than adequate.
A reboot usually clears that issue.
Other people reported this for SM 1.6.0. 
This never happened with earlier versions of SM.

Another issue - the guider sometimes times-out, the guiding needs to be stopped/restarted.
Again, I never had this with earlier versions of SM.

I am attaching two log files.
-- shorter one. Right after "DISABLED: FOV must be 10 arcmins..." (reboot).
-- longer one. Guider timeout at 22:27:46.763.

Thanks!
 

File Attachment:

File Name: 2021-09-28.zip
File Size:1,100 KB
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
Last edit: 2 weeks 6 days ago by maxthebuilder.
2 months 2 days ago #76107
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 613
  • Thank you received: 58
I moved cables around. Seemed to help.
Tonight I didn't have the above problems.
KStars crashed once right before the second image in the sequence was completed.
Restarted KStars/Ekos. Now 3 hours in - all is well, including the meridian flip.

That's for my RST-135 setup.

Thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
Last edit: 1 month 4 weeks ago by maxthebuilder.
2 months 1 day ago #76151

Please Log in or Create an account to join the conversation.

  • Posts: 613
  • Thank you received: 58
Two nights in a row - not a single problem.
So, the problems I was originally having were most likely due to flaky cabling.
I am glad I got this sorted out.

Thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
1 month 4 weeks ago #76248

Please Log in or Create an account to join the conversation.

  • Posts: 299
  • Thank you received: 22

This was a big and was fixed in the nightly beta a couple of days ago
Clear Skies!
Mohamed

Permanent
C9.25, HEQ5, Pi 4 Kstars/Indi, MyFocuserPro2, OAG with ASI120MC guide, f/6.3 reducer, ASI533MC Pro

Portable
WO Z61, iOptron SmartEQ Pro+, Pi 4 Kstars/Indi, MyFocuserPro2, ZWO OAG with ASI120MM guide, ASI183MM Pro, ZWO EFW (LRGBHaS2O3)
1 month 4 weeks ago #76256

Please Log in or Create an account to join the conversation.

  • Posts: 613
  • Thank you received: 58
I am not sure what the root cause of this might be...
I had it several times randomly and it would go away after a reboot.
Didn't install any updates/nightlies and recently had three nights in a row without this problem.
I did rearrange the cables though.
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
1 month 3 weeks ago #76428

Please Log in or Create an account to join the conversation.

  • Posts: 299
  • Thank you received: 22

I think had had to do with the sequence of which your equipment connects to to indi, so sometimes your camera comes last and it’s pixels size is recorded as zero
Clear Skies!
Mohamed

Permanent
C9.25, HEQ5, Pi 4 Kstars/Indi, MyFocuserPro2, OAG with ASI120MC guide, f/6.3 reducer, ASI533MC Pro

Portable
WO Z61, iOptron SmartEQ Pro+, Pi 4 Kstars/Indi, MyFocuserPro2, ZWO OAG with ASI120MM guide, ASI183MM Pro, ZWO EFW (LRGBHaS2O3)
1 month 3 weeks ago #76429

Please Log in or Create an account to join the conversation.

  • Posts: 613
  • Thank you received: 58
Makes sense - thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
1 month 3 weeks ago #76430

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Hi,

I have the same issue that Polar alignment is disabled so the calculated and effective FOV in the dialogue box at the right are >90. I found several posts. (another one is indilib.org/forum/ekos/10435-polar-align...ue-to-fov.html#75957)

This chain here is marked "solved" but the solution seems to be to switch to the beta release.

Is there a way in the stable release to work aound/change a parameter etc? I don't use the beta versions so far and would need to find out how to do that. Moreover I use the stable versions mainly as the numbers of clear nights where I live is very limited (last night the first in 4 weeks).

So it would be great to understand what can be done to work around this issue until the next stable release if there is an option.

Last night was the first chance for me to use the new release. When I bumped into the problem of polar alignment right at the start I first tried rebooting and reinstalling the index files with no success. Then after finding this chain in the forum tried to switch to beta versions using the dashboard on the PI4 via VNC. This went wrong as it seem to have deinstalled parts and I finally flashed the SD card from a previous image. In the meantime I managed to polar align with a separate version on  backup SD cad and switched back to the card with the latest release. Took a while and not solved for me  - and maybe others.

Thanks for any ideas if there is a way in the stable version to work around for the time being.

Akex

 
Standard setup: EQ6R, Williams Megrez 72- ASI 533MC -ZWO EAF, 50 mm viewfinder - ASI 120MM
1 month 3 weeks ago #76438

Please Log in or Create an account to join the conversation.

  • Posts: 299
  • Thank you received: 22
Akex

Switching sometimes is troublesome. The fix should come anyway with the next stable release within the month.
Clear Skies!
Mohamed

Permanent
C9.25, HEQ5, Pi 4 Kstars/Indi, MyFocuserPro2, OAG with ASI120MC guide, f/6.3 reducer, ASI533MC Pro

Portable
WO Z61, iOptron SmartEQ Pro+, Pi 4 Kstars/Indi, MyFocuserPro2, ZWO OAG with ASI120MM guide, ASI183MM Pro, ZWO EFW (LRGBHaS2O3)
1 month 3 weeks ago #76448

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Hi Mohamed,

Thanks, I was hoping there is a way to patch or work around this for the time being. Last night was clear but the problem is still there and I stopped attempts to reboot or influence the USB connections order after some attempts.

Ok, wait and see and try to manage the polar alignment for the time being with an older version and flip SD cards in between as the latest version seems more stable otherwise ...

Thanks!

Alex
Standard setup: EQ6R, Williams Megrez 72- ASI 533MC -ZWO EAF, 50 mm viewfinder - ASI 120MM
1 month 3 weeks ago #76468

Please Log in or Create an account to join the conversation.

  • Posts: 613
  • Thank you received: 58
So... I said it was solved. Not really.
Over the past month, I was playing mainly with my RST-135 mount (which I need to setup/align every night) and 1.6.0.
There I had this error maybe a couple of times but then it just went away - everything was running smoothly for about 10 nights in a row.
Everything was running on RPI.

Tonight I switched to my permanent installation (HEQ5).
There I don't normally do Polar Alignment so I didn't notice before but when I tried I got this "FOV must be 10 arcmins" issue and I couldn't get rid of it!
I restarted/rebooted several times. Rearranged cables. Nothing helped.

I reverted back to 1.5.9 and there it worked.
On RPI.
When switched to Windows KStars client (latest stable 3.5.5) with RPI running on 1.5.9/3.5.4- I again got "FOV must be 10 arcmins" error.

Well. Hopefully it will get sorted out in the next release.
It's really behaving strangely.

Just reporting.
Thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
Last edit: 1 month 2 weeks ago by maxthebuilder.
1 month 2 weeks ago #76568

Please Log in or Create an account to join the conversation.

  • Posts: 1149
  • Thank you received: 204
I had a similar experience tonight when using the PAA on an unfamiliar mount, a Celestron AVX. New profile had default telescope focal length specifications. I would enter the focal length and hit Save tree Telescope Info, then go to the PAA and set the fov greater than 10 arc minutes warning and some greyed out PAA options. It solve the first frame then crash KStars by the next frame.
It turns out that in my haste, I did not give the telescope information configure a name. Once I did, the configuration saved properly and PAA stopped crashing. Worked flawlessly, no more 10 arc sec warning, and no greyed out options.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
2 weeks 6 days ago #77469

Please Log in or Create an account to join the conversation.

Time to create page: 0.570 seconds