×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Meridian Flip confusion

  • Posts: 49
  • Thank you received: 0
Hi all,

Since I moved from a HEQ-5 Pro to an iOptron CEM40 mount I didn't succed to perform a meridian flip.
With the hand controller I've set the mount to do the flip at 5 degrees, while in Ekos I set it to 2 degrees (all according to the  StellarMate manual ).

The mount performs the flip, but then nothing happens. With the HEQ-5 it plate solved, autofocused, reinitialized the guiding and then started capturing again after the flip.

One thing that confuses me is that in the manual it says "The mount must begin <strong>tracking east</strong> of the meridian in order to the meridian flip to be commanded in Ekos."
When I look in the INDI control panel it says in the mount's Main Cotrol tab: "Pier Side: West (poining east)". Does this mean that it is "tracking east" or what?
If not, could this be the problem? And in that case, how do I change it?

Cheers,
// Åke
Last edit: 7 months 3 weeks ago by Åke Liljenberg.
7 months 3 weeks ago #78857

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 290
Hello Åke,
pointing east should mean the same as tracking east. If your target ist east of the meridian, a GEM places the scope on the western side of the pier.

Regarding the flip: please post the log, the post flip behavior is not mount specific.

Cheers
Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
7 months 3 weeks ago #78858

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Thanks Wolfgang for your reply.

I'll try it tonight again with the log enabled.

Which options should I turn on?
My guess:
Verbose - Ouptput: File
Ekos: Capture/Alignment/Mount
Drivers: Mount

Cheers, Åke
7 months 3 weeks ago #78859

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 290
Verbosity and output are correct, for EKOS turn on (at least) all modules that you use, better simply all. For drivers, mount should be sufficient.
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
7 months 3 weeks ago #78860

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Of course everything worked as normal tonight!
The only difference since yesterday was that I performed a factory reset on the hand controller for the CEM40.
It must have been a glitch somewhere. Anyways, I'm happy the meridian flip works again :-)
Stellarmate is an amazing piece of software.
Thanks for the response.

Cheers,
// Åke
7 months 3 weeks ago #78866

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Still confused...

Yesterday evening the capturing was once again aborted after the flip!
I think it has to do with what time the mount think it is relative to Stellarmate. It seems like it was the mount that performed the flip and therefore the capturing was aborted.
This is how it looked in Ekos when I started the session (please note, latest on top):

2022-01-05T17:09:11 Telescope info updated successfully.
2022-01-05T17:09:09 Warning: Overriding WO GT 81iv configuration.
2022-01-05T17:09:09 Warning: Overriding WO GT 81iv configuration.

But please note the time (showing exactly minus one hour) in the INDI control panel for the mount:

2022-01-05T16:09:11: [INFO] Device configuration applied.
2022-01-05T16:09:11: [INFO] Mount PEC Chip Needs Training
2022-01-05T16:09:11: [INFO] Observer location updated: Latitude 57:42:07.0 (57.70) Longitude 11:46:15.0 (11.77)
2022-01-05T16:09:11: [INFO] Site location updated to Lat 57:42:07 - Long 11:46:15
2022-01-05T16:09:11: [INFO] Dome Policy set to: Dome ignored. Mount can park or unpark regardless of dome parking state.
2022-01-05T16:09:11: [INFO] Debug is disabled.
2022-01-05T16:09:11: [INFO] Loading device configuration...
2022-01-05T16:09:10: [INFO] Debug is enabled.
2022-01-05T16:09:10: [INFO] Mount PEC Chip Needs Training
2022-01-05T16:09:10: [INFO] Mount is parked.
2022-01-05T16:09:10: [INFO] Mount Location: Lat 57:42:07 - Long 11:46:15
2022-01-05T16:09:10: [INFO] Mount Daylight Savings: OFF
2022-01-05T16:09:10: [INFO] Mount UTC Offset: 1.00
2022-01-05T16:09:10: [INFO] Mount UTC: 2022-01-05T16:09:41
2022-01-05T16:09:10: [INFO] iOptron CEM40 is online.

Could this explain that the mount performs the flip, and not Stellarmate? And in that case, why doesn't the Stellarmate perform the flip one hour later?
But if the mount thinks the time is one hour earlier, shouldn't Stellarmate perform the flip before the mount?
In Ekos I've set "Flip if HA > 2.00 Degrees" and in the mount (via the hand controller" it's set to 5 degrees.

And what about the different settings; 1) Should daylight saving be enabled in the mount (via hand controller)? 2) In Ekos, should "INDI - Time&Location Updates" be set to "Kstars updates all devices" or "Mount updates Kstars"?
Please note that I have a GPS module for the CEM40 mount. Should this always be connected and then always having "Mount updates Kstars" set?
Also, in the INDI control panel, there is an option for the mount "Site management - Daylight savings". This is now set to "ON". Is this correct?

When the mount performed the flip, the CCD logged:
2022-01-05T23:21:57 CCD capture aborted
2022-01-05T23:21:57 Autoguiding stopped. Aborting...
2022-01-05T23:19:19 Capturing 300.000-second image...

To resume the session I manually triggered a new alignment ("Capture&Solve - Slew to target") and after that the guiding automatically performed a new calibration process and then the capturing process also automatically resumed.

I'm really confused - could someone please help straigthen this out?

Cheers,
// Åke
Last edit: 7 months 1 week ago by Åke Liljenberg.
7 months 1 week ago #79126

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 290
As always - please post the logs :-)
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
7 months 1 week ago #79127

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Hi Wolfgang,

The problem is this doesn't happen always, so therefore I haven't the logs turned on all the time.
I tried to submit as much information I could above, but the next time I will always have the debug logs turned on.
Though I read somewhere it's not recommended since it takes up unnecessary resources - maybe this is not true?

But could you give some recommendations on the different settings? I'm i bit confused since there are quite a few options, and in various places.

Cheers, Åke
7 months 1 week ago #79131

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 290
The simplest recommendation is: leave your logs on. You may compress them after your session. Since they are plain text, the compression rate is very good. Without logs helping is a pain for both sides :-/

In your case I would try the following:
1. Make sure that EKOS controls the MF. Set the MF delay in EKOS to 3-5 deg and only less if this is too risky. If you turn on the MF on your iOptron, be sure that its limit is greater than that in EKOS plus the longest exposure time you use. EKOS will start a flip earliest when the configured delay is reached, but it waits for a running exposure to terminate.

2. Be sure that time and location are correct and that they match in EKOS and in your mount. Typically the best solution is synching EKOS time to the mount.

HTH
Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
The following user(s) said Thank You: Åke Liljenberg
7 months 1 week ago #79135

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Thanks for the reply Wolfgang and for some good advice.

I've just done some experiments, and it seems the recommended +3 degrees (added to the Ekos HA limit) on the hand controller is on the verge.
When I set HA > 2 degrees in Ekos and 5 degrees in the mount, the mount performs the flip when Ekos says it's 8:01 minutes left to the flip.
Turning up the limit in the mount to 10 degrees works flawlessly.

Cheers,
// Åke
7 months 1 week ago #79137

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 290
Hm, that’s strange. When the mount flips as EKOS displays 8 min, this is exactly the delay of 2deg. I.e. the mount flips when it is exactly on the meridian and not 5deg past meridian. Are you 100% sure that location and time is identical in mount and EKOS?
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
7 months 1 week ago #79139

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
I'm almost certain, but let me double check tomorrow when I will try to reproduce the behaviour.
7 months 1 week ago #79141

Please Log in or Create an account to join the conversation.

Time to create page: 0.236 seconds