×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Meridian Flip confusion

  • Posts: 49
  • Thank you received: 0
I'm almost certain, but let me double check tomorrow when I will try to reproduce the behaviour.
5 months 3 weeks ago #79141

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
OK, so I reproduced it today. And even more strangely, I've set the mount to stop when HA > 10 deg and Ekos to to a flip when HA > 2 deg.
So the mount stopped moving when Ekos said "Meridian flip in 00:08:01 (see pic)
As you also can see in the other pic taken a few minutes afterwards, the scope has stopped before the meridian while KStars continues to track the selected star.
I also set the mount to update Time and Location in KStars and I also verified that this was the case before the flip. Both time and location were in sync.
Attached is the debug log file.
Grateful for any help.
Cheers, Åke
 
Last edit: 5 months 3 weeks ago by Åke Liljenberg.
5 months 3 weeks ago #79163
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 938
  • Thank you received: 285
Hi Åke,
this is a clear indication that mount hardware and EKOS do not have identical time or location settings (or maybe both). Please do me a favour and reverse the time/location synching and sync from EKOS to the mount (currently, you are synching in the opposite direction).
And please post the entire log including the logging for EKOS modules. In yout latest attachment I see only the INDI part.
Cheers
Wolfgang
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
5 months 3 weeks ago #79169

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Hi Wolfgang,

I've changed to "KStars updates all devices". I also made sure the location is the same in KStars and the mount.
Three times in a row the same thing happens, that is when the target hits the meridian Ekos stops tracking (mount is set to stop when HA > 5 and Ekos flip when HA > 2 degrees).
Please see the attached logs. All shows 'Mount status changed from  "Tracking" to "Idle"' when the target hits the meridian.

To me it looks like the mount is stopping the tracking at the meridian no matter what value I set in the hand controller for the mount. Could it be a bug in the mount firmware (version 210105)?

Please let me know if there is any other setting you want me to try out.

Cheers, Åke
Last edit: 5 months 3 weeks ago by Åke Liljenberg.
5 months 3 weeks ago #79197
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Hi again,

A quick update; I thought I solved the problem, but unfortunately not.
I did a complete reset of the mount with the hand controller ("Reset All Settings"), set home position and so on.
Then I got the meridian flip to work - only once (log attached) - but after that it behaves like before again...

The mount status is set to "Idle" exactly when the target object crosses the meridian.
If there was the possibility to set a negative number in Ekos "Flip if HA >" I could probably have it work.

I'm going crazy on this!

// Åke
Last edit: 5 months 3 weeks ago by Åke Liljenberg.
5 months 3 weeks ago #79216
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Any ideas on what to do/try next? I'm going nuts... 
No one else has this problem?
Cheers, Åke
Last edit: 5 months 2 weeks ago by Åke Liljenberg.
5 months 2 weeks ago #79334

Please Log in or Create an account to join the conversation.

  • Posts: 174
  • Thank you received: 11

Replied by Ron Clanton on topic Meridian Flip confusion

I'm not sure that I can help... but since the last update I have problems with the MF. In my case, the mount tries to flip... but fails. It then retries in a few minutes and succeeds. It's like the mount doesn't think that it is past meridian. I suspected a synchronization problem, but the settings in EKOS is set to update the mount... so shouldn't be an issue.

I'm starting to think that EKOS is not truly updating the mount... but don't know how to check.

I've attached my log if anyone wants to have a look.  The first MF attempt is around 22:18.

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85, Celestron NexStar Evolution Alt/Az
OTAs: Celestron 8" Edge HD w/Celestron Focus Motor, Meade 80mm APO Triplet Refractor w/ZWO EAF
Cameras: ASI533MC Pro, ASI183MC Pro, ASI224MC, ASI120MC-S, ZWO ASI290MM
Raspberry Pi 4 with Stellarmate OS, MacBook Pro
Last edit: 5 months 2 weeks ago by Ron Clanton.
5 months 2 weeks ago #79336
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Hi Ron,

It's not exactly the same problem I have, but I recognise yours since I had similar issues earlier.
For you I guess the time and/or location are different in KStars vs your mount. Please make sure you let Kstars update both of those.

My problem is that (it seems) the mount stops the tracking each time it passes the meridian, even if I set it to stop 5 degrees past the meridian.

I hope someone has a clue why this happens.

// Åke
5 months 2 weeks ago #79339

Please Log in or Create an account to join the conversation.

  • Posts: 174
  • Thank you received: 11

Replied by Ron Clanton on topic Meridian Flip confusion

Ake,

Yeah, I checked the setting in EKOS and it is correct. I haven't had any response from StellarMate support on my problem.

I may have missed it... but what kind of mount do you have?  Have you tried calling their technical support?

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85, Celestron NexStar Evolution Alt/Az
OTAs: Celestron 8" Edge HD w/Celestron Focus Motor, Meade 80mm APO Triplet Refractor w/ZWO EAF
Cameras: ASI533MC Pro, ASI183MC Pro, ASI224MC, ASI120MC-S, ZWO ASI290MM
Raspberry Pi 4 with Stellarmate OS, MacBook Pro
Last edit: 5 months 2 weeks ago by Ron Clanton.
5 months 2 weeks ago #79340

Please Log in or Create an account to join the conversation.

  • Posts: 938
  • Thank you received: 285
Åke, I checked your logs. The first three logs you posted show all the same behavior: there is a slew to a certain position, that succeeds, but in none of the cases EKOS recognizes the necessity of a meridian flip ( I guess you slew to a position close, but east of the meridian) and then either the mount stops tracking (log 1 and 3) or parks (log 2). There is something configured in your mount that triggers this, it does not look like something that EKOS triggers.

In the latest log (that one that has been posted as a single one) the meridian flip seems to succeeds, but immediately after the flip the mount parks. I have no explanation what triggers this parking.

@Ron: in your case, it's different. The meridian flip is triggered by EKOS, but your mount decides not to switch the counterweight position. It seems like EKOS and your mount hardware do not agree whether the position it's pointing to is before or after the meridian. EKOS thinks it's beyond the meridian, your mount has a different opinion. The explanation for this is typically a time or location gap between both. If not, it typically helps increasing the meridian flip delay.

HTH
Wolfgang
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
5 months 2 weeks ago #79343

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
Hi Wolfgang,
Thanks for the reply.
What you see is exactly my problem.
The slews and parkings are made manually by me (from within Ekos), not by Ekos nor the mount itself.

I slew to a position near (1 or 2 degrees) and west of the meridian. then, after a few minutes, exactly when the mount reaches the meridian, it stops tracking.
So Ekos correctly haven't yet seen the necessity to do the flip.

The mount is configured to stop 5 degrees after the meridian and Ekos 2 degrees after the meridian.
In the CEM40's hand controller there is no way to disable the meridian treatment, I can only choose between STOP or FLIP and choose degrees between +0 and +14.
I even tried +14 but it doesn't help, the tracking still stops at the meridian.

I will check if it makes a differens to choose FLIP instead in the hand controller.
I will also test to set everything and then disconnect Ekos and see if it the mount behaves differently when it's "on its own".

Cheers, Åke
5 months 2 weeks ago #79347

Please Log in or Create an account to join the conversation.

  • Posts: 938
  • Thank you received: 285
That's really strange. But I would really be surprised if this behavior results from EKOS. Have you tried to get an answer from an iOptron Forum or their support?
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
5 months 2 weeks ago #79359

Please Log in or Create an account to join the conversation.

Time to create page: 0.482 seconds