×

INDI Library v2.0.0 Released (01 Feb 2023)

Bi-monthly release with major changes to INDI properties and client API in addition to new drivers and improvements.

USB Device Recognition Issues (QHY only?)

  • Posts: 6
  • Thank you received: 0
Looking for some guidance, (I use stellarmate OS on my RPi4). Have had little to no issues before last night with the RPi4 recognizing my cameras and mount via USB, but as of last night right before the meridian flip it no longer recognizes the QHY cameras (QHY168c - USB interface and 12V power and QHY5L II M - direct power and data from USB). It does however recognize the Nexstar + hand controller for my CGX L, but only when that is the only USB plugged in, not when cameras + mount are connected.

For troubleshooting, I have tried using different cables, tried using just one camera and no other USBs, have tried turning on/off, unplugging and re-plugging everything, checked for updates. Nothing on the RPi4 is indicating low power from the adapter.

I thought perhaps it might be a USB power consumption issue (even though I haven't had issues in the past), so I got a powered USB hub with an external adapter and the same issues arise; no recognition of the QHY cameras but the Nexstar HC is recognized through the hub. Makes me feel less like it is a USB power issue with that being the case.

I guess my next plan is to get a new power adapter for the RPi4, maybe overall there isn't enough power to the board?
Any other ideas or thoughts on troubleshooting? Any other details I can help provide?

Quick edit;

I had a ASI290mm mini that came in a couple days ago. I tried that out in both USB 2.0 and USB 3.0 ports and the RPi4 recognized and connected. Seems like the issue is isolated to the QHY168c and QHY5L II M? I noticed the red light on the QHY5L II M doesn't come on either, indicating that power isn't being received.

Another quick edit;

the QHY168c, QHY5LIIm, and QHY polemaster cameras are all showing up using lsusb and dmesg. Any idea why kstars doesn't recognize it? Also the red light on the back of the QHY5 guide cam doesn't light up.

Bus 001 Device 036: ID 1618:c167 Cypress WestBridge
Bus 001 Device 035: ID 1618:0920
Bus 001 Device 034: ID 1618:0940
Last edit: 9 months 3 weeks ago by Dalton . Reason: more context
9 months 3 weeks ago #82332

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
I ended up flashing a new SM OS onto a new SD card and everything is running as it should now. QHY cameras are all recognized and connect via USB and KSTARS. Something must have gone wrong during an update I guess, I really don't know what caused the issue. Any who, problem solved.
9 months 2 weeks ago #82399

Please Log in or Create an account to join the conversation.

Time to create page: 0.407 seconds