×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

StellarMate Astrophotography Gadget

  • Posts: 2830
  • Thank you received: 794
Pk, your log file says you were trying to connect to localhost. When you connect to the StellarMate over WiFi from your Mac what is your profile setting for the host when connecting to the remote indi server? You can use the name or the ip address of the StellarMate computer. It’s something like stellarmate_363738.local
5 years 2 months ago #21024
The topic has been locked.
  • Posts: 849
  • Thank you received: 96
When I connect to Stellarmate on my Mac, with wifi, I simply turn on my Mac's wifi and "Stellarmate" shows up.
I use 10.250.250.1 port 7624 in EKOS to connect remotely,
While the instructions mentioned "stellarmate_f0220c" I have never seen anything written after the name "stellarmate".

I just now tried again to connect with Ethernet, and I still get the IP address of 169.254.82.242 on my end.
I tried using this in the EKOS INDO setup, as well as "10.250.250.1", "stellarmate", "localhost", "stellarmate.local" all with no result.

Forgive my lack of computer networking knowledge. Are you able to connect a Mac to the Stellatmate with just a direct ethernet cable?

PK

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
5 years 2 months ago #21040
The topic has been locked.
  • Posts: 849
  • Thank you received: 96
I notice that when I connect the Mac to the Stellarmate via wifi, I get a router connection of "10.250.250.1".
If I connect via the ethernet, I receive no router IP address from Stellermate - as seen in post earlier.
Is there something with that?

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
5 years 2 months ago #21045
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
Sorry, I was starting to write a reply to your last post, but I stopped it midway because I wanted to test them on my system. Yes, I connect this way often, but of course I have my own Raspberry Pi that I configured the way I wanted it and not a stellarmate.

Based on your post, your stellarmate is called stellarmate_f0220c and so when you connect to it from KStars it should be connected to the remote indi server called either stellarmate_f0220c or stellarmate_f0220c.local. I would try each to see which one works better.

The part I wanted to check on my system was the next bit. Your pi and your Mac should be able to connect just fine over Ethernet, mine are connected right now on my desk. But in order to do that, they need to be on the same network, just like if you were connected to the Pi's adhoc network or the router with both the pi and the computer.

I would recommend testing the connection using ping before trying to connect to ekos to be sure you can communicate to the pi and you have the right name for the indiserver. It will be easier for testing purposes. To do this, go to the OS X terminal and type something like this and hit enter (note: my pi is called gemini, and also when you want it to stop trying, hit CTRL-c)

ping gemini.local

I get this as a response when it is right:
PING gemini.local (192.168.2.2): 56 data bytes
64 bytes from 192.168.2.2: icmp_seq=0 ttl=64 time=0.431 ms
64 bytes from 192.168.2.2: icmp_seq=1 ttl=64 time=0.445 ms
64 bytes from 192.168.2.2: icmp_seq=2 ttl=64 time=0.303 ms

I get this as a response when I have the wrong name:
ping: cannot resolve geminiwrong.local: Unknown host

I get this as a response when it is the right name but the network is not configured correctly or the cable comes unplugged:
ping: sendto: No route to host
Request timeout for icmp_seq 6
5 years 2 months ago #21047
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
Of course the easiest way to connect the Pi and your Mac over Ethernet to be sure they are on the same network would be to connect them both via ethernet to a router. This is how I set up my friend's pi. But this is definitely not always possible, especially in observing conditions.

If your computer is going to be on a wifi network or connected to a router and your pi will be directly connected to your Mac via ethernet, there is a VERY easy way to set it up.
Go into System Preferences on your Mac, go to sharing, and Internet Sharing.
Select "Share connection from" <wifi> and "To computers using" <whatever ethernet port you are using>
Then click the checkbox next to Internet sharing to turn it on.

If your computer will not be on a router, such as if you have your equipment in the middle of an observing field and all you have is your pi and your laptop, then you will need to make sure the Pi gets a self assigned IP address with the same range as the mac's self assigned IP address. I did this for mine awhile back but I don't remember the steps that I took. I was just now trying to find them. I actually have mine set so that it will assign itself an IP in the right range for connecting over Ethernet, but then if it gets a wifi network, it will take whatever IP address it is given.
5 years 2 months ago #21048
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
Oh, I just found the setting I had to use to make the 3rd method work. (The 3rd method is my favorite because it doesn't rely on a stupid router)

If you can take the sd card out of the pi and mount it on your Mac, you can see the PI_BOOT partition mount on your mac's desktop. Edit the cmdline.txt file. It should have a whole bunch of commands all on the same line. You just need to add at the end of that long line the IP address you want your pi to have when it cannot get one. For mine I just entered ip=169.254.54.5 because when my Mac is not on any network it self assigns the IP address 169.254.54.212. That way they will be on the same network.

If you need to see your self assigned IP address on your Mac, go into the System Preferences on your Mac while the pi is directly connected over ethernet, go to the Network panel, disconnect your Mac from any wifi networks, and see what IP address it gives itself.
5 years 2 months ago #21050
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
Oh, you don't actually have to mount the pi's sd card in your Mac if you don't want to, I should add. You can also edit the cmdline.txt on the pi itself, since the PI_BOOT partition is mounted. Just go to the terminal and type:

sudo pluma /boot/cmdline.txt

And you can just edit that line to add your IP address at the end.
5 years 2 months ago #21051
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
If there is anything else, I will try to add it.

Sorry this explanation is disjointed. I never really wrote down all of my steps for the IP connection.
5 years 2 months ago #21052
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
One more thing. If you do edit cmdline.txt, and it gives itself a static ip, that will allow you to connect to the pi directly with an ethernet cable in the field as I described. It will not affect connecting to your router over wifi since the IP address is for ethernet only. It also will not affect the way you connect to the pi over its own hotspot for the same reason. But let's say you want to connect both your Mac and your pi to the router over ethernet and do your imaging session that way. Then you will have an issue because the self assigned ip is not in the right range for the ethernet connection. (Mine is 192.168.xxx.xxx when I do this). I have never had this issue because I don't image that way. I either connect directly to the pi using ethernet, or I connect over hotspot wifi in the observing field, or I connect over wifi through my router at home. But I never connect both to the ethernet in my router. The method I described above is fine for that case.

But if you did decide that you want that to work in that configuration as well, I think adding these two lines to the file /etc/network/interfaces will fix it:

allow-hotplug eth0
iface eth0 inet dhcp
The following user(s) said Thank You: anofeles, Peter Kennett
5 years 2 months ago #21057
The topic has been locked.
  • Posts: 51
  • Thank you received: 4
The following user(s) said Thank You: Rob Lancaster
5 years 2 months ago #21070
The topic has been locked.
  • Posts: 849
  • Thank you received: 96
Rican, that did it! THANK YOU!!!
I configured the Stellarmate to accept a direct Ethernet connection by editing the cmdline.txt and connected it without any trouble.
The download speeds for a 40 MB FITS file went from 2 o 8 minutes (depending on wifi congestion) to 32 seconds.
Now I just need to find a good way to keep the ethernet cable from wrapping around the mount. I have it set up now with no other cables coming off the mount - not even the power supply. It's almost as clean as the expensive EagleCore.

On a side note - Stellarmate with Stars and EKOS is a wonderful setup, but it is certainly not 100% ready for the general market - unless it is being marketed to those with a fair amount of networking and Unix programming experience. It took me a while just to understand what you were talking about (editing the cmdline.txt for example) as I am not a unix programmer. I would have NEVER figured out that I needed to add that last line with an IP address. Additionally, the comment "For mine I just entered ip=169.254.54.5 because when my Mac is not on any network. It self assigns the IP address 169.254.54.212." was confusing to me as a beginner, as I did not understand why you went from an IP address ending in 212 to one ending in 5. I finally figured it out, but this is not something is intuitive to someone with no networking knowledge.

I hope all the programmers and astronomers who work on this great project see the value is a beginner like myself, as I face all these confusing issues, which I am sure are non-brainers for you all. But I am sure there are many more beginners out there who just need a plug and play solution and may get frustrated when this is just not that easy. Not yet. I hope you have the patience to deal with my seemingly simple problems. I hope in the long run it will help make this a better product.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
The following user(s) said Thank You: Rob Lancaster
5 years 2 months ago #21090
The topic has been locked.
  • Posts: 2830
  • Thank you received: 794
Well yes, it is not going to be 100% right away. This stuff has come a long way since I started trying to work with it a year ago. It's taken HUGE strides in the last couple of years and even greater ones in the last year. If we were doing this stuff full time with pay, then it would happen much quicker, but we do things when we can around the timeline of our real jobs.

And actually after I got the things I posted for you figured out, I turned it into a script so you wouldn't have to do it manually. Jasem I assume could add similar code to his stellarmate gadget so that its configured already for the user.
5 years 2 months ago #21096
The topic has been locked.
Time to create page: 0.239 seconds