×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Forcing Stellarmate OS to Use 802.11ac WIFI ??

2 months 4 weeks ago 2 months 4 weeks ago by werper.
werper
Senior Boarder
Senior Boarder
Posts: 78
Karma: 1
More
Topic Author
Forcing Stellarmate OS to Use 802.11ac WIFI ?? #42261
I'm running the Beta version of SM on a new RPi 4B, 4GB. So far it's working really well, connects to all my equipment perfectly and has been very stable. I'm testing the networking, trying to find the best/fastest connection possible. Obviously, the less extra gear I need and the fewer the cables, the better. I discovered that SM is only connecting with WIFI using wireless N at between 58 to 72Mbps. I have a wireless AC adapter on my laptop, and the RPi supports wireless AC, but refuses to connect using that protocol, only the slower N.

Is there a way to force SM to use 802.11ac for the fastest wireless networking?

FWIW, here are the three networking methods I've experimented with, all seem to work reliably while testing in my office:

1) Gigabit ethernet from SM to router, gigabit ethernet from router to laptop. 21MB images from my Canon T3i download in about 5 seconds.

2) Gigabit ehternet from SM to router, wireless AC from router to laptop (getting 433Mbps between router and laptop, downloading 21MB images takes about the same 5 seconds, maybe a fraction of a second slower.

3) Hotspot mode connecting completely wireless from SM to laptop, wireless N only (can't get SM to use 5Ghz AC) getting 58 to 72 Mbps, 21 MB images take about 10-11 seconds to download.

TPO 8" Ritchey-Chretien Astrograph
Moonlite CS focuser with Motor Drive
RoboFocus Auto Focuser
iOptron iEQ45 Pro Mount
Stellarrmate OS (beta) RPi 4, 4GB
Canon T3i DSLR - Primary Cam
Starlight Xpress Lodestar X2 Guide Cam
Astromania 60 Guide Scope
Polemaster Polar Alignment Cam

Please Log in or Create an account to join the conversation.

2 months 4 weeks ago
knro
Administrator
Administrator
Posts: 7364
Karma: 51
Forcing Stellarmate OS to Use 802.11ac WIFI ?? #42309
I found this: github.com/raspberrypi/linux/issues/2619

Basically, it boils down to this command:
sudo iw reg set US

Can you check if it helps?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 4 weeks ago
AstroNerd
Moderator
Moderator
Posts: 628
Karma: 1
More
Forcing Stellarmate OS to Use 802.11ac WIFI ?? #42311

knro wrote: I found this: github.com/raspberrypi/linux/issues/2619

Basically, it boils down to this command:
<code>
sudo iw reg set US
</code>

Can you check if it helps?


Just go into the network manager and change the hotspot from Auto which is the default to 5ghz, I have done that and now have 5ghz hotspot... :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

2 months 4 weeks ago
knro
Administrator
Administrator
Posts: 7364
Karma: 51
Forcing Stellarmate OS to Use 802.11ac WIFI ?? #42312
Running 802.11ac ?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 4 weeks ago
stash
Gold Boarder
Gold Boarder
Posts: 307
Karma: 4
More
Forcing Stellarmate OS to Use 802.11ac WIFI ?? #42317
If you search this forum you will see that I had the same problem on RPI3b+ and changing the country code does not always work - e.g. Ubuntu Mate . Raspbian it worked. "Grey" imported AP's also seem to cause this problem as they are built for the country they are normally sold in and have different REGS/freq etc - its just a mess :-(

Hope the country code works for you.

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????

Please Log in or Create an account to join the conversation.

2 months 4 weeks ago 2 months 4 weeks ago by werper.
werper
Senior Boarder
Senior Boarder
Posts: 78
Karma: 1
More
Topic Author
Forcing Stellarmate OS to Use 802.11ac WIFI ?? #42355
I already switched the country code to US, no luck. From what I'm reading, it's an opperating system issue - latest version of Raspian supports it. I thinking we may have to wait until a new release of Ubuntu Mate and hope it's been addressed.

Thanks for your reply Jasem!

TPO 8" Ritchey-Chretien Astrograph
Moonlite CS focuser with Motor Drive
RoboFocus Auto Focuser
iOptron iEQ45 Pro Mount
Stellarrmate OS (beta) RPi 4, 4GB
Canon T3i DSLR - Primary Cam
Starlight Xpress Lodestar X2 Guide Cam
Astromania 60 Guide Scope
Polemaster Polar Alignment Cam

Please Log in or Create an account to join the conversation.

Time to create page: 0.531 seconds