×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Stellarmate vnc black screen problem

1 month 2 weeks ago
AstroNerd
Moderator
Moderator
Posts: 625
Karma: 1
More
Stellarmate vnc black screen problem #44181
No it’s doesn’t, mine works perfectly in both hotspot and on home WiFi, you have issues that are not related to the software I’m afraid... mine connects to home WiFi when it boots, and if home WiFi is not available, it starts the hotspot, and I connect to that...works every time.. :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
khobar
Junior Boarder
Junior Boarder
Posts: 37
More
Topic Author
Stellarmate vnc black screen problem #44183

AstroNerd wrote: No it’s doesn’t, mine works perfectly in both hotspot and on home WiFi, you have issues that are not related to the software I’m afraid... mine connects to home WiFi when it boots, and if home WiFi is not available, it starts the hotspot, and I connect to that...works every time.. :)


I've no doubt of this, and the FAQ confirms that's exactly how it's supposed to work, but for some reason mine can't see my network. I'll keep at it, and when I get a solution I'll post back.

@E Corazan - one thing I came across regarding the black screen is that *if* you have a USB keyboard, plug it into the pi and hit CTRL-D. That *might* help.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
khobar
Junior Boarder
Junior Boarder
Posts: 37
More
Topic Author
Stellarmate vnc black screen problem #44184
Just out of curiosity, do you have an /etc/network/interfaces file that has your SSID and password info in it, or does it just have a reference to loopback?

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
AstroNerd
Moderator
Moderator
Posts: 625
Karma: 1
More
Stellarmate vnc black screen problem #44191
Which SM version are you using, I have the very latest KDE version...and if you click on the network icon top right of screen and then it should show all available networks, click you home WiFi, and enter password and that should be it...next time you boot up it should join it, and if it’s not available to join, it will auto start the hotspot...
you can also check in the settings of that connection and make sure the band is on auto and other settings too... I don’t see why this will not work for you

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 month 1 week ago
khobar
Junior Boarder
Junior Boarder
Posts: 37
More
Topic Author
Stellarmate vnc black screen problem #44374
SM100.

Network "issue" persists. The onboard WiFi seems locked on Hotspot mode. Adding USB WiFi adapter allows me to see my internal network, but the Stellarmate cannot see the internet *until* I issue an "ifconfig wlan0 down". After that, the hotspot is disabled and all network traffic goes via wlan1.

I flashed a new 64GB microSD with the same OS and, *without any updates*, the Stellarmate switched from Hotspot to Infrastructure and I could access it on my home network.

I will continue working on it. Like I said, I probably buggered a config file somewhere along the line. In the meantime, I am pressing on as I have a date with (hopefully) much darker skies in a few days. :) :) :)

Please Log in or Create an account to join the conversation.

1 month 1 week ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1084
Karma: 6
More
Stellarmate vnc black screen problem #44384
My suspicion is that all traffic is routed via wlan0 because that one is enabled first and then wlan1. By then the default route has been set to use the wlan0 interface so deleting the default route and adding one for wlan1 should also solve the issue. It should also be possible to create a script that runs at some point and tries to detect if both wlan0 and wlan1 are up and have a valid ip address. If yes it could delete the default route and create it again for wlan1.

Another solution could be to try and see if the kernel modules for the two wlan devices can be given a priority so the current wlan1 kernel module gets loaded first so it will always get the default route. No idea if that really works because it probably also depends on how quickly your network assigns an ip address via dhcp.

And perhaps this can be configured via wpa-supplicant or so but I really wouldn’t know if that is possible at all.

Just a few thought that I hope may be useful to you.


Clear skies, Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 month 1 week ago
AstroNerd
Moderator
Moderator
Posts: 625
Karma: 1
More
Stellarmate vnc black screen problem #44391
I have both wlan1 and wlan0 work on boot up, the wlan0 is set to just show the hotspot, and wlan1 is my USB dongle and connected to my home WiFi, now in the network settings you can tell each connection to use a certain wlan connection, I use the hotspot to connect to the unit, and then the dongle to give me internet access....
It seems very straight forward to get it all to work this way, so not sure why the issue are..both mine connect on boot and run fine together...

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 month 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 395
Karma: 3
More
Stellarmate vnc black screen problem #44393
I had the same issue at first, but I appear to have fixed the problem by assigning negative priority connection value to the hotspot in the Wifi connection manager (edit connections in the wifi dropdown menu).
Only when the network finds no other Wifi connections does it now seem to turn on the Hotspot.
Try this out and see if it works for you. I think I gave it a -5 value.
Jo

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 1 week ago
AstroNerd
Moderator
Moderator
Posts: 625
Karma: 1
More
Stellarmate vnc black screen problem #44409
The hotspot by default is set to -10, so not sure why you had to change to -5.... mine is on -10...

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 month 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 395
Karma: 3
More
Stellarmate vnc black screen problem #44413
Remember, I'm not using Stellarmate on the Pi4. I had to find this out the "hard" way.

Stellarmate is making things just too easy!

:-)

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 1 week ago 1 month 1 week ago by El Corazon.
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 395
Karma: 3
More
Stellarmate vnc black screen problem #44414
Another problem I came across occasionally - and again last night- is that my Pi4 defaults back to Hotspot mode when there are interfering networks in the neighborhood.

Happened repeatedly last night again. I had to get off the 5 GHz band and on 2.4 GHz for the Pi4 to get out of Hotspot mode. Even then, I had to lower the priority of the Hotspot to -20 to give the Pi4 enough time to find my home network.

That could be a major factor as well.

Another factor I suspect is insufficient power to the Pi. Transmitting in 5 GHz may be more susceptible to power drain than on 2.4 GHz.

I ran my Pi4 off battery last night to test how long the battery would last and although it showed 75% full, operations became erratic. I was ultimately unable to acquire any more images, as Ekos reported errors acquiring the image from my Nikon.

At first I thought it was a bug in the driver due to a KStars crash a few minutes earlier, but I restarted the Pi again this morning from inside the house and now the camera connects and downloads perfectly. Only difference was that the Pi4 was now connected to the grid and not to battery power.

I think this may be the source of many of the spurious problems we are frequently reading about here.

The Pi4 just needs a lot of power.

Troubleshooting problems when there is an underlying power issue is futile and a waste of time. Likely makes things worse.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 1 week ago
khobar
Junior Boarder
Junior Boarder
Posts: 37
More
Topic Author
Stellarmate vnc black screen problem #44432
The thing is, I don't really want the second WiFi connection - it uses a USB port that I will want for an autofocuser in the future. I know I can add a powered hub, but that's more stuff to keep track of.

I don't know if this matters, but here is the specifics on my kernel, etc.
Static hostname: stellarmate1
Icon name: computer
Machine ID: some long number
Boot ID: another long number
Operating System: Ubuntu 18.04.3 LTS
Kernel: Linux 4.19.71-v7l+
Architecture: arm

I changed the hostname in anticipation of powering up another Pi4 to see if it behaves any differently. But I'd really like to get the wlan0 hotspot/infrastructure autoswitchover "issue" resolved. ;)

"Another problem I came across occasionally - and again last night- is that my Pi4 defaults back to Hotspot mode when there are interfering networks in the neighborhood." <- this is very interesting. I wonder, given the supposed weakness in the Pi4's wifi, could this be my problem???

Please Log in or Create an account to join the conversation.

Time to create page: 0.777 seconds