×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

KSTARS v3.3.9 running on Stellarmate. EQMOD INDI driver issue on startup

9 months 3 weeks ago
Acapulco Rolf
Senior Boarder
Senior Boarder
Posts: 52
Karma: 2
More
Topic Author
KSTARS v3.3.9 running on Stellarmate. EQMOD INDI driver issue on startup #46615
After installing the lastest nightly build (KSTARS 3.3.9) within Stellarmate, I'm seeing that my
Skywatcher mount no longer connects when the EQMOD INDI driver tries to startup.

The following message pops during the connection attempt:
"INDI Driver EQMod Mount crashed"





Video walkthrough here



Logs attached for reference
logs for v3.3.8 (successful connections)
logs for v3.3.9 (EQMOD mount fails to connect)


Rolling back to KSTARS 3.3.8 solves the issue

For information:
I'm looking to get the latest FITS header fixes that come with the latest nightly build to allow me to use ASTAP for platesolving

Currently ASTAP fails to solve (CDELT keywords issue) and looking at this post there is a fix for the CDELT FITS header issue in the latest nightlies

I observe that ASTAP solve works as expected on my setup when given an image with the CDELT keywords in the FITS header

I checked my recent image FITS headers and observe that they do not contain the CDELT keywords, so I'm looking for the recent fix in the latest 3.3.9. nightlies to overcome that

Equipment:
Skywatcher EQ5 Mount/EQMOD
Canon 600D DSLR
Altair 80mm refractor
ZWO CCD ASI224MC Guide Camera
MyFocuserPro2 focuser
Stellarmate 1.4.3 (Raspberry Pi 4)
Raspberry Pi 4 (4GB)

Logged as an issue here

File Attachment:

File Name: KStars3.3....5-29.txt
File Size:197 KB

File Attachment:

File Name: KStars3.3....1-58.txt
File Size:137 KB
Attachments:

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 371
More
KSTARS v3.3.9 running on Stellarmate. EQMOD INDI driver issue on startup #46622
Yes. Confirming. Updated today - EQMod (AZ-GTi) doesn't work.
Reverted to Nov 24 backup - all works.
(SM 1.4.3 on RPI4)

Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ZWO ASI294MC Pro, ASI071MC Pro
ZWO ASI120MC-S on ZWO 30F4
ZWO EAF x 2
SW AZ-GTi x 2
SW HEQ5

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8398
Karma: 51
KSTARS v3.3.9 running on Stellarmate. EQMOD INDI driver issue on startup #46656
This is most likely a build issue, especially if you're using nightlies. Maybe a rebuild will resolve the issue.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
Acapulco Rolf
Senior Boarder
Senior Boarder
Posts: 52
Karma: 2
More
Topic Author
KSTARS v3.3.9 running on Stellarmate. EQMOD INDI driver issue on startup #46723
Thanks Jasem

From what you've shared it sounds like you are suggesting this might be a build issue, so i take it that one approach might be for me to do a local full compile from source, right?

I'll give that a go and confirm the outcome

Please Log in or Create an account to join the conversation.

Time to create page: 0.468 seconds