×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

1.4.6 release - impressions, problems, etc. Please post.

  • Posts: 74
  • Thank you received: 9
I give up with current 1.4.6 RPi4 build. It simply cannot perform a session without the 120mm mini camera throwing exposure errors. What's odd is it will show a sub-frame when this occurs.

I had the RPi3 Stellarmate with 1.4.6 also mounted and switched to it and successfully guided for an hour. The problems seem to start when I attempt to plate solve and then guide. Restarting will not fix it. Not sure what's going on, it was about 20F outside and everything ran inside all day, but obviously could not guide or solve, sync, track etc. inside.
1 year 8 months ago #48337
The topic has been locked.
  • Posts: 9
  • Thank you received: 1

I gave up on 1.4.6 on my PI4 for exactly the same issue. Everything works until I plate solve and then try to image. crashes on the 2nd image. I have opened a ticket so hopefully it is fixed in the next release. Having a lot of success with ASTAP so didn't want to go back too 1.4.4, reimaged with Astroberry V2 and its been working perfectly the last week over 4 imaging sessions.
1 year 8 months ago #48338
The topic has been locked.
  • Posts: 74
  • Thank you received: 9
At least I am not alone and a one-off problem holder. The Rpi3 is doing quite well, it is just a tad slow.

I ran the rig indoors all freaking day. I tried plate solving but it just fails cause everything is all white. No problems starting and stopping, looping with guide camera and the Nikon. Fingers crossed for the next revision.
1 year 8 months ago #48339
The topic has been locked.
  • Posts: 157
  • Thank you received: 19
I have two ZWO cameras, a 120MC for guiding and a 183MM for imaging. I did have problems last night (first light for the Pi 4 with 1.4.6) where e.g. the 183 would yield a frame of all white pixels, or the 120 couldn't connect. But when I was careful to use PHD's "fork" button to choose the 120 for guiding, and then run an Ekos profile that had no guide camera specified, eventually the issues went away and I got great performance. However, at one point KStars did a CTD and I lost some imaging time before I noticed it had crashed and needed restarting.

So many things going right! Plate solving right on the Pi was just utterly rock-solid, I have never seen it work that well on the Pi 3 (or even on my Mac!). In fact Polaris was down among some tree branches but astrometry.net offline worked anyway! I mean most of the frame was tree branches but you could pick out a few stars, and the whole polar alignment assistant ran flawlessly. FLAWLESSLY. Through a 12-nm Ha filter, no less, and the "refresh" rate was only a second or two.
1 year 8 months ago #48340
The topic has been locked.
  • Posts: 86
  • Thank you received: 10
also I can't get plate solving to work for a sub taken the night before to do a load and slew, it always times out. but I can plate solve a new image no problem.
1 year 8 months ago #48341
The topic has been locked.
  • Posts: 26
  • Thank you received: 0

Hi Alan (and colleagues),

Some promising news:

I thought I would start from scratch and approach setting up Stellarmate on my home network.

I burned a new fresh image on the SD card and fired up. Hooked it up to my 4K TV (nearest available HDMI slot I had free!). I had the usual nonsense where the Hotspot wasn't being displayed. Keyboard/mouse attached to the Stellarmate I edited the connection setting for Stellarmate from Auto to 5Ghz (Channel 44 - I'm in the UK). I was then able to view Stellarmate on my tablet. From there I followed the instructions to kill the hotspot and connect the Stellarmate to my home network. I went for 5Ghz. Anyway... it works.

I downloaded Real VNC as recommended, but for some reason I must have set it up wrong. Whatever I did I couldn't see the Stellarmate. I then opted to type in stellarmate.local:6080/vnc.html in my web browser and logged on "smate" and it popped up. On another tab in my web browser I typed in stellarmate.local/#/home and got the dashboard.

I opened the Kstar app (within VNC) and the eKos; told it how I wanted it to work (from within Stellarmate and all equipment attached to Stellarmate) and configured my drivers in the INDI app. I opted to make sure all my equipment was connected and working before hitting the "connect" option. To my surprise EVERYTHING connected and none of the nonsense messages popping up regarding USB port settings.

My connectivity is as follow:

SSAG and Pegasus connected into two free USB ports of my Hypercam 183C. Hypercam connected to USB 3.0 of Stellarmate. Lynx EQmod cable (from HEQ5-Pro) plugged into other USB 3.0 port on Stellarmate.

Firstly impressions, this clearly seems much better solution having the software within Stellarmate locally than via Client. It also seems better being connected on my Home Network via WiFi than via the Hotspot setup. The fact the connectivity is also set connected to my Router on 5Ghz (CH 44) seems no issue.

Now for the bad bits:

Pegasus DMFC: This still has a bug where I cannot Set (Enable/Disable) Backlash or Reverse Motion. The latter does - sometimes. However, within Options it still does not fully Save my Configuration. It does Save certain aspects - like setting of Max Position. It does not Load previously Saved Configurations. On the Connections tab: Scan Ports does not automatically Refresh. Only when I do this manually I am able to Enable Reverse Motion. I do not want to be having to do this all the time before I do imaging. This should Save as my Configuration and load automatically surely? Clearly a bug.

I need to have Reverse Motion enabled to work otherwise it all goes to rubbish.

Altair AA183CPROTEC: Similar issue to above: I can set but not SAVE (in Configurations) the temperature I want my camera to be cooled. Reverts to 0 degrees on restart. In Controls; the USB speed sometimes SAVE when set to 2 instead of 3. On occasion it goes back to 3.

In operation I have noticed once the temperature is set (-10.00) it will drop accordingly but frequently come up with [ERROR] get_Temperature error. Unspecified failure. As a result the temperature does not drop as required. Until I hit SET again. Oddly, the (-10.00) figure changes to (-9.80). Weird. I also get [ERROR] Cannot change resolution while streaming/recording despite the fact I have stopped streaming or recording anything.

I thought I'd try an test the camera and focuser together. No success. Focuser was OK once I got it to Reverse mode. Stream on video was impossible with the INDI drivers crashing more times than I could count. I managed to drop the cameras resolution from its capable resolution (5440x3648) to something more modest (2736x1824) and USB down to 1 from 3. Slow when it worked and tbh.. it didn't really work. I think if I wasted a night with this out in the cold I;'d probably douse the whole lot in fuel and set it alight. Everytime INDI crashed I had to reset the setting I saved as it did not save the settings when set and saved. At this point I give up.

No point testing the rest tbh.

One annoyance within Kstars and eKos was the INDI Control Panel disappearing everytime I clicked on something in eKos. I had to go to the front tab on eKos to open it up again.

I cannot be bothered to test anymore on the 1.4.7 - it has serious teething problems nothing a dentist couldn't fix by pulling all it's damned teeth out. Problems everywhere. Bored now...

I'm going to mow my lawn.

Someone email me and let me know they have fixed this. I think I am going to go back to my trusted Windows and APT/SharpCap and Stellarium for now. If I had made strides it is thanks to Alan advising me to ditch Hotspot. Some improvements in connectivity for sure. The rest? well...

Clear Skies.

Jaq
1 year 8 months ago #48366
The topic has been locked.
  • Posts: 603
  • Thank you received: 58
This turned out to be a good thread! I started it...
Hopefully 1.4.7 will bring us some much needed improvements.
I started the thread but personally use 1.4.3 (which is not 64bit) and switched from wifi connection to the mount to EQDir cable (this works but I really liked wifi option - one less cable).
Thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
The following user(s) said Thank You: Mr Jacques Prince
1 year 8 months ago #48422
The topic has been locked.
  • Posts: 26
  • Thank you received: 0
An update:

Jasem (Stellarmate) managed to resolve the issue I had with my Pegasus FocusCube V2.

I am still waiting to resolve the issue with my Altair Astro Hypercam 183C ProTEC camera. Apparently waiting on updated SDK from both Altair and Toupcam. Both haven't been very forthcoming in a response to request. At the moment I am in limbo and cannot use Stellarmate with the hardware I have. Not sure what to do at the moment...

Jaq
1 year 7 months ago #49740
The topic has been locked.
  • Posts: 86
  • Thank you received: 10
Have you tried the new 1.5.0 release.
1 year 7 months ago #49754
The topic has been locked.
  • Posts: 26
  • Thank you received: 0

Yes.. it crashed on installation so I am now nowhere new:







I think I will give up on Stellarmate.

I found out today that the manufacturer will not assist with an updated SDK to make my Altair Hypercam 183C ProTEC function correctly with this platform.

A shame, as when I decided to go for Stellarmate and researched on the INDI forum compatibility with my camera the link said: INDI Altair cameras Driver currently supports all of Altair Astro mono and color cameras.

Er... that's not the case, and in its current format it is useless. Jasem added today an exclusion but I am afraid it runs deeper than just that:

"On embedded platforms (Raspberry Pi, Odroid..etc), the camera exposure can fail with Exposure Timeout messages due to limitations in the camera SDK as it does not properly handle USB bandwidth on embedded devices. As of 2020-02-18, the SDK is still not updated to fix the USB resolution issues. One way to resolve this issue is by reducing the resolution."

Certain 'other' issues I could not resolve: It kept dropping the camera temperature settings when set, would not save configurations etc... I am sure there are more issues. I just have not got to a point to test further.

So... I would say it does not currently support all of Altair Astro mono and color cameras. Misleading header in my opinion on the INDI page: indilib.org/devices/cameras/altair-cameras.html

Anybody want to buy a Raspberry Pi 4 with this software please message me.

Jaq
1 year 7 months ago #49758
Attachments:
The topic has been locked.
  • Posts: 9
  • Thank you received: 1
1.5 has seemed to solve all my problems. ASTAP working perfectly, can center my target in seconds, guiding works and finally I can capture a sequence of images without anything crashing. WiFi also starts up in seconds.
1 year 7 months ago #49799
The topic has been locked.
Time to create page: 1.973 seconds