×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Minimum shutter speed for DSLRs in Capture module?

1 week 6 days ago
esb
Fresh Boarder
Fresh Boarder
Posts: 10
More
Topic Author
Minimum shutter speed for DSLRs in Capture module? #49176
I am attempting to take flats for the first time and have run into a problem. I am using a Canon 5d2 @ ISO 1600 to capture my lights. I am attempting to capture flats with a white t-shirt over the end of the scope pointed straight up at the morning clear blue sky. It appears that I can only set the shutter speed as low as 1/1000. At that speed, my image is still almost fully saturated. The camera is capable of shutter speeds as fast as 1/8000, but I haven't been able to go lower than 1/1000. Is there any way to change the minimum? I didn't see anything in the Ekos settings or in the INDI Control Panel for the camera. I am using it with a WO RedCat 51 if it makes any difference.

Please Log in or Create an account to join the conversation.

1 week 6 days ago
mactech
Senior Boarder
Senior Boarder
Posts: 57
More
Minimum shutter speed for DSLRs in Capture module? #49186
Whenever I attempt to take short exposures on my Nikon D7500 shorter than one second, bad things happen (INDI driver crash ) nor does it honor the selected shutter speed. However, in 1.4.7 (beta) is has improved stability.
This was a problem right off the bat as I attempted to setup my system during the day in my office where it was bright. No amount of love could get it to work. EKOS/KStars does not always deal with errors coming from the SD Card. Trying to take an exposure on the D7500 without an SD card would take it all down, EKOS and KStars.

However, using the ZWO ASI120mm mini, I encountered no such issues and could run it for hours on end.

Please Log in or Create an account to join the conversation.

1 week 6 days ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 450
More
Minimum shutter speed for DSLRs in Capture module? #49193

shutter speed as low as 1/1000

Hi
Set 'force bulb' to off and maybe add another t-shirt.
HTH and clear skies

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 week 5 days ago
ChrisRowland
Platinum Boarder
Platinum Boarder
Posts: 340
Karma: 8
More
Minimum shutter speed for DSLRs in Capture module? #49194
Would reducing the ISO help for collecting flats? It's important to use the same settings for darks and bias but flats are used as a ratio so the absolute values don't matter.

Please Log in or Create an account to join the conversation.

1 week 5 days ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 562
Karma: 3
More
Minimum shutter speed for DSLRs in Capture module? #49200
Yes, set "force bulb" to OFF but also set the camera dial to "M" mode. Taking 1/8000 exposures should be possible then. I'll test with my 5DM2 later and report back.

Please Log in or Create an account to join the conversation.

1 week 4 days ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 562
Karma: 3
More
Minimum shutter speed for DSLRs in Capture module? #49268
Eric, I just tested with my 5DMk2 and was able to take 1/8000s flat frames.

1. Set the camera dial to "M"
2. Start Ekos
3. In Indi settings go to "Canon DSLR..." -> Options and select Force BULB = OFF (after restart this will come up with Force BULB = ON so you will have to set it to OFF again).
4. In Ekos "CCD and Filter Wheel" TAB select Type: FLAT, set Exposure to 0,000125 (can be done by clicking the down arrow)
5. Click at the CALIBRATION button, select Flat duration = MANUAL, click OK.
6. Back in the Ekos CCD TAB click at "+" to add the flats job to the sequence queue
7. Start the sequence. Ekos will now take 1/8000s flat exposures.

HTH and CS!

Please Log in or Create an account to join the conversation.

1 week 4 days ago
esb
Fresh Boarder
Fresh Boarder
Posts: 10
More
Topic Author
Minimum shutter speed for DSLRs in Capture module? #49307
Thanks for the help everybody. I was able to take 1/8000 frames by doing the following:

1. Turn off "Force BULB" (Indi settings -> Canon DSLR... -> Options -> Force BULB -> Off
2. Set camera to manual mode (Indi settings -> Canon DSLR -> capturesettings -> autoexposuremode -> Manual)
** Can also be done by setting camera mode dial to "M"
3. Set exposure length *on camera*
** I was not able to get the exposure length setting in Ekos to affect the Manual mode exposure

During my experiments, I also noticed that when I changed the exposure setting in Ekos (CCD & Filter Wheel pane), I had to tab out of the field for the new exposure to take effect. If I immediately clicked the button to start the capture, the previous value was used. While tuning the length of my flat frame exposures, I kept wondering why changing ISO affected the resulting image, but changing the exposure length did not. Tabbing out of the exposure field "fixed" that problem.

So close to being able to completely automate the capture. I'm not sure why the exposure setting in Ekos isn't affecting the Manual mode capture. (It really doesn't matter so much as I already have to be at the scope to put the flat box / shirt over the scope for flats or cover on for flat darks, though someday I'd love to automate all of that.)

Please Log in or Create an account to join the conversation.

1 week 4 days ago 1 week 3 days ago by Herrhausen.
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 562
Karma: 3
More
Minimum shutter speed for DSLRs in Capture module? #49312

esb wrote: Thanks for the help everybody. I was able to take 1/8000 frames by doing the following:

3. Set exposure length *on camera*
** I was not able to get the exposure length setting in Ekos to affect the Manual mode exposure


Weird! It works here. However, the Ekos-selected exposure time will show up in the camera display only AFTER the picture has been taken (Ekos activates the selected exposure time immediately before the picture is being taken, hence you cannot see it in the camera display before the exposure has been fired. The correct exposure time will be used nevertheless). Also, once you set "Flat Duration" to a suited ADU value, the whole process should run fully automatically.

Please Log in or Create an account to join the conversation.

Time to create page: 0.714 seconds