×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Issues or general comments of the new Raspbian Based Stellarmate 1.5.0

  • Posts: 86
  • Thank you received: 10

ok I did update to 1.5.1 but all of the subs I took last night on 1.5.0 are read protected, will this command change all of those to be readable ??

to run the command I just go to the terminal and enter the command you list in #1 ??

ok that seems to have solved it thanks
Last edit: 2 years 10 months ago by Brent.
2 years 10 months ago #50266
The topic has been locked.
  • Posts: 309
  • Thank you received: 40

Same with me.
I have the new version and it still creates the directories as rwx - - - - -, but I wrote a quick script to chmod them and a desktop icon to launch it.
I put the file ChmodPics.sc in my directory I have called MyScripts (you can put it anywhere you want, but you will have to change the desktop file to point to your location)
I put the file ChmodPictures.desktop in the "/home/stellarmate/Desktop" directory.
Of course you will need to rename them, removing the .txt at the end.
I just double-click the icon when I'm ready to download my files.

I read were you can call the script right from the desktop file... which would be the best way. But I never could get it to work.

File Attachment:

File Name: ChmodPics.sc.txt
File Size:0 KB

File Attachment:

File Name: ChmodPictu...ktop.txt
File Size:0 KB
Last edit: 2 years 10 months ago by David Tate.
2 years 10 months ago #50268
Attachments:
The topic has been locked.
So directories are created as 700? Alright so I have to get the root cause of this... KStars process should be running as 'stellarmate' users .. so why would it make 600 files and 700 directories by default?

EDIT: I just checked and the directory permissions appear OK.
stellarmate@stellarmate:~/Pictures/Light $ ls -lh
total 8.0K
drwxr-xr-x 2 stellarmate stellarmate 4.0K Mar  1 05:41 Green
drwxr-xr-x 2 stellarmate stellarmate 4.0K Mar  1 05:41 Red
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 2 years 10 months ago by Jasem Mutlaq.
2 years 10 months ago #50269
The topic has been locked.
  • Posts: 232
  • Thank you received: 56
I have taken the plunge and replaced my Pi3 with the Pi 4.
All seems to work well with HEQ5, 294MC, 224MC and Pegasus PPB.

One question I have is should the Update button in the StallaMate dashboard work?
Mine runs the percentage usual goes to about 3% then I get a message saying the update was successful but the update icon remains red with a little red exclamation mark next to it.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

The following user(s) said Thank You: Craig
2 years 10 months ago #50286
The topic has been locked.
  • Posts: 6
  • Thank you received: 1
After pairing a bluetooth device, I don't know how to assign a serial port to the device. The device is BTdir. This is connected to EQ6.
Last edit: 2 years 10 months ago by hiroyuki yamashita.
2 years 10 months ago #50289
The topic has been locked.
  • Posts: 108
  • Thank you received: 19

Hi,
use terminal on stellarmate desktop and update using :
sudo apt update  &&  sudo apt-get dist-upgrade

Cheers
----
ES ED 127mm FCD100, AZEQ6 GT, FocusLynx ESX25, Nikon D800 , ASI120mm-s, Polemaster
-- RPi4 4Gb Stellarmate , Windows 10 Pro, Kstars/VNC
-- RPi4 8Gb Ubuntu mate 20.04.1 LTS - Kstars/NoMachine
2 years 10 months ago #50292
The topic has been locked.
  • Posts: 6
  • Thank you received: 1
Last edit: 2 years 10 months ago by hiroyuki yamashita.
2 years 10 months ago #50330
Attachments:
The topic has been locked.
Ok I think I have some idea on what's going on ... going to look into this.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 10 months ago #50353
The topic has been locked.
  • Posts: 120
  • Thank you received: 11
One other question on your configuring of the hard coded IP address. Did you use the network tools GUI that's built into Linux? I've been using this tool as I thought it was the preferred way to do this type of thing, but its leading to constant soft disconnects of the interface.

Thanks, Craig
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
2 years 10 months ago #50371
The topic has been locked.
  • Posts: 12
  • Thank you received: 0
Decided to give StellarMate another try on Rpi 4 with a fresh install of 1.5.1.

Using the iPad app, I get an error when attempting to access the desktop. The iPad app is version 1.9.13. I think I heard there is a newer iOS app, but my version is the latest on the App Store. The error occurs both when I am connected to the hotspot and when connected to my home WiFi.

Attached is a screen shot of the error. I had the same issue that prevented me from using 1.4.6. I have cleared the browser cache on my iPad, as suggested on the Facebook group.

2 years 10 months ago #50407
Attachments:
The topic has been locked.
Please use this beta version now: testflight.apple.com/join/yPEDodh6

Hopefully in a few days, we will work on resolving the other issues with communication ..etc and release it as stable in the App store.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Craig
2 years 10 months ago #50409
The topic has been locked.
  • Posts: 6
  • Thank you received: 1
solved. This is advice from jasem.

I am aware of this issue and working on a solution for it. Will update you soon.

You can install blueman and use that instead. I will include it in the next update of stellarmate.

sudo apt-get -y install blueman

then restart and you will see the blueman icon and use that to setup to your device.
The following user(s) said Thank You: Craig
2 years 10 months ago #50415
The topic has been locked.
Time to create page: 2.045 seconds