INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Issues or general comments of the new Raspbian Based Stellarmate 1.5.0

  • Posts: 12
  • Thank you received: 0
2 years 10 months ago #50433
The topic has been locked.
  • Posts: 753
  • Thank you received: 69
Upgraded to 1.5.1
Ran a 60x240s sequence. All on RPI4 (as quoted below). Not a single problem. Really nice!

Well, there was one issue which is not RPI4 or 1.5 specific and has been there for quite a while.
Bias frames. (this was reported before).
Often, Ekos takes bias frames but they are completely empty (no signal whatsoever).
Usually this happens on the first run, when switching from Lights or Darks to Bias.
Switching back to Lights and taking a few exposures makes Bias to behave normally.
Couldn't quite figure out the exact pattern.
At least I know now that the issue exists and sort of know how to get around it.

Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
iOptron CEM40G
2 years 10 months ago #50449
The topic has been locked.
  • Posts: 6
  • Thank you received: 1
It is a stellarmate application for android tablet, but it can be connected, but it takes a long time to connect. Do you have any tips for a quick connection?
2 years 10 months ago #51036
The topic has been locked.
  • Posts: 232
  • Thank you received: 56
Last night I had to position my mount slightly further away from the house which meant that my wifi connection from my laptop running Kstars and INDI on the Pi was not strong.
I lost connection a few times and focussing was impossible (too long required for the download).

I had an old Airport Express (mini router/Access point) which I have now connected directly to the Pi with a cable. Seems to have solved my wireless woes.
I think the Pi wireless access point is very weak and only really seems to work if you are within a couple of metres.
WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
iOptron GEM45
294 mc pro
224 planetary cam
174 guide cam
Powerbox Ultimate
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

2 years 10 months ago #51153
The topic has been locked.
  • Posts: 1118
  • Thank you received: 182

That honestly baffles me. I imaged again last night and my rig is ~60ft away from the WiFi extender I am using for coverage in my backyard. So definitely not ideal conditions, with distance, extender and all.
Nonetheless, the INTERNAL 5GHz WiFi of the Pi4 never had any trouble whatsoever with that constellation.
I get consistent connection speeds of ~ 390 Mbs, which makes for a very snappy response via VNC. I am running KStars on the Pi4 directly.
I can only wonder whether the poor connection many people here are describing is the result of either a subpar power supply that cannot pull the Amps the Pi4 needs to run at full speed, or whether it is somehow related to the OS. I am using Ubuntu 18.04 as my OS on the Pi4.
Maybe the key is the power supply. I am using the one that came with the Canakit when I originally ordered the Pi4. Rated to 3.5 Amps.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
2 years 10 months ago #51163
The topic has been locked.
  • Posts: 391
  • Thank you received: 116
@rishigarrod: Just popping prior post on issues between USB3 and Wifi at 2.4Ghz. It's not clear whether you're using the Pi4's USB3 ports, and you didn't say whether your wireless is using 2.4Ghz. If yes to both, it's most likely that you are experiencing RF interference. This has nothing to do with SM 1.5. It's solely a function of Pi4's USB3 close proximity to the internal wifi antenna. See this prior post for details and workable solutions: www.indilib.org/forum/general/6576-pi4-u...erference.html#50509
FWIW, after adding a direct ethernet cable from laptop to Pi4 (lured by speed improvement), I'd never go back to wireless now unless it was an absolute emergency ! Clear skies...

p.s. For Jo, I'll note that although power supply can be a problem (lots of prior posts on poor power issues), when it's Pi4, USB3, and wifi at 2.4Ghz, it's almost certain to be RF interference (and NOT power). Similar symptoms though, so it can be very confusing. Folks need to take note as they migrate to Pi4 with USB3 since 2.4Ghz wireless is everywhere, and people don't necessarily think to take action to switch over to 5Ghz.
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
Last edit: 2 years 10 months ago by Doug S. Reason: typo
2 years 10 months ago #51164
The topic has been locked.
  • Posts: 309
  • Thank you received: 40

Yeah... the speed difference and reliability keeps me hardwired. I'm spoiled now. 11MB/sec vs <1-4MB/sec
2 years 10 months ago #51165
The topic has been locked.
  • Posts: 1118
  • Thank you received: 182

Thanks, Doug! I had forgotten about the WiFi interference problem. Never had it, since it felt natural to connect via 5 GHz only. 2.4 GHz WiFi is just too slow. About 6 times slower.
Anyway, just to let everyone know not to give up on the internal WiFi of the Pi4. It works great on 5 GHz and it is not weak at all.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
2 years 10 months ago #51166
The topic has been locked.
  • Posts: 11
  • Thank you received: 0
what makes the difference between astroberryserver and stellarmate ? astroberry runs fast and smooth. stellarmate is laggy and slow. almost ususable.
Last edit: 2 years 9 months ago by Andreas Willi.
2 years 9 months ago #52126
The topic has been locked.
  • Posts: 86
  • Thank you received: 10

still having trouble getting an update to complete.

this command didn't get it done either.
2 years 9 months ago #52774
The topic has been locked.
  • Posts: 1944
  • Thank you received: 419
apt-get dist-upgrade alone is not enough to update the packages on a deb based system. Try

sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y

HTH, Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
2 years 9 months ago #52775
The topic has been locked.
  • Posts: 54
  • Thank you received: 0
Hi, I'm new here (both in the forum but on astrophoto as well) and thought I'd share my experience using Stellarmate on Raspberry PI4 and MacOS.

I've tried several combinations to try to find a stable one that doesn't crash or freezes.

My current setup:

- Stellarmate 1.5.3
- MacOS Catalina 10.15.5
- VNC Viewer 6.19.107 (over WiFi)

- Raspberry Pi 4, Model B, 4GB
- Official Raspberry Pi 4 Power Supply / 5.1V / 3A / USB-C
- FLIRC Raspberry Pi Heatsink Case
- Adafruit PiRTC DS3231 RealTime C
- Ethernet cable to home LAN
- USB-HEQ5 PA Interface (USB to serial cable)

Astrophoto stuff:
- HEQ5 PRO Mount (connected via EQMod Mount)
- ZWO ASI294MC Pro
- ZWO ASI120MM-S (as guiding cam)

I tried KStars 3.4.3 for MacOS (recommended by Stellarmate) but when connected to Stellarmate via Ekos it was quite unstable. If I left the computer for a couple of minutes it seemed it kind of lost the connection for a while and then sometimes managed to reconnect again when I did something like trying to click another tab in Ekos or so. I could not really be sure if an ongoing capture sequence was working properly or not. Sometimes it never reconnected an I had to restart everything. When I tried looping captures or running video it crashed immediately.
It's a pity since the user interface felt better in MacOS KStars than directly in Stellarmate (via VNC). It was somewhat more stable when connected via Ethernet (cable) but not entirely stable.
Anyone else has the same experience?

The only stable setup so far is as below:

- The Rapberry Pi connected by ethernet cable to my home LAN.
- Running VNC from my MacBook (connected on my home WiFi) to run Stellamate's local KStars and Ekos.
- The ASI294 connected directly to the RPi's USB 3.0.
- The ASI120 guiding cam connected to the ASI294's "USB2.0 Out" connector.
- The ASI120's ST4 cable connected to the mount.
- The mount connected (via USB-HEQ5 USB/Serial cable) directly to one of the RPi's USB 2.0 connectors.

This setup has been really stable. When I try to use the RPi on WiFi it randomly freezes. I have only tried on 2.4GHz though since I though that should be more stable, but I now read in this thread that 5GHz might be more stable? I'll definitely try that, since using the extra ethernet cable is a bit of a hassle.

EDIT: I can confirm that after about 24 hours of testing it seems really stable over 5GHz WiFi as well! :-)

I've also tested using a couple of USB 3.0 hubs (with external 2A power) since I thought that was causing instability, but it seems equally stable to connect the ASI294 directly to the RPi's USB 3.0.

// Åke
Last edit: 2 years 7 months ago by Åke Liljenberg.
2 years 7 months ago #55714
The topic has been locked.
Time to create page: 0.946 seconds