×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Major Driver errors RP4

  • Posts: 11
  • Thank you received: 1
Hi there
Im sorry for the short message but have 2 kids and work in lockdown!
Basically all my gear connected no problem before.
Canon DSLR, HEQ5 and Altair guide camera.

Then I attempted an update through Stellarmate OS. I could not see if it failed or succeeded.
EQ mount was then not found but Canon and Altair were.
After many hours trying I reinstalled Stellarmate OS from the start via BalenaEtch.
I did package updater and installed 1 line of PEP(???)
Now it can find the mount but not Canon or Altair.

When Ekos starts it says the driver has crashed restart? but nothing good happens.

If anyone could please help it would be most appreciated.
Perhaps I will reinstall from scratch with BalenaEtch and then if someone could please instruct me from there?
2 years 8 months ago #53674

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 3
Try this
In terminal
update_indi_core
after that completes
update_indi_drivers
The following user(s) said Thank You: Alan O'Connell
2 years 8 months ago #53675

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
Thank you will try in 6 hours when kids go to bed!!
2 years 8 months ago #53678

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
Seemed to find quite a few errors

2 years 8 months ago #53679
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 391
  • Thank you received: 116

Replied by Doug S on topic Major Driver errors RP4

If you are running StellarMate OS, I'm not sure you did the right update process (Those commands may be more appropriate for a "Raw" or Astroberry distro?). First, there have been a few reports of bad results with this latest update to 1.5.2. Not sure what's going on, but most who have run into problems have had to restore from a backup and then do the update again. See this post thread:
www.indilib.org/forum/stellarmate/6959-a...rs-launch-issue.html
In my case, I also run StellarMate OS, and had similar problems with this latest update. I restored/restarted from a 1.5.0 backup, then ran the update command again. I believe the "package updater" app doesn't work. In StellarMate OS, you should use the command:
sudo apt-get update && sudo apt-get -y dist-upgrade
My recommendation is to restore from your backup (or start over from 1.5.0 fresh) and then run the above command. If that doesn't get you going again, you may need to log a ticket on the StellarMate OS site for additional help. cheers, Doug
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
The following user(s) said Thank You: Alan O'Connell
2 years 8 months ago #53684

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
Thanks !
Do you know where I can find 1.5.0 please?
Mu orders page just gives me the option for 1.5.2
2 years 8 months ago #53685

Please Log in or Create an account to join the conversation.

  • Posts: 391
  • Thank you received: 116

Replied by Doug S on topic Major Driver errors RP4

If you don't have a 1.5.0 backup to start from, and you only have the choice for 1.5.2, then you should pull the 1.5.2 again (and keep the file as a backup)! That should solve your issues. If it doesn't, then I'd start looking at your profile setup for issues there. Sorry, I thought you were updating from an older version. 1.5.2 is the current latest version (stable). If that's not working, and you don't see anything wrong with your profile, then creating the SM OS ticket may be the next step.
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
The following user(s) said Thank You: Alan O'Connell
Last edit: 2 years 8 months ago by Doug S.
2 years 8 months ago #53686

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
Provisionally I think that worked!
THANKS!

Lord knows how I was supposed to know that in the 1st place but thank you for the timely answer!!

Will see how I go tonight...

Ill try ASTAP now
Last edit: 2 years 8 months ago by Alan O'Connell.
2 years 8 months ago #53693

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
Sorry while Im here, does ASTAP need to be installed on the RBP4 or on Mac book pro please?

On the MBP I suppose
Last edit: 2 years 8 months ago by Alan O'Connell.
2 years 8 months ago #53694

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Replied by AstroNerd on topic Major Driver errors RP4


If you run these commands, you will end up with the nightly INdI version, and not the stable version, and the nightly could be buggy....so think before you update the INdI core...
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
The following user(s) said Thank You: Alan O'Connell
2 years 8 months ago #53697

Please Log in or Create an account to join the conversation.

Time to create page: 1.352 seconds