×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Has anyone got a Vixen Starbook 10 working with Stellarmate ?

  • Posts: 10
  • Thank you received: 0
Hi,

I am trying to get my Vixen SXD2 mount with Starbook 10 working with Stellarmate, 
When I connect a ethernet cable from the RpI4 to the Starbook 10 it gives an address of 169.254.0.1 (as it did on my Intel NUC under Ascom which worked pefectly)
But it will not connect and Ekos is showing 169.254.1.1 so I change it to 169.254.0.1 and still won't connect2021-04-09T22:25:37: [ERROR] Connection failed2021-04-09T22:25:37: [ERROR] Couldn't connect to server2021-04-09T22:25:37: [INFO] Creating HTTP handle for 169.254.0.1@80Any ideas much appreciated 
Cliff
1 year 9 months ago #69859

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 2
Got the same problem with my Vixen Starbook 10 first. I suppose the Starbook 10 the does have a static IP in his own /24 network (subnetmask 255.255.255.0). On the actual version this is 169.254.0.1. If you choose "Direct Ethernet" on your StellarMate network connection menu (upper right on the StellarMate VNC Screen) StellarMate want to have 169.254.0.1, two. But he don't can, because this address is allready used by starbook 10, so StellarMate hops to the next network and chooses the IP 169.254.100.1. And now the problem is completed. Both devices are in complete diffrent networks and can't talk to each other. The StellarMate has to be configured that he don't choose 169.254.0.1 with "Direct Ethernet"

That's how I solved the problem:
1. Connect to StellarMate by VNC
2. On StellarMate go to Preferences->Advanced Network Configuration
3. Choose "Direct Ethernet" and enter settings (wheel icon on the lower left)
4. Go to the "IPv4 Settings" Tab
5. Under "Method" choose "Shared to other computers"
6. Under "Address (optional)" add 169.254.0.2 for "Address", 24 for "Netmask" and leave "Gateway" empty
7. Save Settings (lower right) and leave the "Advanced Network Configuration"
8. Connect StellarMate, addionally to your Wifi connection, to "Direct Ethernet" (network icon on the upper right of your StellarMate Screen)
9. Now Ekos should connect to your Vixen Starbook 10. Don't forget to reconfigure Ekos to use 169.254.0.1, as you have written on your question. This still have to be done.

That worked for me.
 
The following user(s) said Thank You: Jasem Mutlaq, Cliff
1 year 9 months ago #70632

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Thank you so much Emanuel ,

I will try that later today, as a side note it works perfectly on Astroberry with no changes except the address in EKOS.
Thats what I thought strange it wouldn't work in Stellarmate

I think most unconnected devices seem to also choose that 169.254.0.1 address.

Will give you an update once I try it out,
Cliff
1 year 9 months ago #70662

Please Log in or Create an account to join the conversation.

in SM OS v1.5.8, it should work right away without having to do the trick suggested above. I haven't tested this with Starbook 10, but tried it with a direct connection to a PC and the auto-configuration IP was OK.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 9 months ago #70670

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Hi Jasem,

Well I updated to 1.58 but still had to use Emanuel's trick to get it to work so now it does.

Cheers
Cliff
1 year 9 months ago #70677

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Ekos doesn't keep the 169.254.0.1 address have set it each time ?
1 year 9 months ago #70702

Please Log in or Create an account to join the conversation.

Time to create page: 0.822 seconds