×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

hidden SSIDs, wpa_supplicant, 5ghz, wifi_localisation

  • Posts: 3
  • Thank you received: 0
Issue #1:
The WiFi network I connect to is hidden.  It also supports both 2.4Ghz and 5Ghz.  I added this network to my Pi4 Stellarmate a month ago and all was working fine.  I could boot up the Pi4 Stellarmate and it would find the network and therefore not turn on the hotspot.  Yesterday, however, it stopped finding the hidden network and always loads the hotspot.  I can manually connect to the hidden network with no problem, however.  If I expose the SSID (no longer hidden) it works fine as well.  On another Pi3 I have that does not run Stellarmate (just out-of-the-box Raspbian) I setup my wifi networks in wpa_supplicant.conf where I can tell it to scan for hidden SSID using "scan_ssid=1".  Out of desperation I tried this on the Stellarmate but no luck.  Seems like the Stellarmate is storing the network configurations somewhere else and probably overriding whatever is in wpa_supplicant.conf?

Issue #2:
I also noticed recently that it was not connecting to the 5Ghz channels and instead always using 2.4Ghz.  Running "iwlist channel" I see 5Ghz channels but they stop at channel 149.  My router is using channel 153.  I changed the router to 149 and it will connect on that channel.  But if I change it back to 153 then it won't.  Does the Pi4 just stop at channel 149?  Or is this possibly a WiFi Localization issue?  I noticed on my Stellarmate that "WiFi Country" is not set in "Preferences | Raspberry Pi Configuration".  I set it to US (I'm in the US) but after rebooting it goes back to not being set.  It appears maybe Stellarmate doesn't use that setting anyway and also perhaps more evidence that maybe wpa_supplicant isn't being used where indeed I have "country=US".

Any advice on these two issues?

Jeff
7 months 1 day ago #72722

Please Log in or Create an account to join the conversation.

Time to create page: 0.303 seconds