×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Please roll back focus filter first in sequence overrides "Lock" filter!

  • Posts: 297
  • Thank you received: 55
In 3.5.7, the focus filter in a sequence automatically changes to the first filter in the sequence.

I can see why this was done, but it's a problem when imaging a target with dim stars in narrowband. 

I use focus offsets for all my filters and have my L filter set as the "Lock" filter so that even if my imaging is all Ha or Sii I can get enough stars for autofocusing in a reasonable time. The improved sequence logic OVERRIDES this Lock and swaps my filter against my will when focusing at the start of a sequence in the Scheduler.

Now my autofocus fails because too often I'm trying to autofocus with extremely dim stars in narrowband. It's possible to workaround this feature using very long autofocus exposures (like 20 or 30 seconds) to get enough stars, but I would much rather autofocus with my Lock filter.

Please consider rolling this feature back in 3.5.8 or at worst making it an optional checkbox. 
Last edit: 3 months 3 weeks ago by Scott Denning.
3 months 3 weeks ago #80998

Please Log in or Create an account to join the conversation.

  • Posts: 143
  • Thank you received: 25
Agreed to make this optional.

Actually, would it be an idea to display the changelog before an upgrade is actually made?
Or make a few versions of 'downgrade' possible? At least that would prevent messing with user's workflow too much.
We're not beta testers, right? ;)
Latest Stellarmate on Rpi 4B, 294mm-pro, EFW-8, CEM70
Last edit: 3 months 3 weeks ago by Bart.
3 months 3 weeks ago #80999

Please Log in or Create an account to join the conversation.

Just tested it a couple of times and it's appears OK. The LOCK filter is respected and it changes to it before it starts the focus process. Include logs to see what's going on.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 3 weeks ago #81024

Please Log in or Create an account to join the conversation.

Time to create page: 0.255 seconds