×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

INDI Driver for SVBONY cameras

  • Posts: 47
  • Thank you received: 0
I though you already install this

sudo apt-get -y install libnova-dev libcfitsio-dev libusb-1.0-0-dev zlib1g-dev libgsl-dev build-essential cmake git libjpeg-dev libcurl4-gnutls-dev libtiff-dev libfftw3-dev libftdi-dev libgps-dev libraw-dev libdc1394-22-dev libgphoto2-dev libboost-dev libboost-regex-dev librtlsdr-dev liblimesuite-dev libftdi1-dev libavcodec-dev libavdevice-dev

if it does not work, give a screenshot of the output after running the above command.

once done, go to


cd ../../indi-sv305/

rm build -r

mkdir build

cd build

cmake ../ -DCMAKE_INSTALL_PREFIX=/usr

make

sudo make install

sudo ldconfig
2 years 3 months ago #58521
The topic has been locked.
  • Posts: 67
  • Thank you received: 0
Yes I already installed that long line but I started new this morning with a fresh SD with Stellarmate.

Here's my error for the second part.
Last edit: 2 years 3 months ago by Doug MacGregor.
2 years 3 months ago #58524
Attachments:
The topic has been locked.
  • Posts: 47
  • Thank you received: 0
if you started a fresh, you need to run the apt again.

because if you read the log, it is saying "libcfitsio" and that is installed by that long line


sudo apt-get -y install libnova-dev libcfitsio-dev libusb-1.0-0-dev zlib1g-dev libgsl-dev build-essential cmake git libjpeg-dev libcurl4-gnutls-dev libtiff-dev libfftw3-dev libftdi-dev libgps-dev libraw-dev libdc1394-22-dev libgphoto2-dev libboost-dev libboost-regex-dev librtlsdr-dev liblimesuite-dev libftdi1-dev libavcodec-dev libavdevice-dev
Last edit: 2 years 3 months ago by Rashed.
2 years 3 months ago #58528
The topic has been locked.
  • Posts: 47
  • Thank you received: 0
sorry my mistake, you did install it after i told you. Apologies


it seems you have not installed indiserver devel.

what is stellamate? does it come with indi-dev stuff? Why are you not using astroberry?

try running
sudo apt install indi-full

you should still run the long line just to double check you got everything.
Last edit: 2 years 3 months ago by Rashed.
2 years 3 months ago #58529
The topic has been locked.
  • Posts: 67
  • Thank you received: 0
Stellarmate is a product running KStars. It is available as a full hardware/software product or just the OS, which I purchased.

I also have AstroBerry on a separate SD card.

Why am I using Stellarmate? No reason. I thought I'd try the "INDI" thing on it first.
I can always do the same thing for Astroberry.

OK, I just did an sudo apt install indi-full and got a couple of errors.

So I did "sudo apt-get update" and then ran "sudo apt install indi-full" and it worked -no errors.

Long line re-ran and no errors.

I'll try the second part again......

Same error on cmake


stellarmate@stellarmate:~/thx8411_sv305/indi-sv305 $ cd build
stellarmate@stellarmate:~/thx8411_sv305/indi-sv305/build $ cmake ../ -DCMAKE_INSTALL_PREFIX=/usr
-- Found CFITSIO: /usr/lib/arm-linux-gnueabihf/libcfitsio.so
CMake Error at /home/stellarmate/thx8411_sv305/cmake_modules/FindINDI.cmake:285 (message):
Could not find INDI include directory
Call Stack (most recent call first):
CMakeLists.txt:13 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/stellarmate/thx8411_sv305/indi-sv305/build/CMakeFiles/CMakeOutput.log".
stellarmate@stellarmate:~/thx8411_sv305/indi-sv305/build $


Web Manager seems to be starting the Driver OK (see attachment).

Then why is Ekos giving me an error? (see attachment)
Last edit: 2 years 3 months ago by Doug MacGregor.
2 years 3 months ago #58530
Attachments:
The topic has been locked.
  • Posts: 47
  • Thank you received: 0
without knowing which version of indi-sv305 is installed in your system, it will not be easy to say. What we can do is do a reinstall of sv305 and take it from there.

can you check what you see when you run this command

ls /usr/include/libindi/*

also do this:

cd <>/indi-sv305/build/
rm * -f
cmake ../ -DINDI_INCLUDE_DIR=/usr/include/libindi -DCMAKE_INSTALL_PREFIX=/usr
Last edit: 2 years 3 months ago by Rashed.
2 years 3 months ago #58534
The topic has been locked.
  • Posts: 67
  • Thank you received: 0
I have whatever version is on GitHub right now.

stellarmate@stellarmate:/usr/include $ ls /usr/include/libindi/*
ls: cannot access '/usr/include/libindi/*': No such file or directory

stellarmate@stellarmate:/usr/include $ cd <>/indi-sv305/build/
bash: /indi-sv305/build/: No such file or directory

I have a build folder in /home/stellarmate/thx8411_sv305/indi-sv305

It contains a CMakeFiles folder and a CMakeCache.txt file both created this morning.

Are these the items you want me to delete?
2 years 3 months ago #58536
The topic has been locked.
The driver has been accepted to INDI 3rd party repository and the primary Ubuntu PPA + StellarMate are now updated and contain the driver. No need to compile directly unless you really need to.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #58541
The topic has been locked.
  • Posts: 67
  • Thank you received: 0
Just got back from a conference.
Should I keep trying to build a driver or can I download the finished one from somewhere.
Thanks.
2 years 3 months ago #58858
The topic has been locked.
I found an issue just now in the PPA build, so it should be available in the PPA in the next couple of hours hopefully.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #58861
The topic has been locked.
  • Posts: 10
  • Thank you received: 0
Was the issue fixed? For those of us who'd built the driver locally, can we now use the 3rd party driver repository? And is that update via regular sudo apt update? (sorry, I've been finishing school and am now back ready to get the SV305 ready as a guider)
Thanks
2 years 2 months ago #59345
The topic has been locked.
  • Posts: 67
  • Thank you received: 0
I am assuming it was, because AstroDMX was just relased for the RPi and it works perfectly with my SV305. I downloaded and installed the 32-bit Debian Installer.
I am still waiting on news for KStars.
Last edit: 2 years 2 months ago by Doug MacGregor.
2 years 2 months ago #59347
The topic has been locked.
Time to create page: 0.579 seconds