×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

INDI Driver for SVBONY cameras

  • Posts: 81
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Dear Thx8411,

I have done different tests to see what results I get ... and nothing in the last one I managed to make images of (and without much success, too).:blink:
In the attached pdf, you will see a table where I have tried to describe what tests I have done.
In the compressed file are the sv305_pro_dump_vN files of each test (where N is the test number or version, which I named).
My dmesg results is like 1-1.3 (connected directly to USB3 port) or 1-1.4.1 (from Hub powered usb3). On "cat " instructions I put "1u" , this is correct, don't you?

I hope it helps you with something ... If I have to clarify something, tell me. Or if some other test needs to be done, too.
I have a raspi4 with 4Gb of ram, astroberry 2.0.3 and I have either connected via VNC (via web) or remotely via PC (Ekos).
Thanks for everything.
I will waiting your news :cheer:

Pep

File Attachment:

File Name: SV305_PRO_dump.tar.gz
File Size:1,506 KB

This browser does not support PDFs. Please download the PDF to view it: Download PDF

1 year 10 months ago #68400
Attachments:
The topic has been locked.
  • Posts: 238
  • Thank you received: 15

Replied by Tom on topic INDI Driver for SVBONY cameras

This is my libsv305 version.

Package: libsv305
Version: 1.6.5
Priority: extra
Section: libs
Maintainer: Blaise-Florentin Collin <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Installed-Size: 2,189 kB
Depends: libc6 (>= 2.9), libgcc1 (>= 1:3.5), libstdc++6 (>= 4.8.1)
Download-Size: 1,407 kB
APT-Manual-Installed: no
APT-Sources: www.astroberry.io/repo buster/main armhf Packages
Description: SDK library for the SVBONY SV305 Camera
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
1 year 10 months ago #68412
The topic has been locked.
  • Posts: 81
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi thx8411,
Good Morning.
I didn't know how to check the version but looking at ekos (INDI-Panel) I can tell you I have versions1.1 interface 6
Now I upgrade the lib and I have 1.6.5 version. Is to say I had just had the before one.
I hope it serves.
Thanks,
Pep
Today I'll try it and tell you what happen.
1 year 10 months ago #68423
The topic has been locked.
  • Posts: 81
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi Thx8411,

I just upgrade the system and works perfectly well.
In VNC mode (web access) and remotely (by Ekos (PC)). The camera is connected directly to the USB3 of the RasPi4 without Power Hub.
In both cases I try to do different exposures (from 0.001s to 60s), videos, guide and works perfect. I check if on 12bits works and works too, but have to much noise (normal, of course).
Now I only need a cloudless sky and check if works guide, in internal mode, from ekos works too.
Thanks a lot Blaise.
I attach the dump files if you will check them. <em>v1C</em> is in VNC mode and <em>v2C</em> is remotely mode.

Thanks again,
Pep

File Attachment:

File Name: sv305pro_d...s.tar.gz
File Size:700 KB
Last edit: 1 year 10 months ago by Pep.
1 year 10 months ago #68438
Attachments:
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
Hi !

@Pep : Glad to know the camera is working for you now.
@Pep and Tom : Thanks for your investment !

Please let me know of you have other issues.

Have a clear sky !

Thx8411
1 year 10 months ago #68486
The topic has been locked.
  • Posts: 81
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi Thx8411,

Thank you. You are a master ... (we will leave the universe for other occasions ).
Thank you so much for the work you have done and the dedication you had put into it.
(By the way, only one thing: the minimum time of the camera is 0.001s but in Ekos you have to set it manually, if you put the minimum with the arrows to go up and down the value continue only accepting 0.01s. Hey! but it do the pictures of 0.001s if you put the value manualy, therefore OK)
I insist, Thank you very much,

CLEAR and GOOD SKIES.
Pep
1 year 10 months ago #68499
The topic has been locked.
  • Posts: 47
  • Thank you received: 0
HI Thx8411

Have you noticed that the frames there is 1 frame lag between when you capture using PHD2? i.e. the frame being presented by the driver after nth exposure is actually what was taken during the (n-1)th exposure?

I noticed it before after optimizing my mount to remove DE backlash the impact it has on calibration data is throwing off my guiding.

Cheers
1 year 9 months ago #70556
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
Hi Rashed,

Sorry for this late, late, late answer...

Are you sure you are using the last driver ?

I had this issue with the very first SDK. (CKCameraSDK). I had to systematically drop the first frame. The first versions of the new SDK (SVBCamera) mostly fixed this issue, with sometime a junk frame.
I didn't notice this issue with last SDK anymore.

I don't use PHD2, but the Ekos internal guider. It works great for me. Did you notice the same issue with the Ekos guider ?

Best regards,

Thx8411

 
Last edit: 1 year 6 months ago by Collin.
1 year 6 months ago #72989
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
Hi folks !

SVBony just released a new camera : The SV305 Pro M, an SV305 Pro with a mono sensor.
I asked SVBony to send me the last SDK,
I wish to upgrade the indi driver to support this new camera soon.

Are any of you planning to buy this camera ? I will need some beta testers ;-)

Best regards !

Thx8411
 
The following user(s) said Thank You: giorgio
1 year 6 months ago #72993
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
SVBony is also working on a deep sky cooled camera, the SV405C, with an IMX533 color sensor.
If this camera has the same value for money than the SV305, I think I will buy it (and support it also ;-))

Best regards !

Thx8411
1 year 6 months ago #72994
The topic has been locked.
  • Posts: 3
  • Thank you received: 0
Hi,I hope I am ok posting to this thread rather than creating a new one…..I have a Pi4 running ubuntu 32-bit configured with the AstroPiMaker4 script.Connected to it is a SV305 PRO.Initially it didn’t work, but I found this very thread and upgraded libsv305 to 1.6.5 from the nightly repo.So I can connect via ekos and take pictures. However, all the pictures are greyscale and pixellated - I can reproduce this in sharpcap on a windows box by selecting one of the RAW formats.  If I select RGB24 there the pictures are in colour and fine.BUT in the ekos configuration window, I can only select Raw 12 bits or Raw 8 bits for the Frame Format. Am I overlooking a setting somewhere? Thanks!
1 year 6 months ago #73151
The topic has been locked.
  • Posts: 3
  • Thank you received: 0
Hi,

I hope I am ok posting to this thread rather than creating a new one…..

I have a Pi4 running ubuntu 32-bit configured with the AstroPiMaker4 script.
Connected to it is a SV305 PRO.

Initially it didn’t work, but I found this very thread and upgraded libsv305 to 1.6.5 from the nightly repo.

So I can connect via ekos and take pictures.

However, all the pictures are greyscale and pixellated - I can reproduce this in sharpcap on a windows box by selecting one of the RAW formats. If I select RGB24 there the pictures are in colour and fine.

BUT in the ekos configuration window, I can only select Raw 12 bits or Raw 8 bits for the Frame Format.

Am I overlooking a setting somewhere?

Thanks!
1 year 6 months ago #73152
The topic has been locked.
Time to create page: 0.617 seconds