×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

INDI Driver for SVBONY cameras

  • Posts: 3
  • Thank you received: 0
OK, I've found I need to debayer the images, so not a problem with the driver or ekos etc.

Going back to learn some more.... :)
1 year 5 months ago #73184
The topic has been locked.
  • Posts: 1
  • Thank you received: 0
Hello everyone, If I've read the thread correctly, this driver is for the SV305, I own an SV105 that I would like to try as a guide camera for my widefield astrophoto setup, and was wondering if this driver could also work for me. I've tried using both the INDI webcam and V4L2 drivers via ekos in kstars, but none work, as the camera is only able to take a single exposure before not responding again. I figured this thread is the right place to ask, so if anyone has any experience with this little cam I'd be helpful for any tips !!.
1 year 4 months ago #74169
The topic has been locked.
  • Posts: 120
  • Thank you received: 16
Will this driver work also with SV305M Pro camera?
1 year 3 months ago #74553
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
@Alvaro

Hello,

Sorry, but the SV105 and SV205 are totaly different devices. They should act as usual UVC devices, but I don't own any of it.

Best regards

Thx8411
1 year 3 months ago #74676
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
@HADES

Hello,

I'm working on it. Not a big deal, in facts, the actual driver should work, except that the bayer matrix reported in the FITS fields should be wrong.
I'm waiting for informations from SVBony to properly identify the camera and set the good color/mono pattern.

Do you allready own a SV305M Pro ? In this case, you can allready give a try to the actual driver, and report me the results.
It would help me a lot.
If it doesn't work, you may try with the "work in progress" driver in my repo :

github.com/thx8411/indi-3rdparty

It includes the last SVBony libraries, supporting the SV305M Pro

Best regards,

Thx8411



 
Last edit: 1 year 3 months ago by Collin.
1 year 3 months ago #74677
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
@all

Hi folks !

I pushed to my repo the last SVBony libraries (v1.4.2):

github.com/thx8411/indi-3rdparty

Tested on my rig, it seems to work.

Could some of you test it on their one rig, to avoid regressions before submitting a pull resquest ?

Thanks and best regards !

Thx8411

 
1 year 3 months ago #74678
The topic has been locked.
  • Posts: 120
  • Thank you received: 16
Hi Collin, thank you for reply. I don't own this camera yet, but I would like to buy one and INDI support is critical for me. So if you think that it will work, I can order the camera and try your driver.
1 year 3 months ago #74679
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
@HADES

Hello !

I just pushed a new commit to my repo, disabling the HAS_BAYER capability for the SV305M Pro.
It deserves some cleaning (bayer matrix offsets and white balance/saturation settings are a non sens and should by removed), but I hope it could work "as is".

Best regards,

Thx841
 
1 year 3 months ago #74744
The topic has been locked.
  • Posts: 8
  • Thank you received: 0

Replied by Toby on topic INDI Driver for SVBONY cameras

Can anybody tell me if the SVBONY 305 driver can work on osx?

I'm trying to use the SVBONY 305 with KSTARS on mac osx 10.15.17 .

When I select it in EKOS and try to connect I get this message:Driver indi_sv305_ccd was not found on the system. Please make sure the package that provides the 'indi_sv305_ccd' binary is installed.

I've been going around in circles a bit.

If anybody could provide some pointers or advice. I'd be very grateful.

 
1 year 3 months ago #75115
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
Hi Toby,

In december 2020, SVBony sent me a MacOS version of the SDK :

<<  This is the first version SDK for Mac OS. I know it not that perfect. >>
I haven't received any update since.
I haven't developed on MacOs for 15 years, and I don't own an Apple device.
I don't know how to handle the platform detection, the packaging, etc.

If an INDI/MacOS experienced developer could help me, it would be great.

Best regards,

Thx8411
 
 
1 year 3 months ago #75148
The topic has been locked.
  • Posts: 2
  • Thank you received: 0
I'm trying to use the SVBONY 305 pro camera for guiding i Kstars, using the stellarmate on a raspberry pi. Not having great succes. There is a lot of "noise" in the picture compared to pictures taken with the same camera in a different program, eg. SharpCap. When I check the list with supported cameras in ekos, sv305 camera is listed but not the sv305 pro version. I think it could be a problem with the driver. Does anyone know if there is an updated driver or there might be one on the way. I have taken 5 darks with an exposure time between 1 and 5 seconds, gain 200 and bin 1x1. If anyone can use the pictures for something, they are attached as zip file. The attached image is preview of one dark frame in kstars.


 
1 year 3 months ago #75215
Attachments:
The topic has been locked.
  • Posts: 149
  • Thank you received: 31
Hi casper,

There is only one driver, the SV305, supporting both SV305 and SV305PRO (and perhaps the SV305M PRO, not tested yet).

Did you test with other softwares on your raspberry ?

Having strong black and white pixels on your darks is usual. The dynamic is stretched by the viewer.

Look at your histogram, you darks are... dark ;-)

But you have a lot of banding in your picture. This is usually a power supply issue
Do you have a strong and stable power supply on you raspberry ?

Best regards,

Thx8411
1 year 3 months ago #75230
Attachments:
The topic has been locked.
Time to create page: 0.816 seconds