I found libstellarsolver.so.2.2 in /usr/local/lib. No conflicting versions to be found in /usr/lib.
Although the version found in /usr.local/lib is a couple days old, from just before I performed the inplace upgrade. I should probably delete it and re-try. Thank you.

Read More...