I will test the values tomorrow and give you feedback afterwards. You are right the Max Value of 6 Seconds seems to be only available in the still mode. The video mode seems to need at least 1 second. But I may try to change the value in the bcm driver - because i really need at least 3 seconds to be able to see any stars for autoguiding with my set up.


With that the option is here - see also the Screenshot that I have attached.

So first I have to say thank you at least 1000 times :)

There is just one more issure: The maximum exposure time seems to be 10000 (may be 1 second) but the Rasperry Pi Camera supports up to 6 seconds. On the first page I can enter different values for "Expose" but they seem to make no real change. On The V4L2 Control Tab is also a value where you can enter times up to 10 000 (see also my second attached screenshot). That's acutally pretty bad because even ISO 800 and 1 Second may not be enough for some needs of Astronomy.

That value may come directly from V4L2 because that L readout gives me also:
exposure_time_absolute (int) : min=1 max=10000 step=1 default=1000 value=10000

There was also a thread about the problem (but only one entry) which also had the idea that the problem may be V4L2 related (what might be pretty bad I thing).


Ps: Thanks for developing the solution !


geehalel wrote: Ok I made a mistake in the integer menu item names, could you try again ?
And also have a look at the driver output as you did in your preceding post (when you circle in red its output).

I have reinstalled it on the VM and on the Raspberry Pi but the same problem either - can't see any new options to controle the ISO. I have also attached the log file for the driver (on the raspberry pi).


Yes they are.

iso_sensitivity (intmenu): min=0 max=4 default=0 value=0
                                0: 0 (0x0)
                                1: 100000 (0x186a0)
                                2: 200000 (0x30d40)
                                3: 400000 (0x61a80)
                                4: 800000 (0xc3500)
           iso_sensitivity_auto (menu)   : min=0 max=1 default=1 value=1
                                0: Manual
                                1: Auto

I also attached there KStars Log-File.


I actually tested it. What i have done was downloaded it from your fork. And installed it afterwards. On my virtual machine and on the raspberry pi. But I have not found any new options for the ISO Setting.

I have already opened an issue about the problem on github.

If I should try something else just tell me or if you need remote access to an raspberry pi with atached camera - i think that would be manageable.


3.5 might be the Version. I have found it right here: https://linuxtv.org/downloads/v4l-dvb-apis/uapi/v4l/hist-v4l2.html#v4l2-in-linux-3-5

I don't know anything about C++ oder C Programming so I don't think I can fix the problem either.


Dominik Laa replied to the topic 'raspberry pi NoIR camera board' in the forum. 6 years ago

I have actually the same problem with the pi NoIR Camera Module (v2). With other applications it's possible to controll everything but there seems to be an bug in the indi driver. I have not found an solution yet - maybe anyone else has in idea ?

Some values seem to work for me but it's behaving a little bit strange.

Thanks and advance,